aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2013-11-06 02:34:22 +0800
committerrakuco <rakuco@FreeBSD.org>2013-11-06 02:34:22 +0800
commit905304d05f3b7a9a489cd782748daf74e8d882e1 (patch)
treef32ee7b1238a5be5178c342fb367d0842295aaf9 /cad
parentc863663a01f64ec3981c680ae99e6365fc7485fa (diff)
downloadfreebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.tar.gz
freebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.tar.zst
freebsd-ports-gnome-905304d05f3b7a9a489cd782748daf74e8d882e1.zip
Welcome CMake 2.8.12!
With contributions from Schaich Alonso <alonsoschaich@fastmail.fm>, including stage support for devel/cmake-gui. This update took much longer than expected due to CMake changing the arguments to an internal macro that ended up being used by some ports: http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=9ce60ff5 I have also started a discussion about this on CMake's development list: http://article.gmane.org/gmane.comp.programming.tools.cmake.devel/8464 It required adjusting the affected ports, and these changes have approved by portmgr (bdrewery). PR: ports/182981 Approved by: portmgr (bdrewery)
Diffstat (limited to 'cad')
-rw-r--r--cad/brlcad/files/patch-cmake_2.8.1281
-rw-r--r--cad/brlcad/files/patch-src__other__CMakeLists.txt16
2 files changed, 97 insertions, 0 deletions
diff --git a/cad/brlcad/files/patch-cmake_2.8.12 b/cad/brlcad/files/patch-cmake_2.8.12
new file mode 100644
index 000000000000..80dc224952ad
--- /dev/null
+++ b/cad/brlcad/files/patch-cmake_2.8.12
@@ -0,0 +1,81 @@
+------------------------------------------------------------------------
+r57006 | starseeker | 2013-08-21 04:30:27 +0300 (Wed, 21 Aug 2013) | 1 line
+
+Latest CMake spotted a syntax error.
+
+------------------------------------------------------------------------
+r57007 | starseeker | 2013-08-21 04:40:51 +0300 (Wed, 21 Aug 2013) | 1 line
+
+More string formatting gotchas caught by 2.8.12rc1 CMake
+
+------------------------------------------------------------------------
+Index: src/other/tk/CMake/tcl.cmake
+===================================================================
+--- src/other/tk/CMake/tcl.cmake (revision 57006)
++++ src/other/tk/CMake/tcl.cmake (revision 57007)
+@@ -959,8 +959,8 @@
+ ENDMACRO(CHECK_FD_SET_IN_TYPES_D)
+
+ MACRO(CHECK_COMPILER_SUPPORTS_HIDDEN_D)
+- SET(TEST_SRC"
+- #define MODULE_SCOPE extern __attribute__((__visibility__("hidden")))
++ SET(TEST_SRC "
++ #define MODULE_SCOPE extern __attribute__((__visibility__(\"hidden\")))
+ main(){};
+ ")
+ CHECK_C_SOURCE_COMPILES("${TEST_SRC}" COMPILER_SUPPORTS_HIDDEN)
+Index: src/other/tcl/CMake/tcl.cmake
+===================================================================
+--- src/other/tcl/CMake/tcl.cmake (revision 57006)
++++ src/other/tcl/CMake/tcl.cmake (revision 57007)
+@@ -959,8 +959,8 @@
+ ENDMACRO(CHECK_FD_SET_IN_TYPES_D)
+
+ MACRO(CHECK_COMPILER_SUPPORTS_HIDDEN_D)
+- SET(TEST_SRC"
+- #define MODULE_SCOPE extern __attribute__((__visibility__("hidden")))
++ SET(TEST_SRC "
++ #define MODULE_SCOPE extern __attribute__((__visibility__(\"hidden\")))
+ main(){};
+ ")
+ CHECK_C_SOURCE_COMPILES("${TEST_SRC}" COMPILER_SUPPORTS_HIDDEN)
+Index: misc/CMake/FindTCL.cmake
+===================================================================
+--- misc/CMake/FindTCL.cmake (revision 57006)
++++ misc/CMake/FindTCL.cmake (revision 57007)
+@@ -307,7 +307,7 @@
+
+
+ # Set up the logic for determining if a particular Tcl is compiled threaded.
+-set(tclthreaded_script"
++set(tclthreaded_script "
+ set filename \"${CMAKE_BINARY_DIR}/CMakeTmp/TCL_THREADED\"
+ set fileId [open $filename \"w\"]
+ if {[info exists tcl_platform(threaded)]} {puts $fileId 1}
+Index: INSTALL
+===================================================================
+--- INSTALL (revision 57005)
++++ INSTALL (revision 57006)
+@@ -374,7 +374,7 @@
+ Disabling the run-time debugging facilities can provide a significant
+ (10%-30%) performance boost at the expense of extensive error
+ checking (that in turn help prevent corruption of your data).
+-Default is ;ON;, and should only be disabled for read-only render
++Default is "ON", and should only be disabled for read-only render
+ work where performance is critical.
+
+ Aliases: ENABLE_RUNTIME_DEBUG, ENABLE_RUN_TIME_DEBUG, ENABLE_RUNTIME_DEBUGGING
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 57005)
++++ CMakeLists.txt (revision 57006)
+@@ -1121,7 +1121,7 @@
+ Disabling the run-time debugging facilities can provide a significant
+ (10%-30%) performance boost at the expense of extensive error
+ checking (that in turn help prevent corruption of your data).
+-Default is "ON", and should only be disabled for read-only render
++Default is \"ON\", and should only be disabled for read-only render
+ work where performance is critical.
+ ")
+ BRLCAD_OPTION(ON BRLCAD_ENABLE_RUNTIME_DEBUG BRLCAD_ENABLE_RUNTIME_DEBUG_ALIASES BRLCAD_ENABLE_RUNTIME_DEBUG_DESCRIPTION)
+
diff --git a/cad/brlcad/files/patch-src__other__CMakeLists.txt b/cad/brlcad/files/patch-src__other__CMakeLists.txt
new file mode 100644
index 000000000000..1cf975504184
--- /dev/null
+++ b/cad/brlcad/files/patch-src__other__CMakeLists.txt
@@ -0,0 +1,16 @@
+Fixes a build failure with CMake 2.8.12.
+
+Discussed in http://article.gmane.org/gmane.comp.cad.brlcad.devel/3782
+
+Index: src/other/CMakeLists.txt
+===================================================================
+--- src/other/CMakeLists.txt (revision 58323)
++++ src/other/CMakeLists.txt (working copy)
+@@ -390,6 +390,7 @@
+ # PNG_INCLUDE_DIR, so a generic macro won't pick up the setting -
+ # handle it here.
+
++ set(PNG_LIBRARY "${PNG_LIBRARY}" CACHE STRING "PNG library" FORCE)
+ set(PNG_INCLUDE_DIR ${PNG_PNG_INCLUDE_DIR} CACHE STRING "PNG include directory" FORCE)
+ endif(BRLCAD_PNG_BUILD)
+ DISTCLEAN(${CMAKE_CURRENT_BINARY_DIR}/libpng/CTestTestfile.cmake)