aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-02-08 19:16:36 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-02-08 19:16:36 +0800
commit9a7ca6aad722b6437c82619de9361d75943c53de (patch)
treeacdb6c2576eccf8871653279ea5f3a700a07a89a /cad
parent14493deed4d1182a309746db7dac6909bbf0503c (diff)
downloadfreebsd-ports-gnome-9a7ca6aad722b6437c82619de9361d75943c53de.tar.gz
freebsd-ports-gnome-9a7ca6aad722b6437c82619de9361d75943c53de.tar.zst
freebsd-ports-gnome-9a7ca6aad722b6437c82619de9361d75943c53de.zip
- Fix build with boost 1.60
- Fix LICENSE PR: 199601 Approved by: portmgr blanket
Diffstat (limited to 'cad')
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--cad/openscad/files/patch-src_colormap.h14
-rw-r--r--cad/openscad/files/patch-src_scintillaeditor.h14
3 files changed, 29 insertions, 1 deletions
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 1095e169f1ae..f9bc0c0e4a58 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -11,7 +11,7 @@ DISTNAME= openscad-${PORTVERSION}.src
MAINTAINER= mr@FreeBSD.org
COMMENT= Programmer's solid 3D CAD modeller
-LICENSE= GPLv2
+LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
diff --git a/cad/openscad/files/patch-src_colormap.h b/cad/openscad/files/patch-src_colormap.h
new file mode 100644
index 000000000000..7acadcfad624
--- /dev/null
+++ b/cad/openscad/files/patch-src_colormap.h
@@ -0,0 +1,14 @@
+--- src/colormap.h.orig 2015-03-05 16:25:10 UTC
++++ src/colormap.h
+@@ -5,9 +5,11 @@
+ #include <list>
+ #include "linalg.h"
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
+ #include <boost/filesystem.hpp>
+ #include <boost/property_tree/ptree.hpp>
++#endif
+
+ namespace fs = boost::filesystem;
+
diff --git a/cad/openscad/files/patch-src_scintillaeditor.h b/cad/openscad/files/patch-src_scintillaeditor.h
new file mode 100644
index 000000000000..871562905778
--- /dev/null
+++ b/cad/openscad/files/patch-src_scintillaeditor.h
@@ -0,0 +1,14 @@
+--- src/scintillaeditor.h.orig 2015-03-05 20:25:13 UTC
++++ src/scintillaeditor.h
+@@ -11,9 +11,11 @@
+ #include "scadlexer.h"
+ #include "parsersettings.h"
+
++#ifndef Q_MOC_RUN
+ #include <boost/shared_ptr.hpp>
+ #include <boost/property_tree/ptree.hpp>
+ #include <boost/property_tree/json_parser.hpp>
++#endif
+
+ class EditorColorScheme
+ {