aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-05-06 04:47:22 +0800
committerrakuco <rakuco@FreeBSD.org>2014-05-06 04:47:22 +0800
commitf42b5431e9f9d7047c4b854d2a8834d8899d3553 (patch)
tree2015cfd3cef2d1e1dc4c19e9e7c48b34e3510de3 /cad
parent1b4cc3ea3738568cd4efa8cc088bee2cbeeab9f0 (diff)
downloadfreebsd-ports-gnome-f42b5431e9f9d7047c4b854d2a8834d8899d3553.tar.gz
freebsd-ports-gnome-f42b5431e9f9d7047c4b854d2a8834d8899d3553.tar.zst
freebsd-ports-gnome-f42b5431e9f9d7047c4b854d2a8834d8899d3553.zip
The KDE on FreeBSD team presents Qt 4.8.6.
This is a minor bugfix release that fortunately contains quite a few patches that we have upstreamed in the past months. See http://blog.qt.digia.com/blog/2014/04/24/qt-4-8-6-released/ for a summary of changes, and http://download.qt-project.org/official_releases/qt/4.8/4.8.6/changes-4.8.6 for a detailed list of changes. This patch contains commits by me, makc@ and Schaich Alonso. PR: ports/189213
Diffstat (limited to 'cad')
-rw-r--r--cad/qcad/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 21685d283bb5..8d4400b1d5fb 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -54,6 +54,13 @@ pre-configure:
${REINPLACE_CMD} -e "s|%%DATADIR%%|${DATADIR}|" \
${WRKSRC}/src/core/RSettings.cpp
+# Temporary hack for Qt 4.8.6 support while upstream does not add proper
+# bindings.
+ (cd ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-4.8.5 && \
+ ${COPYTREE_SHARE} . ../qt-labs-qtscriptgenerator-4.8.6)
+ (cd ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-4.8.6 && \
+ mv qt-labs-qtscriptgenerator-4.8.5.pro qt-labs-qtscriptgenerator-4.8.6.pro)
+
do-install:
${INSTALL_PROGRAM} ${RESDIR}/qcad-bin ${STAGEDIR}${PREFIX}/bin/
${LN} -sf ${PREFIX}/bin/qcad-bin ${STAGEDIR}${PREFIX}/bin/qcad