aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/BBMan
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-12-12 05:53:12 +0800
committerkris <kris@FreeBSD.org>2004-12-12 05:53:12 +0800
commit8500944d0ba48ae2f47e8abd2c0032763fb71c9a (patch)
treecd4baf80f0acb8ea2880233d0db2dbc66888ccac /chinese/BBMan
parent418c89b2c6c4e9df7d245a2f1d1ecf75e0698117 (diff)
downloadfreebsd-ports-gnome-8500944d0ba48ae2f47e8abd2c0032763fb71c9a.tar.gz
freebsd-ports-gnome-8500944d0ba48ae2f47e8abd2c0032763fb71c9a.tar.zst
freebsd-ports-gnome-8500944d0ba48ae2f47e8abd2c0032763fb71c9a.zip
BROKEN on 4.x: Does not link
BROKEN on ia64: Hard-codes reference to libc_r
Diffstat (limited to 'chinese/BBMan')
-rw-r--r--chinese/BBMan/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/chinese/BBMan/Makefile b/chinese/BBMan/Makefile
index 6960259cd272..56dde3016b63 100644
--- a/chinese/BBMan/Makefile
+++ b/chinese/BBMan/Makefile
@@ -26,10 +26,20 @@ USE_GCC= 3.3
PLIST_FULES= bin/BBMan
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not link on FreeBSD 4.x"
+.endif
+
+.if ${ARCH} == ia64
+BROKEN= "Hard-codes reference to libc_r"
+.endif
+
do-build:
cd ${WRKSRC} && ${CXX} main.cpp `wxgtk2-2.4-config --libs --cxxflags` -I${LOCALBASE}/include ${CFLAGS} -o BBMan
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/BBMan ${PREFIX}/bin/BBMan
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>