aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/arphicttf/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-12-22 02:48:37 +0800
committerijliao <ijliao@FreeBSD.org>2002-12-22 02:48:37 +0800
commit2d7c45feda182368287c36d5036b62c449db2029 (patch)
tree257f8c0e9eae485317784d302d3ae3567c274545 /chinese/arphicttf/Makefile
parent9f6b177a00636bbe669f6ad210b50d6c78961820 (diff)
downloadfreebsd-ports-gnome-2d7c45feda182368287c36d5036b62c449db2029.tar.gz
freebsd-ports-gnome-2d7c45feda182368287c36d5036b62c449db2029.tar.zst
freebsd-ports-gnome-2d7c45feda182368287c36d5036b62c449db2029.zip
due to ttfm module ghostscript6 change to gscjk
PR: 42330 Submitted by: Statue <statue@freebsd.sinica.edu.tw>
Diffstat (limited to 'chinese/arphicttf/Makefile')
-rw-r--r--chinese/arphicttf/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/chinese/arphicttf/Makefile b/chinese/arphicttf/Makefile
index 78d8b4292741..f064fa5d4d0c 100644
--- a/chinese/arphicttf/Makefile
+++ b/chinese/arphicttf/Makefile
@@ -23,7 +23,7 @@ USE_XLIB= yes
FONTDIR= ${PREFIX}/share/fonts/TrueType
XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
INSTALL_ENV= PKG_PREFIX=${PREFIX} XFREE86_VERSION=${XFREE86_VERSION} \
- WANT_CJK=${WANT_CJK} WANT_GS6=${WANT_GS6} \
+ WANT_CJK=${WANT_CJK} WANT_GS=${WANT_GS} \
WITHOUT_X=${WITHOUT_X}
.include <bsd.port.pre.mk>
@@ -31,8 +31,8 @@ INSTALL_ENV= PKG_PREFIX=${PREFIX} XFREE86_VERSION=${XFREE86_VERSION} \
.if defined(WANT_CJK)
RUN_DEPENDS+= bg5latex:${PORTSDIR}/chinese/CJK
.endif
-.if defined(WANT_GS6)
-RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/CJK/CMap/B5pc-H:${PORTSDIR}/chinese/ghostscript6
+.if defined(WANT_GS)
+RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
.endif
.if ${XFREE86_VERSION} == 3 && !defined(WITHOUT_X)
RUN_DEPENDS+= mkfontdir.pl:${PORTSDIR}/x11-servers/XttXF86srv-common
@@ -42,16 +42,16 @@ pre-fetch:
.if defined(WANT_CJK)
@${ECHO} "CJK support will be added."
.endif
-.if defined(WANT_GS6)
- @${ECHO} "Ghostscript6 support will be added."
+.if defined(WANT_GS)
+ @${ECHO} "Ghostscript support will be added."
.endif
.if defined(WITHOUT_X)
@${ECHO} "X Window support will NOT be added."
.endif
-.if !defined(WANT_CJK) && !defined(WANT_GS6) && !defined(WITHOUT_X)
+.if !defined(WANT_CJK) && !defined(WANT_GS) && !defined(WITHOUT_X)
@${ECHO} --
@${ECHO} "Type \"make WANT_CJK=yes\" if you want CJK support."
- @${ECHO} "Type \"make WANT_GS6=yes\" if you want Ghostscript6 support."
+ @${ECHO} "Type \"make WANT_GS=yes\" if you want Ghostscript support."
@${ECHO} "Type \"make WITHOUT_X=yes\" if you DONT want X Window support."
@${ECHO} "You can use them in combinations."
@${ECHO} --