aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/autoconvert
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-05-15 11:06:04 +0800
committerijliao <ijliao@FreeBSD.org>2003-05-15 11:06:04 +0800
commitd1e555cc1a9cd18e5e1292425d4d661a7db3d9b3 (patch)
tree94727b99188dc83f9e549773d32f417ac7c0150a /chinese/autoconvert
parent90347a120dd565ee4e654a0e1a34ad630d29ca35 (diff)
downloadfreebsd-ports-gnome-d1e555cc1a9cd18e5e1292425d4d661a7db3d9b3.tar.gz
freebsd-ports-gnome-d1e555cc1a9cd18e5e1292425d4d661a7db3d9b3.tar.zst
freebsd-ports-gnome-d1e555cc1a9cd18e5e1292425d4d661a7db3d9b3.zip
utilize USE_GETOPT_LONG and DATADIR
Approved by: maintainer
Diffstat (limited to 'chinese/autoconvert')
-rw-r--r--chinese/autoconvert/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index b3c60dae616d..01f4c8747d58 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -13,14 +13,14 @@ MASTER_SITES= http://people.debian.org/~ygh/
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= Intelligent Chinese encoding converter
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG= yes
INSTALLS_SHLIB= yes
+DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}-${PORTNAME}
pre-install:
- @${MKDIR} ${PREFIX}/share/zh-autoconvert
+ @${MKDIR} ${DATADIR}
.for i in ChangeLog LICENSE Readme TODO Thanks Version hz.txt procmailrc.example shed.big5 shed.gb shed.uni shed.utf7 shed.utf8
- @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/zh-autoconvert
+ @${INSTALL_DATA} ${WRKSRC}/$i ${DATADIR}
.endfor
.include <bsd.port.mk>