aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/cmexfonts/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-07-30 13:52:39 +0800
committerclive <clive@FreeBSD.org>2001-07-30 13:52:39 +0800
commitf71c6f8e74263ac1fb40de509c8ed98a541404f6 (patch)
tree71e450faac19b2409804bbba995e6233f3053e38 /chinese/cmexfonts/Makefile
parent7b6ad84d51d8b3f44dacef71654928722e0d19e7 (diff)
downloadfreebsd-ports-gnome-f71c6f8e74263ac1fb40de509c8ed98a541404f6.tar.gz
freebsd-ports-gnome-f71c6f8e74263ac1fb40de509c8ed98a541404f6.tar.zst
freebsd-ports-gnome-f71c6f8e74263ac1fb40de509c8ed98a541404f6.zip
This package contains the standard Big5+ Chinese Ming 24x24 bitmap font (and
a resized 16x16 bitmap font) by CMEX and DynaLab for the X Window System (PCF). This is one of the few Big5 or Big5+ Chinese bitmap fonts on the Internet that is DFSG-compliant. The font was designed by DynaLab and released by CMEX as part of the proposed Big5+ standard documentation. It was then converted to HBF and BDF format and further modified by Wei-Lun Chao in September 1998. Submitted by: statue@freebsd.sinica.edu.tw Handed to me via: keichii
Diffstat (limited to 'chinese/cmexfonts/Makefile')
-rw-r--r--chinese/cmexfonts/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/chinese/cmexfonts/Makefile b/chinese/cmexfonts/Makefile
new file mode 100644
index 000000000000..dffdbd1c2d27
--- /dev/null
+++ b/chinese/cmexfonts/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: cmexfonts
+# Date created: 10 Mar 2001
+# Whom: Shen Chuan-Hsing
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmexfonts
+PORTVERSION= 0.1
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= http://freebsd.sinica.edu.tw/~statue/ \
+ ftp://sunsite.unc.edu/pub/Linux/X11/fonts/
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${XFREE86_VERSION} == 4
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11/XFree86-4-clients
+RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11/XFree86-4-clients
+.endif
+
+WRKSRC= ${WRKDIR}/cmexfonts
+
+post-install:
+ @${SETENV} ${INSTALL_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>