aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/fcitx
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-11-14 17:12:38 +0800
committerpav <pav@FreeBSD.org>2011-11-14 17:12:38 +0800
commit137ac30a2375e2a2c2ee9f1b85ac0a0b79e670e7 (patch)
tree589d32ca81d0a7026bce7933186b9d953e94d4f0 /chinese/fcitx
parent8f5485ed22b3c37d9d7ebb5bef03d9f136ce0f62 (diff)
downloadfreebsd-ports-gnome-137ac30a2375e2a2c2ee9f1b85ac0a0b79e670e7.tar.gz
freebsd-ports-gnome-137ac30a2375e2a2c2ee9f1b85ac0a0b79e670e7.tar.zst
freebsd-ports-gnome-137ac30a2375e2a2c2ee9f1b85ac0a0b79e670e7.zip
- Unbreak on 7.X
Submitted by: maintainer Feature safe: yes
Diffstat (limited to 'chinese/fcitx')
-rw-r--r--chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c7
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt8
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt8
-rw-r--r--chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt8
-rw-r--r--chinese/fcitx/pkg-plist6
5 files changed, 16 insertions, 21 deletions
diff --git a/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c
index 8002d5242e70..cf1b1dc91236 100644
--- a/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c
+++ b/chinese/fcitx/files/getline-src_lib_fcitx-utils_utils.c
@@ -1,9 +1,10 @@
---- ./src/lib/fcitx-utils/utils.c.orig 2011-10-02 05:43:11.000000000 -0500
-+++ ./src/lib/fcitx-utils/utils.c 2011-11-09 21:15:42.497306506 -0600
-@@ -249,4 +249,21 @@ char* fcitx_get_process_name()
+--- src/lib/fcitx-utils/utils.c.orig 2011-10-02 05:43:11.000000000 -0500
++++ src/lib/fcitx-utils/utils.c 2011-11-13 16:32:39.627873790 -0600
+@@ -249,4 +249,22 @@ char* fcitx_get_process_name()
#endif
}
++FCITX_EXPORT_API
+ssize_t getline(char ** p, size_t * cap, FILE * fp) {
+ ssize_t l;
+ if (!*cap && (*p = malloc(128))) *cap = 128;
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
index c03db3d89338..cf509d11eaae 100644
--- a/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
+++ b/chinese/fcitx/files/patch-src_lib_fcitx-config_CMakeLists.txt
@@ -1,12 +1,10 @@
--- src/lib/fcitx-config/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
-+++ src/lib/fcitx-config/CMakeLists.txt 2011-11-09 23:47:47.999482381 -0600
-@@ -14,8 +14,8 @@ set(FCITX_CONFIG_HEADERS
- add_library(fcitx-config SHARED ${FCITX_CONFIG_SOURCES})
++++ src/lib/fcitx-config/CMakeLists.txt 2011-11-13 16:02:26.681232301 -0600
+@@ -15,7 +15,7 @@ add_library(fcitx-config SHARED ${FCITX_
target_link_libraries(fcitx-config fcitx-utils)
set_target_properties(fcitx-config
-- PROPERTIES VERSION 4.1.0
+ PROPERTIES VERSION 4.1.0
- SOVERSION 4.1
-+ PROPERTIES VERSION 4.1
+ SOVERSION 4
COMPILE_FLAGS "-fvisibility=hidden"
LINK_FLAGS "-Wl,--no-undefined"
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
index 824c74001d86..48bfd69e9629 100644
--- a/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
+++ b/chinese/fcitx/files/patch-src_lib_fcitx-utils_CMakeLists.txt
@@ -1,12 +1,10 @@
--- src/lib/fcitx-utils/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
-+++ src/lib/fcitx-utils/CMakeLists.txt 2011-11-09 23:48:04.469816075 -0600
-@@ -20,8 +20,8 @@ endif (LIBKVM_FOUND)
-
++++ src/lib/fcitx-utils/CMakeLists.txt 2011-11-13 16:02:51.201489333 -0600
+@@ -21,7 +21,7 @@ endif (LIBKVM_FOUND)
add_library(fcitx-utils SHARED ${FCITX_UTILS_SOURCES})
set_target_properties(fcitx-utils
-- PROPERTIES VERSION 0.1.0
+ PROPERTIES VERSION 0.1.0
- SOVERSION 0.1
-+ PROPERTIES VERSION 0.1
+ SOVERSION 0
COMPILE_FLAGS "-fvisibility=hidden"
LINK_FLAGS "-Wl,--no-undefined"
diff --git a/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt b/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
index cd565a7955cd..471685706b9b 100644
--- a/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
+++ b/chinese/fcitx/files/patch-src_lib_fcitx_CMakeLists.txt
@@ -1,12 +1,10 @@
--- src/lib/fcitx/CMakeLists.txt.orig 2011-10-02 05:43:11.000000000 -0500
-+++ src/lib/fcitx/CMakeLists.txt 2011-11-09 23:45:35.930811384 -0600
-@@ -31,8 +31,8 @@ link_directories(${DL_LIBRARY_DIRS} ${PT
-
++++ src/lib/fcitx/CMakeLists.txt 2011-11-13 16:01:32.246665458 -0600
+@@ -32,7 +32,7 @@ link_directories(${DL_LIBRARY_DIRS} ${PT
add_library(fcitx-core SHARED ${LIBFCITX_SOURCES})
set_target_properties(fcitx-core
-- PROPERTIES VERSION 0.2.0
+ PROPERTIES VERSION 0.2.0
- SOVERSION 0.2
-+ PROPERTIES VERSION 0.2
+ SOVERSION 0
COMPILE_FLAGS "-fvisibility=hidden"
LINK_FLAGS "-Wl,--no-undefined"
diff --git a/chinese/fcitx/pkg-plist b/chinese/fcitx/pkg-plist
index 80983f2eddab..51adc81755cf 100644
--- a/chinese/fcitx/pkg-plist
+++ b/chinese/fcitx/pkg-plist
@@ -54,13 +54,13 @@ lib/fcitx/fcitx-x11.so
lib/fcitx/fcitx-xim.so
lib/libfcitx-config.so
lib/libfcitx-config.so.4
-lib/libfcitx-config.so.4.1
+lib/libfcitx-config.so.4.1.0
lib/libfcitx-core.so
lib/libfcitx-core.so.0
-lib/libfcitx-core.so.0.2
+lib/libfcitx-core.so.0.2.0
lib/libfcitx-utils.so
lib/libfcitx-utils.so.0
-lib/libfcitx-utils.so.0.1
+lib/libfcitx-utils.so.0.1.0
libdata/pkgconfig/fcitx-config.pc
libdata/pkgconfig/fcitx-utils.pc
libdata/pkgconfig/fcitx.pc