aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/firebird/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2001-02-16 21:35:31 +0800
committervanilla <vanilla@FreeBSD.org>2001-02-16 21:35:31 +0800
commitef173030dfa142851379a7c40d421b0e134aff6c (patch)
tree41c5d51d522e58e65b39372daebd7e5f81223333 /chinese/firebird/Makefile
parent68a5d674011fae776659b16acb10b665e05ae1dc (diff)
downloadfreebsd-ports-gnome-ef173030dfa142851379a7c40d421b0e134aff6c.tar.gz
freebsd-ports-gnome-ef173030dfa142851379a7c40d421b0e134aff6c.tar.zst
freebsd-ports-gnome-ef173030dfa142851379a7c40d421b0e134aff6c.zip
Firebird BBS is widely used telnet based Bulletin Board System in
Chinese Internet Community. In Taiwan, there're over 300 BBS sites using Firebird, about 50 sites in china, and about 20 worldwide (USA, UK, Canada, Austrailla and many countries can be find Firebird) and over thousands of users on-line at the same time in biggest BBS site. For more information, ref: http://www.firebird.org.tw/ PR: ports/24899 Submitted by: Edward Ping-Da Chuan <edwardc@firebird.com.tw>
Diffstat (limited to 'chinese/firebird/Makefile')
-rw-r--r--chinese/firebird/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/chinese/firebird/Makefile b/chinese/firebird/Makefile
new file mode 100644
index 000000000000..9a60bea8af29
--- /dev/null
+++ b/chinese/firebird/Makefile
@@ -0,0 +1,37 @@
+# ports collection makefile for: Firebird BBS
+# Date created: Sun Feb 4 22:48:06 CST 2001
+# Whom: Edward Chuang <edwardc@firebird.org.tw>
+# $FreeBSD$
+
+PORTNAME= firebird
+PORTVERSION= 3.0R
+CATEGORIES= chinese net
+MASTER_SITES= http://www.firebird.org.tw/download/ \
+ ftp://ftp.firebird.org.tw/pub/Firebird/ \
+ ftp://ftp4.firebird.org.tw/network/BBS/Firebird/
+DISTNAME= 3.0-RELEASE
+
+MAINTAINER= edwardc@firebird.org.tw
+
+WRKSRC= ${WRKDIR}/bbs/bbssrc
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+IS_INTERACTIVE= yes
+
+pre-install:
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/rc.d/bbs.sh.example ]; then \
+ ${ECHO} "Installing ${PREFIX}/etc/rc.d/bbs.sh.example startup file."; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/bbs.sh.example ${PREFIX}/etc/rc.d/bbs.sh.example; \
+ fi
+ @echo "======================================================================="
+ @echo "Installnation Complete."
+ @echo "======================================================================="
+ @echo "please review ${PREFIX}/etc/rc.d/bbs.sh.example change bbsd port you want"
+ @echo "then rename to ${PREFIX}/etc/rc.d/bbs.sh then:"
+ @echo "use ${PREFIX}/etc/rc.d/bbs.sh { start | stop } to start the BBS service"
+ @echo "full and complete document in ${PREFIX}/bbs/bbssrc/doc read before ask."
+
+.include <bsd.port.mk>