aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/gcin-devel/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2005-05-19 15:59:51 +0800
committervanilla <vanilla@FreeBSD.org>2005-05-19 15:59:51 +0800
commit0c36cf67506232d1a21f770226580d4feb036f68 (patch)
treeb807792345577e1b7cc6d61f9fc6e724ce327e60 /chinese/gcin-devel/Makefile
parent5777765a54f67f64240f754f1fe824e53367f1ee (diff)
downloadfreebsd-ports-gnome-0c36cf67506232d1a21f770226580d4feb036f68.tar.gz
freebsd-ports-gnome-0c36cf67506232d1a21f770226580d4feb036f68.tar.zst
freebsd-ports-gnome-0c36cf67506232d1a21f770226580d4feb036f68.zip
- add support for Boshiamy input method
The Boshiamy .cin & .gtab table is port from Edward Lee and I make it as an option for gcin poeple. Therefore, there's a new extra patch file(extra-patch-data-Makefile) and I put "PLIST_FILES+= share/gcin/table/noseeing.gtab" into "if defined(WITH_BOSHIAMY)" section in Makefile to suit the pkg-plist which people choose Boshiamy. - option NOPORTDOCS has incorrect package list - remove unused patch (patch-about.c) PR: ports/81246 Submitted by: chinsan <chinsan@mail2000.comdottw> Approved by: maintainer
Diffstat (limited to 'chinese/gcin-devel/Makefile')
-rw-r--r--chinese/gcin-devel/Makefile30
1 files changed, 28 insertions, 2 deletions
diff --git a/chinese/gcin-devel/Makefile b/chinese/gcin-devel/Makefile
index 82d8e0be94d4..f485d98984a4 100644
--- a/chinese/gcin-devel/Makefile
+++ b/chinese/gcin-devel/Makefile
@@ -6,9 +6,14 @@
#
PORTNAME= gcin
-PORTVERSION= 0.9.5
+PORTVERSION= 0.9.6
CATEGORIES= chinese
-MASTER_SITES= http://www.csie.nctu.edu.tw/~cp76/gcin/download/
+MASTER_SITES= http://www.csie.nctu.edu.tw/~cp76/gcin/download/ \
+ http://edt1023.sayya.org/misc/
+.if defined(WITH_BOSHIAMY)
+DISTFILES= ${GCINFILE} ${BOSHIAMYFILE}
+EXTRACT_ONLY= ${GCINFILE}
+.endif
MAINTAINER= statue@freebsd.netlab.cse.yzu.edu.tw
COMMENT= A traditional chinese input utility in X
@@ -18,13 +23,34 @@ USE_BZIP2= YES
GNU_CONFIGURE= YES
USE_GNOME= gtk20
USE_GMAKE= YES
+PLIST_SUB+= BOSHIAMY="@comment "
.include <bsd.port.pre.mk>
+pre-everything::
+ @${ECHO_MSG} ''
+ @${ECHO_MSG} 'gcin has the following tunable option:'
+ @${ECHO_MSG} ' WITH_BOSHIAMY - enable Boshiamy support'
+ @${ECHO_MSG} ''
+ @${ECHO_MSG} 'Example: "make WITH_BOSHIAMY=yes install clean" '
+ @${ECHO_MSG} ''
+
.if ${OSVERSION} <= 500034
USE_GCC= 3.4
.endif
+.if defined(WITH_BOSHIAMY)
+GCINFILE= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+BOSHIAMYFILE= noseeing-${BOSHIAMYVER}.tar.gz
+BOSHIAMYVER= 3
+post-extract:
+ @cd ${WRKSRC}/data/ \
+ && ${TAR} -zxf ${DISTDIR}/${BOSHIAMYFILE}
+post-patch:
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-data-Makefile
+PLIST_SUB+= BOSHIAMY=""
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}