aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/gcin/files
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2012-01-31 20:52:37 +0800
committervanilla <vanilla@FreeBSD.org>2012-01-31 20:52:37 +0800
commit34fb6545e0360f990cbb837469250da3e7991b52 (patch)
tree709b1129e911559ef6c45b21bc86097801f90d88 /chinese/gcin/files
parent1e9cfb85a776f169113c9881a001d79680b80a38 (diff)
downloadfreebsd-ports-gnome-34fb6545e0360f990cbb837469250da3e7991b52.tar.gz
freebsd-ports-gnome-34fb6545e0360f990cbb837469250da3e7991b52.tar.zst
freebsd-ports-gnome-34fb6545e0360f990cbb837469250da3e7991b52.zip
Upgrade to 2.7.1.
Diffstat (limited to 'chinese/gcin/files')
-rw-r--r--chinese/gcin/files/patch-Makefile15
-rw-r--r--chinese/gcin/files/patch-gcin-exit.cpp11
-rw-r--r--chinese/gcin/files/patch-pho-play.cpp11
3 files changed, 34 insertions, 3 deletions
diff --git a/chinese/gcin/files/patch-Makefile b/chinese/gcin/files/patch-Makefile
index 4b9ed4dce0d8..14cd7604865b 100644
--- a/chinese/gcin/files/patch-Makefile
+++ b/chinese/gcin/files/patch-Makefile
@@ -1,6 +1,15 @@
---- Makefile.orig 2012-01-31 16:17:52.000000000 +0800
-+++ Makefile 2012-01-31 16:18:06.000000000 +0800
-@@ -221,6 +221,7 @@
+--- Makefile.orig 2011-12-19 10:45:09.000000000 +0800
++++ Makefile 2012-01-31 20:30:12.000000000 +0800
+@@ -90,7 +90,7 @@ PROGS_CV=kbmcv pin-juyin
+ all: $(PROGS) trad2sim $(GCIN_SO) $(DATA) $(PROGS_CV) gcin.spec gcin-fedora.spec
+ $(MAKE) -C data
+ $(MAKE) -C gtk-im
+- if [ $(BUILD_MODULE) = 'Y' ]; then $(MAKE) -C modules; fi
++ $(MAKE) -C modules
+ if [ $(USE_I18N) = 'Y' ]; then $(MAKE) -C po; fi
+ if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im; fi
+ if [ $(QT_IM) = 'Y' ]; then $(MAKE) -C qt-im; fi
+@@ -221,6 +221,7 @@ install:
rm -f $(bindir)/trad2sim; ln -sf sim2trad $(bindir)/trad2sim; \
fi
$(MAKE) -C scripts install
diff --git a/chinese/gcin/files/patch-gcin-exit.cpp b/chinese/gcin/files/patch-gcin-exit.cpp
new file mode 100644
index 000000000000..bd1fd9bee91f
--- /dev/null
+++ b/chinese/gcin/files/patch-gcin-exit.cpp
@@ -0,0 +1,11 @@
+--- gcin-exit.cpp.orig 2012-01-25 19:29:28.000000000 +0800
++++ gcin-exit.cpp 2012-01-25 19:29:38.000000000 +0800
+@@ -12,7 +12,7 @@ int main()
+ #if UNIX
+ Display *dpy = GDK_DISPLAY();
+ if (find_gcin_window(dpy)==None)
+- return;
++ return 0;
+ send_gcin_message(dpy, GCIN_EXIT_MESSAGE);
+ #else
+ if (!find_gcin_window())
diff --git a/chinese/gcin/files/patch-pho-play.cpp b/chinese/gcin/files/patch-pho-play.cpp
new file mode 100644
index 000000000000..eac63a6344b3
--- /dev/null
+++ b/chinese/gcin/files/patch-pho-play.cpp
@@ -0,0 +1,11 @@
+--- pho-play.cpp.orig 2012-01-25 19:26:50.000000000 +0800
++++ pho-play.cpp 2012-01-25 19:27:29.000000000 +0800
+@@ -12,7 +12,7 @@ int pho_play(phokey_t key)
+ if (!phonetic_speak)
+ return 0;
+ if (test_mode)
+- return;
++ return 0;
+
+ static int pid;
+ static time_t last_time;