aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/gcin
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2011-02-16 06:18:24 +0800
committerchinsan <chinsan@FreeBSD.org>2011-02-16 06:18:24 +0800
commit0b42196d241d3474131f54d09646aa8749ff8d36 (patch)
tree034872e043b522a58363dd941113b262bfd6f67f /chinese/gcin
parent9a8d58619df4739e43cd79aa5a1c18736c2cfa1a (diff)
downloadfreebsd-ports-gnome-0b42196d241d3474131f54d09646aa8749ff8d36.tar.gz
freebsd-ports-gnome-0b42196d241d3474131f54d09646aa8749ff8d36.tar.zst
freebsd-ports-gnome-0b42196d241d3474131f54d09646aa8749ff8d36.zip
- update to 1.5.8
- remove noseeing - fix gcin-setup - fix qt4 detecting problem (path) - remove unused patch - use 'xdg-open(1)' to opens a file or URL in the user's preferred application
Diffstat (limited to 'chinese/gcin')
-rw-r--r--chinese/gcin/Makefile42
-rw-r--r--chinese/gcin/distinfo6
-rw-r--r--chinese/gcin/files/patch-gcin.h17
-rw-r--r--chinese/gcin/files/patch-im-client-Makefile8
-rw-r--r--chinese/gcin/files/patch-im-srv.cpp11
-rw-r--r--chinese/gcin/files/patch-qt4-im-Makefile15
-rw-r--r--chinese/gcin/pkg-plist22
7 files changed, 33 insertions, 88 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index c24924b57b87..37ca3f9fa21a 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcin
-PORTVERSION= 1.5.6
+PORTVERSION= 1.5.8
CATEGORIES= chinese textproc gnome
MASTER_SITES= http://cle.linux.org.tw/gcin/download/:main \
http://ftp.twaren.net/local-distfiles/gcin/:main \
@@ -21,16 +21,16 @@ LICENSE= LGPL21
USE_BZIP2= YES
HAS_CONFIGURE= YES
+CONFIGURE_ARGS+= --use_gtk3=N
USE_GNOME= gtk20
USE_GMAKE= YES
-USE_XORG= x11 xtst
+USE_XORG= x11 xtst xext
INSTALLS_ICONS= YES
USE_LDCONFIG= YES
OPTIONS= ANTHY "enable Japanese anthy IM module" off \
- BOSHIAMY "enable Boshiamy Input Method" on \
- QT_IM_MODULE "enable QT IM module" on
+ QT_IM_MODULE "enable QT IM module" off
-MAN1= gcin.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
+MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
gcin-message.1 gcin-setup.1 gtab-merge.1 juyin-learn.1 \
phoa2d.1 sim2trad.1 tsa2d32.1 tslearn.1
@@ -53,30 +53,16 @@ BUILD_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
RUN_DEPENDS+= ${LOCALBASE}/include/anthy/anthy.h:${PORTSDIR}/japanese/anthy
.endif
-.if defined(WITH_BOSHIAMY)
-MASTER_SITES+= http://cle.linux.org.tw/~edt1023/gcin/:boshiamy \
- LOCAL/chinsan/gcin:boshiamy \
- http://edt1023.sayya.org/gcin/:boshiamy
-DISTFILES+= ${BOSHIAMY_FILE}:boshiamy
-BOSHIAMY_FILE= noseeing-12.tar.gz
-post-extract:
- @${TAR} -C ${WRKSRC}/data/ -zxf ${DISTDIR}/${BOSHIAMY_FILE} \
- noseeing.cin
- @${TAR} -C ${WRKSRC}/scripts/ -zxf ${DISTDIR}/${BOSHIAMY_FILE} \
- noseeadd.rb
- @${REINPLACE_CMD} -e 's,cj.gtab,cj.gtab noseeing.gtab,' \
- ${WRKSRC}/data/Makefile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,&,,; 1 s,bash,sh,; \
- s,QT_IM_DIR=/usr,QT_IM_DIR=$$prefix,; \
+ s,QT_IM_DIR=/usr,QT_IM_DIR=$$prefix,g; \
+ s,QT4_IM_DIR=/usr,QT4_IM_DIR=$$prefix,g; \
s,mandir=$$datadir,mandir=$$prefix,; \
- s,/usr/share,$$prefix/share,; s,libdir)\/gcin,libdir),; \
- s,/usr/lib/qt4/plugins/lib,${PREFIX}/lib/qt4/plugins,; \
- s,gcc,$$CC,; s,gcin-$$GCIN_VERSION,gcin,' ${WRKSRC}/configure
+ s,/usr/share,$$prefix/share,; \
+ 1, 300 s,gcc,$$CC,; s,gcin-$$GCIN_VERSION,gcin,' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,\/usr\/share,$$(prefix)\/share,;' \
${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '93,95 d' ${WRKSRC}/gcin-common.cpp
@${REINPLACE_CMD} -e 's,/usr/local,/usr,g' \
${WRKSRC}/gtk-im/Makefile ${WRKSRC}/menu/Makefile
@${REINPLACE_CMD} -e 's,modify-XIM ,,; 8,10 d' \
@@ -87,7 +73,7 @@ post-patch:
${WRKSRC}/scripts/tsin-gtab-import \
${WRKSRC}/scripts/tsin-gtab-edit
@${REINPLACE_CMD} -e 's,bash,sh,; s/&//; 12,13 s/=/ /; \
- s/export/setenv/; s/mozilla-firefox/firefox3/;' \
+ s/export/setenv/; s/$$UTF8ED/xdg-open/' \
${WRKSRC}/scripts/html-browser
@${REINPLACE_CMD} -e 's,gcin-im-client.h,im-client/gcin-im-client.h,;' \
${WRKSRC}/gtk-im/gtkimcontextgcin.c
@@ -100,12 +86,6 @@ post-patch:
@${REINPLACE_CMD} '/install.*DOC_DIR/d' ${WRKSRC}/Makefile
.endif
-.if defined(WITH_BOSHIAMY)
-PLIST_SUB+= BOSHIAMY=""
-.else
-PLIST_SUB+= BOSHIAMY="@comment "
-.endif
-
.if defined(WITH_QT_IM_MODULE)
PLIST_SUB+= QT_IM_MODULE=""
.else
diff --git a/chinese/gcin/distinfo b/chinese/gcin/distinfo
index b29a305c263b..613e6c1ad189 100644
--- a/chinese/gcin/distinfo
+++ b/chinese/gcin/distinfo
@@ -1,4 +1,2 @@
-SHA256 (gcin-1.5.6.tar.bz2) = ce7e7ef6cedcd0d9fce6c6cf03c4bcc87d157b7dfa82990b1b52585a39299086
-SIZE (gcin-1.5.6.tar.bz2) = 2833378
-SHA256 (noseeing-12.tar.gz) = 9082f50db64b9e2971873aca1607c45a8eb41e803b99f66bd239fd587e1ce19b
-SIZE (noseeing-12.tar.gz) = 416726
+SHA256 (gcin-1.5.8.tar.bz2) = 9827eaee904d6e943382a897128bdd04c9f097159d76e12f1a585dc91ef45774
+SIZE (gcin-1.5.8.tar.bz2) = 2869134
diff --git a/chinese/gcin/files/patch-gcin.h b/chinese/gcin/files/patch-gcin.h
deleted file mode 100644
index 1c92f3a330af..000000000000
--- a/chinese/gcin/files/patch-gcin.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- gcin.h.bak 2010-06-18 08:54:14.000000000 +0800
-+++ gcin.h 2011-02-08 12:13:27.000000000 +0800
-@@ -50,6 +50,14 @@
- #define GTK_WIDGET_REALIZED gtk_widget_get_realized
- #endif
-
-+#if GTK_CHECK_VERSION(2, 22, 0)
-+#define GDK_DISPLAY() (GDK_DISPLAY_XDISPLAY(gdk_display_get_default()))
-+#endif
-+
-+#ifndef GTK_API_VERSION_2
-+#define GDK_DISPLAY() (GDK_DISPLAY_XDISPLAY(gdk_display_get_default()))
-+#endif
-+
- typedef enum {
- GCIN_STATE_DISABLED = 0,
- GCIN_STATE_ENG_FULL = 1,
diff --git a/chinese/gcin/files/patch-im-client-Makefile b/chinese/gcin/files/patch-im-client-Makefile
index c462b454cc67..f69e02bf9340 100644
--- a/chinese/gcin/files/patch-im-client-Makefile
+++ b/chinese/gcin/files/patch-im-client-Makefile
@@ -1,11 +1,11 @@
---- im-client/Makefile.orig 2009-12-12 19:28:49.000000000 +0800
-+++ im-client/Makefile 2010-11-20 18:09:18.000000000 +0800
+--- im-client/Makefile.old 2011-02-08 09:20:29.000000000 +0800
++++ im-client/Makefile 2011-02-16 05:14:52.000000000 +0800
@@ -20,7 +20,7 @@
$(CC) -x c -c $(CFLAGS) $<
$(SOFILEVER): $(OBJS)
-- $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -lX11 -o $@
-+ $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -o $@
+- $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -lX11 -o $@ -L/usr/X11R6/lib
++ $(CC) $(SO_FLAGS) -Wl,-soname,libgcin-im-client.so.1 $(OBJS) -o $@ -lX11 -L/usr/local/lib
ln -sf $(SOFILEVER) $(SOFILE)
ln -sf $(SOFILEVER) $(SOFILE).1
$(MAKE) -C ../gtk-im
diff --git a/chinese/gcin/files/patch-im-srv.cpp b/chinese/gcin/files/patch-im-srv.cpp
deleted file mode 100644
index 85dc4147e31b..000000000000
--- a/chinese/gcin/files/patch-im-srv.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- im-srv.cpp~ 2010-04-09 21:14:55.000000000 +0800
-+++ im-srv.cpp 2011-01-29 14:11:47.000000000 +0800
-@@ -15,6 +15,8 @@
- #include "gcin.h"
- #include "gcin-protocol.h"
- #include "im-srv.h"
-+#include <gtk/gtk.h>
-+#include <gdk/gdkx.h>
- #include <gdk/gdk.h>
-
- #if UNIX
diff --git a/chinese/gcin/files/patch-qt4-im-Makefile b/chinese/gcin/files/patch-qt4-im-Makefile
index ff75352b3090..070169b36947 100644
--- a/chinese/gcin/files/patch-qt4-im-Makefile
+++ b/chinese/gcin/files/patch-qt4-im-Makefile
@@ -1,6 +1,6 @@
---- qt4-im/Makefile~ 2010-07-29 00:15:03.000000000 +0800
-+++ qt4-im/Makefile 2011-02-09 16:44:54.000000000 +0800
-@@ -1,21 +1,22 @@
+--- qt4-im/Makefile.orig 2011-02-08 09:35:24.000000000 +0800
++++ qt4-im/Makefile 2011-02-16 02:54:57.000000000 +0800
+@@ -1,21 +1,21 @@
include ../config.mak
QT=qt4
QTIM=$(QT)/plugins/inputmethods
@@ -8,14 +8,13 @@
+IMMODULES=/usr/local/lib/$(QTIM)
-INCS=-I../im-client -I/usr/include/X11 `pkg-config QtCore QtGui --cflags`
-+INCS=-I../im-client -I/usr/local/include `pkg-config QtCore QtGui --cflags`
- CXXFLAGS=$(OPTFLAGS) $(INCS) -Wall -D_REENTRANT -fPIC -DQT4 -DQT_SHARED \
++INCS=-I../im-client -I/usr/local/include/X11 -I/usr/local/include `pkg-config QtCore QtGui --cflags`
+ CXXFLAGS=$(OPTFLAGS) $(INCS) -Wall -D_REENTRANT -DUNIX=1 -fPIC -DQT4 -DQT_SHARED \
-DQT_IMMODULE -DPIC
OBJS= moc_gcin-qt.o gcin-qt.o im-gcin-qt.o gcin-imcontext-qt.o
.SUFFIXES: .c .cpp .a .so .E .h
--LDFLAGS=-L../im-client -lgcin-im-client -Wl,-rpath,$(gcinlibdir) `pkg-config QtCore QtGui --libs`
-+LDFLAGS=-L../im-client -lgcin-im-client -lXext -lX11 -lm -lSM -lICE \
-+ -lpthread -Wl,-rpath,$(gcinlibdir) `pkg-config QtCore QtGui --libs`
+-LDFLAGS=-L../im-client -lgcin-im-client `pkg-config QtCore QtGui --libs`
++LDFLAGS=-L../im-client -lgcin-im-client -lpthread -Wl,-rpath,$(gcinlibdir) `pkg-config QtCore QtGui --libs`
all: im-gcin.so
.cpp.E:
diff --git a/chinese/gcin/pkg-plist b/chinese/gcin/pkg-plist
index f69879bccf49..bd3c5c79a630 100644
--- a/chinese/gcin/pkg-plist
+++ b/chinese/gcin/pkg-plist
@@ -1,4 +1,5 @@
bin/gcin
+bin/gcin-exit
bin/gcin-gb-toggle
bin/gcin-kbm-toggle
bin/gcin-message
@@ -16,15 +17,14 @@ bin/tsin2gtab-phrase
bin/tslearn
lib/gtk-2.0/immodules/im-gcin.so
@comment %%QT_IM_MODULE%%lib/qt4/plugins/inputmethods/im-gcin.so
-lib/gcin1.so
-lib/gcin2.so
-lib/libgcin-im-client.so
-lib/libgcin-im-client.so.1.2.2
-lib/libgcin-im-client.so.1
+lib/gcin/gcin1.so
+lib/gcin/gcin2.so
+lib/gcin/libgcin-im-client.so
+lib/gcin/libgcin-im-client.so.1.2.2
+lib/gcin/libgcin-im-client.so.1
%%DATADIR%%/script/gcin-user-setup
%%DATADIR%%/script/gtab.append_prepare
%%DATADIR%%/script/html-browser
-@comment %%BOSHIAMY%%%%DATADIR%%/script/noseeadd.rb
%%DATADIR%%/script/tsin-gtab-import
%%DATADIR%%/script/tsin-gtab-edit
%%DATADIR%%/script/utf8-edit
@@ -36,9 +36,7 @@ lib/libgcin-im-client.so.1
%%DATADIR%%/table/cj543.gtab
%%DATADIR%%/table/dayi3.gtab
%%DATADIR%%/table/dvorak.kbm
-%%DATADIR%%/table/et-asdf.kbm
%%DATADIR%%/table/et.kbm
-%%DATADIR%%/table/et26-asdf.kbm
%%DATADIR%%/table/et26.kbm
%%DATADIR%%/table/greek.gtab
%%DATADIR%%/table/gtab.list
@@ -47,14 +45,12 @@ lib/libgcin-im-client.so.1
%%DATADIR%%/table/jyutping.gtab
%%DATADIR%%/table/latin-letters.gtab
%%DATADIR%%/table/mitac.kbm
-%%BOSHIAMY%%%%DATADIR%%/table/noseeing.gtab
%%DATADIR%%/table/phrase-ctrl.table
-%%DATADIR%%/table/pho-huge.tab
-%%DATADIR%%/table/pho.tab
+%%DATADIR%%/table/pho-huge.tab2
+%%DATADIR%%/table/pho.tab2
%%DATADIR%%/table/phrase.table
%%DATADIR%%/table/pinyin.gtab
%%DATADIR%%/table/pinyin.kbm
-%%DATADIR%%/table/pinyin-asdf.kbm
%%DATADIR%%/table/pin-juyin.xlt
%%DATADIR%%/table/russian.gtab
%%DATADIR%%/table/s2t.dat
@@ -66,7 +62,6 @@ lib/libgcin-im-client.so.1
%%DATADIR%%/table/tsin32
%%DATADIR%%/table/tsin32.idx
%%DATADIR%%/table/zo.kbm
-%%DATADIR%%/table/zo-asdf.kbm
%%PORTDOCS%%%%DOCSDIR%%/Changelog.html
%%PORTDOCS%%%%DOCSDIR%%/README.html
share/applications/gcin
@@ -126,5 +121,6 @@ share/icons/gcin.png
@dirrmtry %%DATADIR%%
@dirrmtry lib/gtk-2.0/immodules
@dirrmtry lib/gtk-2.0
+@dirrmtry lib/gcin
@exec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
@unexec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules