aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/ibus-chewing
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
committertcberner <tcberner@FreeBSD.org>2017-06-26 05:07:58 +0800
commit19b60f6341c1340c532b32ab42000f8ef533e37c (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /chinese/ibus-chewing
parentcc28d78986356b14cfa92360db6e23f595431254 (diff)
downloadfreebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.gz
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.tar.zst
freebsd-ports-gnome-19b60f6341c1340c532b32ab42000f8ef533e37c.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Diffstat (limited to 'chinese/ibus-chewing')
-rw-r--r--chinese/ibus-chewing/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/chinese/ibus-chewing/Makefile b/chinese/ibus-chewing/Makefile
index 91e914f0edf5..207c153cc2af 100644
--- a/chinese/ibus-chewing/Makefile
+++ b/chinese/ibus-chewing/Makefile
@@ -20,7 +20,7 @@ CMAKE_ARGS= -DSYSCONF_INSTALL_DIR=${PREFIX}/etc \
-DLIB_DIR=${PREFIX}/lib
LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.freedesktop.IBus.Chewing.gschema.xml
-USES= cmake gettext pkgconfig
+USES= cmake:noninja gettext pkgconfig
USE_GNOME= gtk20
USE_XORG= xtst