aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/librime
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /chinese/librime
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'chinese/librime')
-rw-r--r--chinese/librime/Makefile2
-rw-r--r--chinese/librime/files/patch-CMakeLists.txt9
2 files changed, 1 insertions, 10 deletions
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 75f9a70fa1f1..bf17914e2e6a 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libopencc.so:chinese/opencc \
libyaml-cpp.so:devel/yaml-cpp
-USES= cmake compiler:c++11-lib pkgconfig gettext perl5
+USES= cmake compiler:c++11-lib pathfix pkgconfig gettext perl5
USE_PERL5= build patch
USE_LDCONFIG= yes
USE_XORG= xproto
diff --git a/chinese/librime/files/patch-CMakeLists.txt b/chinese/librime/files/patch-CMakeLists.txt
index be56ba257543..301102a5a69d 100644
--- a/chinese/librime/files/patch-CMakeLists.txt
+++ b/chinese/librime/files/patch-CMakeLists.txt
@@ -9,15 +9,6 @@
# uninstall target
configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in"
-@@ -142,7 +142,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
- ${PROJECT_BINARY_DIR}/rime.pc
- @ONLY)
- install(FILES include/rime_api.h DESTINATION include)
-- install(FILES ${PROJECT_BINARY_DIR}/rime.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-+ install(FILES ${PROJECT_BINARY_DIR}/rime.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
- install(FILES cmake/RimeConfig.cmake DESTINATION share/cmake/rime)
- if(BUILD_DATA)
- install(FILES ${PROJECT_SOURCE_DIR}/data/default.yaml DESTINATION ${pkgdatadir})
@@ -153,7 +153,7 @@ if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
file(GLOB supplement_schema ${PROJECT_SOURCE_DIR}/data/supplement/*.yaml)
install(FILES ${supplement_schema} DESTINATION ${pkgdatadir})