aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/moefonts-cid
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-31 08:24:20 +0800
committeredwin <edwin@FreeBSD.org>2003-08-31 08:24:20 +0800
commit2049a030be2d105cf0b5468e695e761c08d1e5f4 (patch)
tree2b84dd073cfc62ec98b25432032d8eba1babf48a /chinese/moefonts-cid
parent16de3749d9043e4511f0c160784f130d1fcc26f2 (diff)
downloadfreebsd-ports-gnome-2049a030be2d105cf0b5468e695e761c08d1e5f4.tar.gz
freebsd-ports-gnome-2049a030be2d105cf0b5468e695e761c08d1e5f4.tar.zst
freebsd-ports-gnome-2049a030be2d105cf0b5468e695e761c08d1e5f4.zip
[PATCH] chinese/moefonts-cid: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54921 Submitted by: Jens Rehsack <rehsack@liwing.de>
Diffstat (limited to 'chinese/moefonts-cid')
-rw-r--r--chinese/moefonts-cid/Makefile16
-rw-r--r--chinese/moefonts-cid/pkg-install2
2 files changed, 16 insertions, 2 deletions
diff --git a/chinese/moefonts-cid/Makefile b/chinese/moefonts-cid/Makefile
index 52155af4260d..7343e7f22c53 100644
--- a/chinese/moefonts-cid/Makefile
+++ b/chinese/moefonts-cid/Makefile
@@ -18,11 +18,25 @@ EXTRACT_ONLY= # empty
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= MOE CIDFonts converted by Adobe
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
NO_BUILD= YES
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
do-install:
@${INSTALL_DATA} ${DISTDIR}/MOEKai-Regular \
${DISTDIR}/MOESung-Regular \
diff --git a/chinese/moefonts-cid/pkg-install b/chinese/moefonts-cid/pkg-install
index c453580206c7..f8379cb9f195 100644
--- a/chinese/moefonts-cid/pkg-install
+++ b/chinese/moefonts-cid/pkg-install
@@ -1,6 +1,6 @@
#!/bin/sh
-GSVER=`cd ${PORTSDIR}/print/ghostscript-gnu && make -V GS_VERSION`
+GSVER=`gs --version`
GSDIR=${PREFIX}/share/ghostscript
FONTMAP=${GSDIR}/${GSVER}/lib/Fontmap.GS