aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/oicq/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-11-13 12:58:31 +0800
committervanilla <vanilla@FreeBSD.org>2003-11-13 12:58:31 +0800
commit72674ea0da3df254d94cc99e950aae8889794211 (patch)
treeaf03084614bd7e2074f0d4d07d3c1df9d22e6621 /chinese/oicq/Makefile
parent51506b98f254769c7870fa85d4223e7894ee3891 (diff)
downloadfreebsd-ports-gnome-72674ea0da3df254d94cc99e950aae8889794211.tar.gz
freebsd-ports-gnome-72674ea0da3df254d94cc99e950aae8889794211.tar.zst
freebsd-ports-gnome-72674ea0da3df254d94cc99e950aae8889794211.zip
Add oicq 0.7, implements OICQ messaging protocol.
PR: 59093 Submitted by: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
Diffstat (limited to 'chinese/oicq/Makefile')
-rw-r--r--chinese/oicq/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/chinese/oicq/Makefile b/chinese/oicq/Makefile
new file mode 100644
index 000000000000..e39e56ee0708
--- /dev/null
+++ b/chinese/oicq/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: oicq
+# Date created: 10 Nov 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oicq
+PORTVERSION= 0.7
+CATEGORIES= chinese net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= perl-oicq
+DISTNAME= Net-OICQ-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= Implements OICQ messaging protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OICQ.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/oicq ${PREFIX}/bin
+
+.include <bsd.port.post.mk>