aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/opendesktop-fonts
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-02-19 21:51:50 +0800
committerleeym <leeym@FreeBSD.org>2005-02-19 21:51:50 +0800
commit31459e01770eecb2584fba51544d7b5855a6300f (patch)
tree4b1bb35388cb87d2d1c66e786f5ae233b418c9f9 /chinese/opendesktop-fonts
parent5f8f4cbde94a90e2f70c8e265d8a42fc29b483ee (diff)
downloadfreebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.tar.gz
freebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.tar.zst
freebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.zip
- add chinese/Makefile.ttf to control install/deinstall process of all
TrueType fonts in chinese/*ttf - update related Makefile(s) and remove pkg-{install,pkg-deinstall,pkg-plist} - relocate non-font files to DATADIR or DOCSDIR - fix "unable to reomve fonts from gscjk" problem in ttfm.sh and gscjk.ttfm - update chinese/zh-fireflyttf to 1.2.6 [1] PR: [1] 77438 Submitted by: leeym Approved by: statue at freebsd.sinica.edu.tw
Diffstat (limited to 'chinese/opendesktop-fonts')
-rw-r--r--chinese/opendesktop-fonts/Makefile34
-rw-r--r--chinese/opendesktop-fonts/pkg-plist13
2 files changed, 19 insertions, 28 deletions
diff --git a/chinese/opendesktop-fonts/Makefile b/chinese/opendesktop-fonts/Makefile
index ee7a4eee8332..4a27ba8012de 100644
--- a/chinese/opendesktop-fonts/Makefile
+++ b/chinese/opendesktop-fonts/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= fireflyttf
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.2.6
+PORTREVISION= 0
CATEGORIES= chinese x11-fonts
MASTER_SITES= http://www.study-area.org/apt/firefly-font/
DISTNAME= fireflysung.ttf
@@ -16,28 +16,26 @@ EXTRACT_SUFX= .gz
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= Firefly TrueType Font is combine of two arphic sung fonts
-BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
- ttfm.sh:${PORTSDIR}/chinese/ttfm
-
NO_BUILD= yes
WRKSRC= ${WRKDIR}
-USE_XLIB= yes
-FONTDIR= ${PREFIX}/share/fonts/TrueType
-XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
EXTRACT_AFTER_ARGS= > ${DISTNAME}
-.include <bsd.port.pre.mk>
+TTF= ${DISTNAME}
+
+.if !defined(WITHOUT_X11)
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
do-install:
- @${MKDIR} ${FONTDIR}
- @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${FONTDIR}
- @${ECHO_MSG} "===> Running ttfm.sh"
- -@${PREFIX}/bin/ttfm.sh --add xttfm ${DISTNAME}
- @${ECHO_MSG} "===> Running fc-cache"
- -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
- ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTDIR}
+ ${MKDIR} ${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${TTF} ${FONTSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTSDIR}
+.if !defined(WITHOUT_X11)
${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${X11BASE}/etc/fonts/local.conf
+.endif
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
.include <bsd.port.post.mk>
diff --git a/chinese/opendesktop-fonts/pkg-plist b/chinese/opendesktop-fonts/pkg-plist
index 87aa373d2879..51ad1ebac38c 100644
--- a/chinese/opendesktop-fonts/pkg-plist
+++ b/chinese/opendesktop-fonts/pkg-plist
@@ -1,10 +1,3 @@
-@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/share/fonts/TrueType/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
-share/fonts/TrueType/local.conf-sung
-@exec cp %D/share/fonts/TrueType/local.conf-sung %%X11BASE%%/etc/fonts/local.conf
-@unexec %D/bin/ttfm.sh --remove xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
-share/fonts/TrueType/fireflysung.ttf
-@exec %D/bin/ttfm.sh --add xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
-@unexec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
-@exec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
-@unexec rmdir %D/share/fonts/TrueType 2>/dev/null || true
-@unexec rmdir %D/share/fonts 2>/dev/null || true
+%%X11%%@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/%%FONTSDIR%%/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
+%%FONTSDIR%%/local.conf-sung
+%%X11%%@exec cp %D/%%FONTSDIR%%/local.conf-sung %%X11BASE%%/etc/fonts/local.conf