aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/pine4/Makefile
diff options
context:
space:
mode:
authorkeith <keith@FreeBSD.org>2000-11-18 03:06:54 +0800
committerkeith <keith@FreeBSD.org>2000-11-18 03:06:54 +0800
commitd3ca4e742df94d84386391a38e719189db25aadd (patch)
tree38d2b821ccc99ba10cf9bab3d71498087c3a2e81 /chinese/pine4/Makefile
parent934aac66cdbe46697ca68b78a214b053f1200792 (diff)
downloadfreebsd-ports-gnome-d3ca4e742df94d84386391a38e719189db25aadd.tar.gz
freebsd-ports-gnome-d3ca4e742df94d84386391a38e719189db25aadd.tar.zst
freebsd-ports-gnome-d3ca4e742df94d84386391a38e719189db25aadd.zip
Upgrade from 4.21 to 4.30.
Especially thanks to the maintainer, Tai-hwa Liang (avatar), for ending those long lasting evil +400k files/patch-*. :-) According to kkenn, pine4's security will exist until it's totally rewritten, so I'll leave pkg-install untouched, which shows the security warning. PR: ports/22436
Diffstat (limited to 'chinese/pine4/Makefile')
-rw-r--r--chinese/pine4/Makefile37
1 files changed, 26 insertions, 11 deletions
diff --git a/chinese/pine4/Makefile b/chinese/pine4/Makefile
index 84929d6d0688..da178178e56a 100644
--- a/chinese/pine4/Makefile
+++ b/chinese/pine4/Makefile
@@ -6,17 +6,20 @@
#
PORTNAME= pine
-PORTVERSION= 4.21
-PORTREVISION= 1
+PORTVERSION= 4.30
+PORTREVISION= 0
CATEGORIES= chinese mail news
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/
-DISTNAME= pine${PORTVERSION}
+DISTNAME= ${PORTNAME}${PORTVERSION}
-MAINTAINER= avatar@www.mmlab.cse.yzu.edu.tw
+PATCH_SITES= ftp://freebsd.ntu.edu.tw/OS/FreeBSD/taiwan/users/benedick/patch/
+PATCHFILES= patch-${PORTNAME}-${PORTVERSION}.gz
-NO_LATEST_LINK= yes
+MAINTAINER= avatar@mmlab.cse.yzu.edu.tw
-MAN1= pine.1 pico.1 pilot.1
+NO_LATEST_LINK= yes
+
+MAN1= pine.1 pico.1 pilot.1
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@@ -49,12 +52,24 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/pico ${PREFIX}/bin/pico
${INSTALL_PROGRAM} ${WRKSRC}/bin/pilot ${PREFIX}/bin/pilot
${INSTALL_PROGRAM} ${WRKSRC}/bin/pine ${PREFIX}/bin/pine
- ${INSTALL_SCRIPT} ${FILESDIR}/pgpencrypt ${PREFIX}/bin/pgpencrypt
- ${INSTALL_SCRIPT} ${FILESDIR}/pgpdecode ${PREFIX}/bin/pgpdecode
- ${INSTALL_SCRIPT} ${FILESDIR}/pgpsign ${PREFIX}/bin/pgpsign
- ${INSTALL_DATA} ${FILESDIR}/dot.pinerc.sample \
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
+ < ${FILESDIR}/pgpdecode > ${WRKSRC}/bin/pgpdecode
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
+ < ${FILESDIR}/pgpencrypt > ${WRKSRC}/bin/pgpencrypt
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
+ < ${FILESDIR}/pgpsign > ${WRKSRC}/bin/pgpsign
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpencrypt ${PREFIX}/bin/pgpencrypt
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpdecode ${PREFIX}/bin/pgpdecode
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/pgpsign ${PREFIX}/bin/pgpsign
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
+ < ${FILESDIR}/dot.pinerc.sample \
+ > ${WRKSRC}/dot.pinerc.sample
+ ${INSTALL_DATA} ${WRKSRC}/dot.pinerc.sample \
${PREFIX}/etc/dot.pinerc.sample
- ${INSTALL_DATA} ${FILESDIR}/dot.pinerc.pgp.sample \
+ ${SED} -e 's,@@PREFIX@@,${PREFIX},g' \
+ < ${FILESDIR}/dot.pinerc.pgp.sample \
+ > ${WRKSRC}/dot.pinerc.pgp.sample
+ ${INSTALL_DATA} ${WRKSRC}/dot.pinerc.pgp.sample \
${PREFIX}/etc/dot.pinerc.pgp.sample
${INSTALL_MAN} ${WRKSRC}/doc/pico.1 ${PREFIX}/man/man1/pico.1
${INSTALL_MAN} ${WRKSRC}/doc/pilot.1 ${PREFIX}/man/man1/pilot.1