aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/rxvt/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-02-15 06:22:35 +0800
committersf <sf@FreeBSD.org>2001-02-15 06:22:35 +0800
commit73d8bad76230ae72b44bd86bf07e4f2061c30631 (patch)
tree7489e40b434e26cd6afcd63afe4839e596e96240 /chinese/rxvt/Makefile
parent6762f77112a4325d4819767e1c75b6901175352f (diff)
downloadfreebsd-ports-gnome-73d8bad76230ae72b44bd86bf07e4f2061c30631.tar.gz
freebsd-ports-gnome-73d8bad76230ae72b44bd86bf07e4f2061c30631.tar.zst
freebsd-ports-gnome-73d8bad76230ae72b44bd86bf07e4f2061c30631.zip
o update to 2.7.5.
o change maintainer. PR: 24870 Submitted by: maintainer add USE_LIBTOOL and --enable-shared to install shared library.
Diffstat (limited to 'chinese/rxvt/Makefile')
-rw-r--r--chinese/rxvt/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/chinese/rxvt/Makefile b/chinese/rxvt/Makefile
index c35ca9e6e987..5ca172a115e7 100644
--- a/chinese/rxvt/Makefile
+++ b/chinese/rxvt/Makefile
@@ -6,31 +6,33 @@
#
PORTNAME= rxvt
-PORTVERSION= 2.7.3
-PORTREVISION= 1
+PORTVERSION= 2.7.5
CATEGORIES= chinese x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/ \
ftp://mason.primenet.com.au/pub/rxvt/ \
ftp://ftp.ics.es.osaka-u.ac.jp/pub/mirrors/rxvt/ \
ftp://ftp.fu-berlin.de/unix/X11/terms/rxvt/ \
${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= X11/terms
+MASTER_SITE_SUBDIR= X11/terms
DISTNAME= rxvt-${PORTVERSION}
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= rxvt-2.7.3.patch1.gz
-PATCH_DIST_STRIP+= -p1
-
-MAINTAINER= frankch@waru.life.nthu.edu.tw
+MAINTAINER= keichii@iteration.net
USE_X_PREFIX= yes
USE_XPM= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
USE_BZIP2= yes
-CONFIGURE_ARGS= --enable-xpm-background --enable-transparency \
+CONFIGURE_ARGS= --enable-xpm-background --enable-transparency \
--enable-menubar --enable-graphics --enable-xim \
- --enable-languages --with-encoding=big5
+ --disable-backspace-key --disable-delete-key \
+ --enable-rxvt-scroll --enable-next-scroll \
+ --enable-languages --with-encoding=big5 \
+ --enable-utmp --enable-wtmp --enable-shared
MAN1= crxvt.1
+post-install:
+ @${CHMOD} 4711 ${PREFIX}/bin/crxvt
+
.include <bsd.port.mk>