aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/tin
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2000-12-08 00:37:52 +0800
committerclive <clive@FreeBSD.org>2000-12-08 00:37:52 +0800
commit0ee930cf95fd2a1f350ccb4d72c21cc4fe7322c4 (patch)
tree4cdfc01b15e0d844c6ad23798d9fd83bad81ee6b /chinese/tin
parent0502fffa17ad3e909d3bde496034d38351ac5e2b (diff)
downloadfreebsd-ports-gnome-0ee930cf95fd2a1f350ccb4d72c21cc4fe7322c4.tar.gz
freebsd-ports-gnome-0ee930cf95fd2a1f350ccb4d72c21cc4fe7322c4.tar.zst
freebsd-ports-gnome-0ee930cf95fd2a1f350ccb4d72c21cc4fe7322c4.zip
Don't do isprint(3) filtering, just print it.
Before isprint(3) get fixed or any one knows how to use isprint(3) to identify multibytes characters, this temporary fix would remain here. PR: 23196 Reviewed by: People on tw.bbs.comp.386bsd newsgroup
Diffstat (limited to 'chinese/tin')
-rw-r--r--chinese/tin/Makefile3
-rw-r--r--chinese/tin/files/patch-misc.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index 14378448097f..f8253e8e7072 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -12,7 +12,8 @@ MAINTAINER= yssu@CCCA.NCTU.edu.tw
EXTRA_PATCHES= ${.CURDIR}/files/patch-charset.c \
${.CURDIR}/files/patch-cook.c \
- ${.CURDIR}/files/patch-init.c
+ ${.CURDIR}/files/patch-init.c \
+ ${.CURDIR}/files/patch-misc.c
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/tin/files/patch-misc.c b/chinese/tin/files/patch-misc.c
new file mode 100644
index 000000000000..748a3861fe06
--- /dev/null
+++ b/chinese/tin/files/patch-misc.c
@@ -0,0 +1,10 @@
+--- src/misc.c~ Thu Aug 3 21:49:22 2000
++++ src/misc.c Wed Nov 29 08:03:36 2000
+@@ -1169,6 +1169,7 @@
+ my_isprint (
+ int c)
+ {
++ return 1;
+ #ifndef NO_LOCALE
+ /* use locale */
+ return isprint(c);