aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/unrar
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-09-07 22:13:55 +0800
committerleeym <leeym@FreeBSD.org>2005-09-07 22:13:55 +0800
commitcef61fb1479021f580bea6c5f55542c6021b28ad (patch)
treeadd2aa50c39b7b5ff875520dc7edce6e89f4678a /chinese/unrar
parent0b21a5298fad917054a6ce0f70fb03ce8f6aa043 (diff)
downloadfreebsd-ports-gnome-cef61fb1479021f580bea6c5f55542c6021b28ad.tar.gz
freebsd-ports-gnome-cef61fb1479021f580bea6c5f55542c6021b28ad.tar.zst
freebsd-ports-gnome-cef61fb1479021f580bea6c5f55542c6021b28ad.zip
- update patch, fix build, and unbreak this port
Diffstat (limited to 'chinese/unrar')
-rw-r--r--chinese/unrar/Makefile2
-rw-r--r--chinese/unrar/files/patch-unicode.cpp16
2 files changed, 8 insertions, 10 deletions
diff --git a/chinese/unrar/Makefile b/chinese/unrar/Makefile
index c611b48ab470..d9ef056b47d8 100644
--- a/chinese/unrar/Makefile
+++ b/chinese/unrar/Makefile
@@ -9,8 +9,6 @@ CATEGORIES= chinese
MAINTAINER= ports@FreeBSD.org
-BROKEN= "Patch fails"
-
MASTERDIR= ${.CURDIR}/../../archivers/unrar
EXTRA_PATCHES= ${.CURDIR}/files/patch-arcread.cpp \
diff --git a/chinese/unrar/files/patch-unicode.cpp b/chinese/unrar/files/patch-unicode.cpp
index 052669a6bd34..14bfc0dac269 100644
--- a/chinese/unrar/files/patch-unicode.cpp
+++ b/chinese/unrar/files/patch-unicode.cpp
@@ -1,10 +1,10 @@
---- unicode.cpp.orig Wed Sep 8 21:57:20 2004
-+++ unicode.cpp Tue Oct 26 01:49:46 2004
-@@ -6,6 +6,7 @@
-
- void WideToChar(const wchar *Src,char *Dest,int DestSize)
+--- unicode.cpp.orig Thu Aug 4 00:34:30 2005
++++ unicode.cpp Wed Sep 7 22:01:58 2005
+@@ -7,6 +7,7 @@
+ bool WideToChar(const wchar *Src,char *Dest,int DestSize)
{
-+ return; /* patch for chinese filename */
+ bool RetCode=true;
++ return(RetCode); /* patch for chinese filename */
#ifdef _WIN_32
- WideCharToMultiByte(CP_ACP,0,Src,-1,Dest,DestSize,NULL,NULL);
- #else
+ if (WideCharToMultiByte(CP_ACP,0,Src,-1,Dest,DestSize,NULL,NULL)==0)
+ RetCode=false;