aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/vflib/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-01-31 11:22:16 +0800
committerarved <arved@FreeBSD.org>2004-01-31 11:22:16 +0800
commitc05fcf1c0fc4693d005e5cda44e523349a344c36 (patch)
treedda3ec62139372cb7789087d0009a9f79b08cae7 /chinese/vflib/Makefile
parentb7fcc33e74f0ef35781c94828f1befa5a7e7787a (diff)
downloadfreebsd-ports-gnome-c05fcf1c0fc4693d005e5cda44e523349a344c36.tar.gz
freebsd-ports-gnome-c05fcf1c0fc4693d005e5cda44e523349a344c36.tar.zst
freebsd-ports-gnome-c05fcf1c0fc4693d005e5cda44e523349a344c36.zip
s/varargs.h/stdarg.h/
Diffstat (limited to 'chinese/vflib/Makefile')
-rw-r--r--chinese/vflib/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/chinese/vflib/Makefile b/chinese/vflib/Makefile
index a206aaf95c51..613c318702fb 100644
--- a/chinese/vflib/Makefile
+++ b/chinese/vflib/Makefile
@@ -31,19 +31,19 @@ USE_FREETYPE= yes
USE_XLIB= yes
USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-freetype \
--with-freetype-includedir=${PREFIX}/include/freetype1/freetype \
--with-freetype-libdir=${PREFIX}/lib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (need to replace varargs.h with stdarg.h)"
-.endif
-
pre-patch:
@${SED} -e "s;%%LOCALBASE%%;${LOCALBASE};g" -e "s;%%X11BASE%%;${X11BASE};g" ${DISTDIR}/zh-vfontcap.in > ${WRKSRC}/vfontcap
+post-patch:
+ ${REINPLACE_CMD} -e "s,varargs.h,stdarg.h," ${WRKSRC}/tools/disol.c
+
pre-install:
@(cd ${WRKSRC}/tools; \
${INSTALL_SCRIPT} fmtest disol kban vfperf vftest ${PREFIX}/bin)