aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/zhcon/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-10-27 00:37:44 +0800
committerleeym <leeym@FreeBSD.org>2004-10-27 00:37:44 +0800
commit5da71347665655b45f45e288cc143e21c414d75c (patch)
tree4d90a23e277e85af99186f2c857601f5438bcf4b /chinese/zhcon/Makefile
parentee0e219571f8a3c5ffe6f3f4034348f46465e0b7 (diff)
downloadfreebsd-ports-gnome-5da71347665655b45f45e288cc143e21c414d75c.tar.gz
freebsd-ports-gnome-5da71347665655b45f45e288cc143e21c414d75c.tar.zst
freebsd-ports-gnome-5da71347665655b45f45e288cc143e21c414d75c.zip
- wrap USE_GETTEXT by adding "if !defined(WITHOUT_NLS)"
- use system libintl instead of included one
Diffstat (limited to 'chinese/zhcon/Makefile')
-rw-r--r--chinese/zhcon/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index a914e96c643c..ead2bbf7e285 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -16,16 +16,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A fast Console Chinese System which supports framebuffer device
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-included-gettext=${LOCALBASE}
-USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
USE_GMAKE= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
MAN1= zhcon.1
post-patch:
@${REINPLACE_CMD} -Ee 's,(\s*=\s*)("?)/usr/local([^"]*)("?),\1\2${PREFIX}\3\4,g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
+ -e '/_nl_expand_alias/s,\(0\),\(\),g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>