aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/zhcon/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2002-11-28 10:25:03 +0800
committervanilla <vanilla@FreeBSD.org>2002-11-28 10:25:03 +0800
commitbb9aa265c222d9c163616b751db3312a2cefa546 (patch)
treec3b95e0efafca6165d0f5aa40a8860dc51eab305 /chinese/zhcon/Makefile
parent54c3aedeb1950717aa659a0ca5fdac0a889ac564 (diff)
downloadfreebsd-ports-gnome-bb9aa265c222d9c163616b751db3312a2cefa546.tar.gz
freebsd-ports-gnome-bb9aa265c222d9c163616b751db3312a2cefa546.tar.zst
freebsd-ports-gnome-bb9aa265c222d9c163616b751db3312a2cefa546.zip
1: Upgrade to 0.2.1.
2: Fix build on -current. 3: Fix hangs on -current. PR: ports/45797 Submitted by: maintainer Approved by: kris
Diffstat (limited to 'chinese/zhcon/Makefile')
-rw-r--r--chinese/zhcon/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index 0df5a24c7ae6..134e2dae8b46 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zhcon
-PORTVERSION= 0.2
-PORTREVISION= 4
+PORTVERSION= 0.2.1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,6 +19,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-included-gettext=${LOCALBASE}
USE_GMAKE= yes
USE_REINPLACE= yes
+REINPLACE_ARGS= # empty
+USE_XLIB= yes
MAN1= zhcon.1
@@ -27,7 +28,11 @@ MAN1= zhcon.1
post-patch:
.if ${OSVERSION} > 500012
- @${FIND} ${WRKSRC}/src/ -name "*.cpp" | ${XARGS} ${REINPLACE_CMD} -e 's,machine/console.h>,sys/consio.h>\n#include <sys/fbio.h>\n#include <sys/kbio.h>\n,'
+.for i in src/main.cpp src/zhcon.cpp src/inputmanager.cpp src/display/fbdev.cpp src/mouse.h
+ ${REINPLACE_CMD} 's,machine/console.h>,sys/consio.h>@#include <sys/fbio.h>@#include <sys/kbio.h>,' ${WRKSRC}/${i} | tr '@' '\n' > ${WRKSRC}/${i}.bak && \
+ ${MV} ${WRKSRC}/${i}.bak ${WRKSRC}/${i}
+.endfor
+ ${REINPLACE_CMD} -i.bak -e 's,machine/mouse.h>,sys/mouse.h>,' ${WRKSRC}/src/mouse.h
.endif
.include <bsd.port.post.mk>