aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/zhcon/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-09-11 12:49:46 +0800
committerclive <clive@FreeBSD.org>2001-09-11 12:49:46 +0800
commitec2f20952ddf4c8fcc1f446a72f0529d1b7c3489 (patch)
tree68261900bca249b3aab0693bdf538996044d72af /chinese/zhcon/Makefile
parentc4f0d132c61bf9c415ffbb4b7a6483d45f7c456f (diff)
downloadfreebsd-ports-gnome-ec2f20952ddf4c8fcc1f446a72f0529d1b7c3489.tar.gz
freebsd-ports-gnome-ec2f20952ddf4c8fcc1f446a72f0529d1b7c3489.tar.zst
freebsd-ports-gnome-ec2f20952ddf4c8fcc1f446a72f0529d1b7c3489.zip
o Add Big5 IME support.
o Bump PORTREVISION. PR: ports/30498 Submitted by: Yen-Ming Lee <leeym@utopia.leeym.com> Reminded by: MAINTAINER
Diffstat (limited to 'chinese/zhcon/Makefile')
-rw-r--r--chinese/zhcon/Makefile45
1 files changed, 42 insertions, 3 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index cc5628271e7f..90bda9bac738 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -7,10 +7,12 @@
PORTNAME= zhcon
PORTVERSION= 0.14f
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= chinese
MASTER_SITES= http://freebsd.sinica.edu.tw/~statue/ \
- ftp://ftp.gnuchina.org/pub/linux/chinese/inputmethod/console/zhcon/BSDPort/
+ ftp://ftp.gnuchina.org/pub/linux/chinese/inputmethod/console/zhcon/BSDPort/ \
+ http://www.cis.nctu.edu.tw/~gis89501/zhcon/
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} zhb5-ime-0.tgz
MAINTAINER= statue@freebsd.sinica.edu.tw
@@ -20,8 +22,45 @@ USE_GMAKE= yes
MAN1= zhcon.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 500012
+
+.if defined(WITH_BIG5)
+PLIST_SUB+= BIG5IME=""
+.else
+PLIST_SUB+= BIG5IME="@comment "
+.endif
+
+.if !defined(WITH_BIG5)
+pre-everything:
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Big5 IME support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BIG5=yes\""
+ @${ECHO_MSG}
+.endif
+
post-patch:
+.if ${OSVERSION} > 500012
@${PERL} -pi -e 's,machine/console.h>,sys/consio.h>\n#include <sys/fbio.h>\n#include <sys/kbio.h>\n,' ${WRKSRC}/${PORTNAME}/*.cpp
.endif
+.if defined(WITH_BIG5)
+ @${PATCH} ${PATCH_DIST_ARGS:S/${WRKSRC}/${WRKDIR}\/zh-big5-ime/} < ${PATCHDIR}/extrapatch-aa
+.for file in zhcon-0.14-big5-bar.diff.gz zhcon-0.14-big5-dirty-ime.diff.gz
+ @${GZCAT} ${WRKDIR}/zh-big5-ime/${file} | ${PATCH} ${PATCH_DIST_ARGS:S/p0/p1/}
+.endfor
+.endif
+
+post-build:
+.if defined(WITH_BIG5)
+.for file in make.sh make-mb.sh
+ @cd ${WRKDIR}/zh-big5-ime; ${SH} ${file}
+.endfor
+.endif
+
+post-install:
+.if defined(WITH_BIG5)
+.for file in big5-ary30.mb big5-cj.mb big5-liu5.mb big5-phone.mb
+ @${INSTALL_DATA} ${WRKDIR}/zh-big5-ime/mb/${file} ${PREFIX}/lib/zhcon
+.endfor
+ @${INSTALL_DATA} ${WRKDIR}/zh-big5-ime/zhcon.cfg.big5 ${PREFIX}/lib/zhcon/zhcon.cfg
+.endif
+
.include <bsd.port.post.mk>