aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/zhcon
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2006-07-19 23:43:33 +0800
committervanilla <vanilla@FreeBSD.org>2006-07-19 23:43:33 +0800
commit89808d22cbe01c629c1e281988a2a4dc0ddae15a (patch)
treed8a6c43b34b8a7b4dc1c47fa76ab7a229cee64d7 /chinese/zhcon
parenta4a366fa6f3e64980530a23c12de1b3c0726fbc6 (diff)
downloadfreebsd-ports-gnome-89808d22cbe01c629c1e281988a2a4dc0ddae15a.tar.gz
freebsd-ports-gnome-89808d22cbe01c629c1e281988a2a4dc0ddae15a.tar.zst
freebsd-ports-gnome-89808d22cbe01c629c1e281988a2a4dc0ddae15a.zip
- Fix input error on some Big5 range
- Summitted by Edward G.J. Lee <edt1023@info.sayya.org> Thanks. PR: ports/100545 Submitted by: maintainer
Diffstat (limited to 'chinese/zhcon')
-rw-r--r--chinese/zhcon/Makefile1
-rw-r--r--chinese/zhcon/files/patch-src-winime.cpp11
-rw-r--r--chinese/zhcon/files/patch-src-winime.h15
3 files changed, 27 insertions, 0 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index b12d100952a4..856b9f89fa63 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zhcon
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/chinese/zhcon/files/patch-src-winime.cpp b/chinese/zhcon/files/patch-src-winime.cpp
new file mode 100644
index 000000000000..c017310bfebf
--- /dev/null
+++ b/chinese/zhcon/files/patch-src-winime.cpp
@@ -0,0 +1,11 @@
+--- src/winime.cpp.orig Tue Apr 25 00:38:28 2006
++++ src/winime.cpp Wed Jul 19 22:29:47 2006
+@@ -184,6 +184,8 @@
+ p++;
+ while (IsGB2312_1(*p) && IsGB2312_2(*(p + 1)))
+ p += 2;
++ while (IsBIG5_1(*p) && IsBIG5_2(*(p + 1)))
++ p += 2;
+ return !IsHzCode1(*p);
+ }
+
diff --git a/chinese/zhcon/files/patch-src-winime.h b/chinese/zhcon/files/patch-src-winime.h
new file mode 100644
index 000000000000..1b878902fa0b
--- /dev/null
+++ b/chinese/zhcon/files/patch-src-winime.h
@@ -0,0 +1,15 @@
+--- src/winime.h.orig Tue Apr 25 00:38:26 2006
++++ src/winime.h Wed Jul 19 22:27:58 2006
+@@ -68,6 +68,12 @@
+ bool IsGB2312_2(char c) const {
+ return c >= 0xA1 && c <= 0xFE;
+ }
++ bool IsBIG5_1(char c) const {
++ return c >= 0xA1 && c <= 0xFE;
++ }
++ bool IsBIG5_2(char c) const {
++ return c >= 0x40 && c <= 0x7E;
++ }
+
+ void AddCandilist(char*& p,unsigned& buflen);
+ void SkipNext(char*& rp);