aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-05-15 14:16:33 +0800
committerijliao <ijliao@FreeBSD.org>2003-05-15 14:16:33 +0800
commite10ad403879c71c21c6743958c3d5641bc2cc538 (patch)
treeec8175516f1e53bf102fb1bdec226864e4973606 /chinese
parente2f84deaaa5df3fe2cc2d00536483c2a827733dc (diff)
downloadfreebsd-ports-gnome-e10ad403879c71c21c6743958c3d5641bc2cc538.tar.gz
freebsd-ports-gnome-e10ad403879c71c21c6743958c3d5641bc2cc538.tar.zst
freebsd-ports-gnome-e10ad403879c71c21c6743958c3d5641bc2cc538.zip
1. dont specify -lgnugetopt in Makefile
2. respect CFLAGS 3. utilize BSD_INSTALL_* macro
Diffstat (limited to 'chinese')
-rw-r--r--chinese/autoconvert/Makefile8
-rw-r--r--chinese/autoconvert/files/patch-aa18
2 files changed, 17 insertions, 9 deletions
diff --git a/chinese/autoconvert/Makefile b/chinese/autoconvert/Makefile
index 52673313d663..5318bc8ce632 100644
--- a/chinese/autoconvert/Makefile
+++ b/chinese/autoconvert/Makefile
@@ -13,10 +13,18 @@ MASTER_SITES= http://people.debian.org/~ygh/
MAINTAINER= yinjieh@csie.nctu.edu.tw
COMMENT= Intelligent Chinese encoding converter
+USE_REINPLACE= yes
USE_GETOPT_LONG= yes
+CFLAGS+= "${CPPFLAGS}"
+MAKE_ENV= CFLAG="${CPPFLAGS}" LIBS="${LDFLAGS}"
INSTALLS_SHLIB= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX}${PORTNAME}
+post-patch:
+.for dir in hzconvert contrib/xchat-plugins
+ @${REINPLACE_CMD} -e "s|^CFLAGS|#CLFAGS|" ${WRKSRC}/${dir}/Makefile
+.endfor
+
pre-install:
@${MKDIR} ${DATADIR}
.for i in ChangeLog LICENSE Readme TODO Thanks Version hz.txt procmailrc.example shed.big5 shed.gb shed.uni shed.utf7 shed.utf8
diff --git a/chinese/autoconvert/files/patch-aa b/chinese/autoconvert/files/patch-aa
index 89511447ecb7..acb87a179abb 100644
--- a/chinese/autoconvert/files/patch-aa
+++ b/chinese/autoconvert/files/patch-aa
@@ -1,12 +1,12 @@
--- Makefile.orig Sat Apr 28 09:45:46 2001
-+++ Makefile Thu Aug 9 23:31:09 2001
++++ Makefile Thu May 15 13:52:33 2003
@@ -1,7 +1,7 @@
CC=gcc
-CFLAG=-O2 -g -Wall -Iinclude
-LIBS= -Llib -lhz
-+CFLAG+=-Iinclude -I/usr/local/include
-+LIBS+=-Llib -lhz -L/usr/local/lib -lgnugetopt
++CFLAG+=-Iinclude
++LIBS+=-Llib -lhz
.PHONY: all hzlib clean install-home install
@@ -23,11 +23,11 @@
- install -m 755 contrib/xchat-plugins/xchat-autob5.so $(DESTDIR)/usr/share/zh-autoconvert
- install -m 644 include/*.h $(DESTDIR)/usr/include
- ln -s autogb $(DESTDIR)/usr/bin/autob5
-+ install -m 755 autogb $(PREFIX)/bin
-+ install -m 755 lib/libhz.so.0.0 $(PREFIX)/lib/libhz.so.0
++ ${BSD_INSTALL_PROGRAM} autogb $(PREFIX)/bin
++ ${BSD_INSTALL_PROGRAM} lib/libhz.so.0.0 $(PREFIX)/lib/libhz.so.0
+ cd $(PREFIX)/lib;ln -s libhz.so.0 libhz.so
-+ install -m 755 lib/libhz.a $(PREFIX)/lib
-+ install -m 755 contrib/xchat-plugins/xchat-autogb.so $(PREFIX)/share/zh-autoconvert
-+ install -m 755 contrib/xchat-plugins/xchat-autob5.so $(PREFIX)/share/zh-autoconvert
-+ install -m 644 include/*.h $(PREFIX)/include
++ ${BSD_INSTALL_PROGRAM} lib/libhz.a $(PREFIX)/lib
++ ${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autogb.so $(PREFIX)/share/zh-autoconvert
++ ${BSD_INSTALL_PROGRAM} contrib/xchat-plugins/xchat-autob5.so $(PREFIX)/share/zh-autoconvert
++ ${BSD_INSTALL_DATA} include/*.h $(PREFIX)/include
+ ln -s autogb $(PREFIX)/bin/autob5
d>- Update to 3.2.9bdrewery2017-02-044-102/+4 * - Fix regression from last commit with -Wpbdrewery2017-02-042-1/+24 * - Fix building with -Wp,-MT,path. Namely this fixes buildingbdrewery2017-02-042-1/+76 * - Add links for clang39amdmi32016-08-171-2/+2 * - Add links for gcc 7amdmi32016-05-311-2/+2 * - Fix trailing whitespace in pkg-messagesamdmi32016-05-191-1/+1 * - Update to 3.2.5bdrewery2016-04-192-4/+4 * - Add links for clang38amdmi32016-02-111-2/+2 * - Don't cache -fcolor-diagnostics.bdrewery2016-02-112-2/+36 * Regenerate patchesbdrewery2016-02-113-8/+8 * - Fix defining of strndup(3) prototype due to improperly definedbdrewery2015-10-282-1/+21 * Update to 3.2.4.bdrewery2015-10-165-32/+10 * - Switch to options helpersamdmi32015-10-081-7/+5 * Remove deprecated @exec/@unexec from ports using ccache-update-linksantoine2015-09-261-3/+3 * Update to 3.2.3.bdrewery2015-09-054-4/+29 * Always default CCACHE_CPP2 to 1, otherwise a build error with parenthesis canbdrewery2015-09-042-13/+3 * - Remove obsolete clang linksamdmi32015-08-201-2/+2 * - Add links for clang37amdmi32015-08-191-2/+2 * - Drop @dirrm* from plistamdmi32015-07-131-3/+0 * Enable CLANG/LLVM links by default.bdrewery2015-06-062-12/+2 * Update to 3.2.2bdrewery2015-06-012-4/+4 * - Add links for gcc6amdmi32015-05-071-2/+2 * - Add link for clang36amdmi32015-04-231-2/+2 * Fix use with clang. CCACHE_CPP2 is still required. Otherwise thebdrewery2015-01-172-1/+25 * Fix sanitybdrewery2015-01-071-2/+2 * - Update to 3.2.1bdrewery2015-01-076-248/+35 * Move MASTER_SITES from CRITICAL to LOCAL/ehauptehaupt2015-01-061-1/+1 * - Add links for newer compilers: gcc5, clang35 and clang-develamdmi32014-12-111-3/+3 * - Update to 3.1.10bdrewery2014-10-282-4/+4 * Enable colors by defaultbdrewery2014-05-181-1/+2 * - Fix GCC detectionbdrewery2014-03-021-2/+2 * Fix the build after r346759.rakuco2014-03-021-1/+1 * - Add COLORS option to enable contributed colors patch that uses colorsbdrewery2014-03-022-2/+214 * - Create CC symlinkbdrewery2014-02-131-2/+2 * - Add support for clang31,32,33,34 linksbdrewery2014-01-311-3/+4 * - Convert to stagingbdrewery2013-10-103-28/+28 * - Add NO_STAGE until validated to be safe for upcoming staging supportbdrewery2013-09-201-0/+1 * Convert to new options helpersbdrewery2013-06-141-4/+2 * - Always enable CCACHE_CPP2 on CURRENT after clang became the default.bdrewery2013-05-092-1/+31 * - Fix ccache for CURRENT world builds by automatically definingbdrewery2013-04-233-2/+9 * - Take maintainershipbdrewery2013-03-071-2/+2 * - Use DOC instead of NOPORTDOCSehaupt2013-01-151-2/+2 * Update to 3.1.9ehaupt2013-01-072-3/+3 * Restore 'Created by' header information. This has been removed during theehaupt2012-11-041-0/+1 * - Use OPTIONSngehaupt2012-09-081-14/+10 * Update to 3.1.8ehaupt2012-08-122-4/+3 * Add additional compiler links for tinderbox ccache tarball.ehaupt2012-08-071-2/+2 * Add links for newer gcc versions.ehaupt2012-05-291-1/+2 * Fix a typo.ehaupt2012-03-301-1/+1 * Add an option to statically build ccache.ehaupt2012-01-301-1/+6 * Update to 3.1.7ehaupt2012-01-092-4/+4 * Improve english grammar.ehaupt2011-12-271-1/+1 * Improve grammar and use @dirrmtryehaupt2011-12-273-5/+5 * Update to 3.1.6ehaupt2011-11-242-4/+3 * Add options to create compiler links for clang and llvm. Also add a warningehaupt2011-10-022-2/+24 * Restore the possibility to define EXTRA_COMPILERS which must reside in $PATH.ehaupt2011-08-042-1/+3 * Update to 3.1.5ehaupt2011-06-122-4/+3 * Provide 'ccache.tar' tarball for easy use with ports-mgmt/tinderbox.ehaupt2011-03-302-1/+15 * Add pkg-plistehaupt2011-03-291-0/+8 * Only create symlinks for existing compiler. This functionality is outsourcedehaupt2011-03-294-49/+75 * Allow the use of non-default compilers such as clang.ehaupt2011-02-285-21/+31 * Update to 3.1.4ehaupt2011-01-112-3/+3 * Update to 3.1.3ehaupt2010-12-012-4/+3 * Provide make.conf/src.conf instructions that still allow ccache to be used forehaupt2010-11-182-7/+5 * Update instructions on how to workaround a buildworld failure.ehaupt2010-11-172-0/+5 * Update to 3.1.1ehaupt2010-11-082-4/+3 * Fix installation of a document file.ehaupt2010-09-271-1/+1 * Update to 3.1ehaupt2010-09-272-6/+5 * Provide symlinks for clang and llvm-gcc compilers in addition to gccehaupt2010-09-161-1/+2 * - Oops, revert previous commit - I meant to do a send-pramdmi32010-09-161-2/+1 * - Provide symlinks for clang and llvm-gcc compilers as wellamdmi32010-09-161-0/+2 * Update to 3.0.1ehaupt2010-07-319-240/+15 * Take maintainershipehaupt2010-07-261-1/+1 * Reset ahze@ due to maintainer-timeouts and no response to email.linimon2010-07-261-1/+1 * - Fix bug with mmap() on 8.x [1]ahze2009-08-052-14/+15 * Fix a bug in x_realloc() which tries to read out too many bytes from the old ...ahze2008-11-242-1/+26 * Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.rafan2008-08-211-1/+0 * Add links to gcc44 and gcc-ooo, only add links to gcc295 on i386 and alphaahze2008-04-081-4/+7 * Add links to gcc43ahze2006-11-191-2/+2 * - Remove gcc35 linkahze2006-10-061-2/+2 * - Add CCACHE_CACHE_COMPILER patchale2006-03-216-33/+50 * - Update MASTER_SITES to fix fetchahze2006-03-081-1/+1 * - Fix example so it works better with make buildworld if you define NOCCACHEahze2006-01-122-4/+3 * Attempt to attract maintainer's attention to a problem a lot ofru2006-01-111-0/+1 * - Add support to turn off hasing the compiler size and mtime via aahze2005-11-163-1/+35 * - Add SHA256ahze2005-11-091-0/+1 * - Add support for gcc41ahze2005-10-031-1/+1 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * - Add a note to icc users about adding LOCALBASE/intel_cc_80/bin to CCACHE_PATHahze2005-02-212-1/+5 * Fix another typoahze2005-02-051-1/+1 * - Back out of last commit, this does not work like I intendedahze2005-02-041-1/+1 * - Update howto example so make [build]kernel uses ccache.ahze2005-02-041-1/+1 * Correct stupid typoahze2005-02-041-1/+1 * - Add a note in howto about changeing the default cache location since the de...ahze2005-02-041-2/+14 * s/LOCALBASE/DOCSDIR/ in pkg-messageahze2004-12-122-3/+3 * - Don't use PKGMESSAGE or install HOWTO if WITHOUT_COMPILER_LINKS is definedahze2004-12-071-0/+4 * - Add a note about reinstalling libtool15 when you change CC/CXXahze2004-12-052-1/+4 * Add more to the example so you can disable ccache with out having to change PATHahze2004-12-031-0/+3 * - Add a link to gcc32 since it's still used in some ports (ie openoffice)ahze2004-12-023-29/+71 * add link to gcc40ahze2004-11-021-1/+1 * Change email to new FreeBSD.org addressahze2004-10-301-1/+1 * - Reword pkg-messagepav2004-10-151-6/+6 * Removed trash at the end of the Makefile.edwin2004-10-131-1/+1 * [MAINTAINER] devel/ccache: update to 2.4edwin2004-10-134-67/+148 * - Remove STRIP_CMDkrion2004-04-191-1/+2 * Use INSTALL_MAN and INSTALL_PROGRAM macros.trevor2004-04-191-1/+3 * - Assign maintainership to submitterkrion2004-04-181-2/+3 * - Add PORTDOCSkrion2004-03-301-0/+12 * Use PLIST_FILES.trevor2004-02-062-1/+1 * SIZEify.trevor2004-01-291-0/+1 * Update to 0.3.naddy2003-09-282-2/+2 * Cease FreeBSD port maintainershipsedwin2003-09-24