aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1997-02-08 08:40:12 +0800
committerobrien <obrien@FreeBSD.org>1997-02-08 08:40:12 +0800
commit67b302f5e28832e35f9eef1918fa64e47f8f034c (patch)
tree9c064ee41efd1f99410f49cadee1e4df9c649804 /chinese
parent261a5cdaa078fd3e0b778923025145664df21cc6 (diff)
downloadfreebsd-ports-gnome-67b302f5e28832e35f9eef1918fa64e47f8f034c.tar.gz
freebsd-ports-gnome-67b302f5e28832e35f9eef1918fa64e47f8f034c.tar.zst
freebsd-ports-gnome-67b302f5e28832e35f9eef1918fa64e47f8f034c.zip
The lunar program performs date conversion between the Gregorian Solar
Calendar (SC) and the Chinese Lunar Calendar (LC).
Diffstat (limited to 'chinese')
-rw-r--r--chinese/lunar/Makefile29
-rw-r--r--chinese/lunar/distinfo1
-rw-r--r--chinese/lunar/files/patch-0112
-rw-r--r--chinese/lunar/files/patch-0222
-rw-r--r--chinese/lunar/pkg-comment1
-rw-r--r--chinese/lunar/pkg-descr13
-rw-r--r--chinese/lunar/pkg-plist3
7 files changed, 81 insertions, 0 deletions
diff --git a/chinese/lunar/Makefile b/chinese/lunar/Makefile
new file mode 100644
index 000000000000..e399113c1753
--- /dev/null
+++ b/chinese/lunar/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: lunar
+# Version required: 2.1
+# Date created: Mon Feb 03, 1997
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= lunar-2.1
+PKGNAME= cn-lunar-2.1
+CATEGORIES= chinese
+MASTER_SITES= ftp://ftp.ifcss.org/pub/software/unix/c-utils/ \
+ ftp://ftp.edu.tw/Chinese/ifcss/software/unix/c-utils/ \
+ ftp://ftp.cuhk.hk/pub/chinese/ifcss/software/unix/c-utils/
+
+MAINTAINER= obrien@NUXI.com
+
+ALL_TARGET=
+MAN1= lunar.1
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/chinese
+ ${INSTALL_PROGRAM} ${WRKSRC}/lunar ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/lunar.bitmap ${PREFIX}/share/chinese
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+
+.include <bsd.port.mk>
diff --git a/chinese/lunar/distinfo b/chinese/lunar/distinfo
new file mode 100644
index 000000000000..832a84840eec
--- /dev/null
+++ b/chinese/lunar/distinfo
@@ -0,0 +1 @@
+MD5 (lunar-2.1.tar.gz) = 399683498a01615b3a68dceff09581b2
diff --git a/chinese/lunar/files/patch-01 b/chinese/lunar/files/patch-01
new file mode 100644
index 000000000000..34d3fd70306e
--- /dev/null
+++ b/chinese/lunar/files/patch-01
@@ -0,0 +1,12 @@
+--- Makefile.orig Mon Aug 10 21:14:48 1992
++++ Makefile Tue Feb 4 01:20:50 1997
+@@ -1,6 +1,8 @@
+ # Makefile of LUNAR
+
+-CFLAGS= -O
++CFLAGS= -O -DBITMAPFILE=\"$(BITMAPFILE)\"
++
++BITMAPFILE= $(PREFIX)/share/chinese/lunar.bitmap
+
+ lunar: lunar.o
+ cc -o lunar lunar.o
diff --git a/chinese/lunar/files/patch-02 b/chinese/lunar/files/patch-02
new file mode 100644
index 000000000000..8667e0ba005e
--- /dev/null
+++ b/chinese/lunar/files/patch-02
@@ -0,0 +1,22 @@
+--- lunar.c.orig Mon Aug 10 21:14:48 1992
++++ lunar.c Tue Feb 4 01:04:18 1997
+@@ -60,6 +60,10 @@
+ #define GanBM 4
+ #define ZhiBM 14
+
++#ifndef BITMAPFILE
++#define BITMAPFILE "lunar.bitmap"
++#endif
++
+ typedef struct {
+ int year, month, day, hour, weekday;
+ int leap; /* the lunar month is a leap month */
+@@ -124,7 +128,7 @@
+
+ int showHZ = 0; /* output in hanzi */
+ int showBM = 0; /* output in bitmap */
+-char BMfile[] = "lunar.bitmap"; /* bit map file */
++char BMfile[] = BITMAPFILE; /* bit map file */
+ char GZBM[NBM][BMRow][BMCol]; /* the bitmap array */
+ char *progname;
+
diff --git a/chinese/lunar/pkg-comment b/chinese/lunar/pkg-comment
new file mode 100644
index 000000000000..b9a9b8765788
--- /dev/null
+++ b/chinese/lunar/pkg-comment
@@ -0,0 +1 @@
+convert between the Gregorian Solar Calendar (SC) and the Lunar Calendar (LC).
diff --git a/chinese/lunar/pkg-descr b/chinese/lunar/pkg-descr
new file mode 100644
index 000000000000..d9e42c95876d
--- /dev/null
+++ b/chinese/lunar/pkg-descr
@@ -0,0 +1,13 @@
+The lunar program performs date conversion between the Gregorian Solar
+Calendar (SC) and the Chinese Lunar Calendar (LC).
+
+Given a date in either calendar, the program also outputs the corresponding
+"shengxiao" (animal of the year) and "ganzhi" characters.
+
+The date range currently covered is from about 1900 A.D. to 2049 A.D.
+
+The standard time of the Lunar Calendar is Beijing (Hong Kong) Standard Time,
+not GMT. Be sure to adjust appropriately for other time zones and "Day-light
+Saving Time".
+
+-- David O'Brien
diff --git a/chinese/lunar/pkg-plist b/chinese/lunar/pkg-plist
new file mode 100644
index 000000000000..d289ca0eabbe
--- /dev/null
+++ b/chinese/lunar/pkg-plist
@@ -0,0 +1,3 @@
+bin/lunar
+share/chinese/lunar.bitmap
+man/man1/lunar.1.gz