aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-01-23 03:31:45 +0800
committerpi <pi@FreeBSD.org>2018-01-23 03:31:45 +0800
commit8d0db68465d8855bbb0e7c96067e5d26a51873fc (patch)
tree4991522198e01b6cd77b505427b7a13c638d9116 /chinese
parent5ea56195a7dc047a4788f18d18a65da2930ba780 (diff)
downloadfreebsd-ports-gnome-8d0db68465d8855bbb0e7c96067e5d26a51873fc.tar.gz
freebsd-ports-gnome-8d0db68465d8855bbb0e7c96067e5d26a51873fc.tar.zst
freebsd-ports-gnome-8d0db68465d8855bbb0e7c96067e5d26a51873fc.zip
New port: chinese/ibus-cangjie
This is an IBus engine for users of the Cangjie and Quick input methods. It is primarily intended to Hong Kong people who want to input Traditional Chinese, as they are (by far) the majority of Cangjie and Quick users. WWW: http://cangjians.github.io/projects/ibus-cangjie/ PR: 225259 Submitted by: owen94012@gmail.com
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/ibus-cangjie/Makefile38
-rw-r--r--chinese/ibus-cangjie/distinfo3
-rw-r--r--chinese/ibus-cangjie/files/patch-autogen.sh8
-rw-r--r--chinese/ibus-cangjie/files/patch-configure.ac13
-rw-r--r--chinese/ibus-cangjie/pkg-descr8
-rw-r--r--chinese/ibus-cangjie/pkg-plist28
7 files changed, 99 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 29763ebec243..6d3a376c8db2 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -52,6 +52,7 @@
SUBDIR += gydict
SUBDIR += hc
SUBDIR += ibus-array
+ SUBDIR += ibus-cangjie
SUBDIR += ibus-chewing
SUBDIR += ibus-libpinyin
SUBDIR += ibus-pinyin
diff --git a/chinese/ibus-cangjie/Makefile b/chinese/ibus-cangjie/Makefile
new file mode 100644
index 000000000000..5b2d520d4ede
--- /dev/null
+++ b/chinese/ibus-cangjie/Makefile
@@ -0,0 +1,38 @@
+# Created by: blubee <hello@blubee.me>
+# $FreeBSD$
+
+PORTNAME= ibus-cangjie
+PORTVERSION= 2.4
+DISTVERSIONPREFIX= v
+CATEGORIES= chinese
+
+MAINTAINER= hello@blubee.me
+COMMENT= IBus engine for users of the Cangjie and Quick
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libibus-1.0.so:textproc/ibus
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cangjie/_core.so:chinese/pycangjie \
+ ${PYTHON_SITELIBDIR}/pycanberra/pycanberra.py:devel/pycanberra@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/cangjie/_core.so:chinese/pycangjie \
+ ${PYTHON_SITELIBDIR}/pycanberra/pycanberra.py:devel/pycanberra@${PY_FLAVOR}
+
+USES= autoreconf gmake libtool pkgconfig python:3.4+
+USE_PYTHON= allflavors
+USE_GNOME= introspection:run pygobject3 intltool
+GLIB_SCHEMAS= org.cangjians.ibus.cangjie.gschema.xml \
+ org.cangjians.ibus.quick.gschema.xml
+
+OPTIONS_DEFINE= NLS
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= gettext
+
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= Cangjians
+GH_PROJECT= ibus-cangjie
+
+.include <bsd.port.mk>
diff --git a/chinese/ibus-cangjie/distinfo b/chinese/ibus-cangjie/distinfo
new file mode 100644
index 000000000000..602b2832b9c7
--- /dev/null
+++ b/chinese/ibus-cangjie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509798473
+SHA256 (Cangjians-ibus-cangjie-v2.4_GH0.tar.gz) = 632b38bf8fe979fbbe50fe0cee5322fe2f5c815c3ad0e800c0bdab7e3b814043
+SIZE (Cangjians-ibus-cangjie-v2.4_GH0.tar.gz) = 38549
diff --git a/chinese/ibus-cangjie/files/patch-autogen.sh b/chinese/ibus-cangjie/files/patch-autogen.sh
new file mode 100644
index 000000000000..61fdd8c561fe
--- /dev/null
+++ b/chinese/ibus-cangjie/files/patch-autogen.sh
@@ -0,0 +1,8 @@
+--- autogen.sh.orig 2015-03-29 15:19:21 UTC
++++ autogen.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ set -e
+ set -x
diff --git a/chinese/ibus-cangjie/files/patch-configure.ac b/chinese/ibus-cangjie/files/patch-configure.ac
new file mode 100644
index 000000000000..76029e4fbf9e
--- /dev/null
+++ b/chinese/ibus-cangjie/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2015-03-29 15:19:21 UTC
++++ configure.ac
+@@ -15,8 +15,8 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+ IT_PROG_INTLTOOL([0.35.0])
+
+ # i18n
+-AM_GNU_GETTEXT([external])
+-AM_GNU_GETTEXT_VERSION(0.17)
++#AM_GNU_GETTEXT([external])
++#AM_GNU_GETTEXT_VERSION(0.17)
+
+ # Note: If you change GETTEXT_PACKAGE below, you will also need to change it
+ # in src/config.py, or find a way to de-hardcode it there.
diff --git a/chinese/ibus-cangjie/pkg-descr b/chinese/ibus-cangjie/pkg-descr
new file mode 100644
index 000000000000..1f06b3172b5f
--- /dev/null
+++ b/chinese/ibus-cangjie/pkg-descr
@@ -0,0 +1,8 @@
+This is an IBus engine for users of the Cangjie and
+Quick input methods.
+
+It is primarily intended to Hong Kong people
+who want to input Traditional Chinese,
+as they are (by far) the majority of Cangjie and Quick users.
+
+WWW: http://cangjians.github.io/projects/ibus-cangjie/
diff --git a/chinese/ibus-cangjie/pkg-plist b/chinese/ibus-cangjie/pkg-plist
new file mode 100644
index 000000000000..6084b2cf779f
--- /dev/null
+++ b/chinese/ibus-cangjie/pkg-plist
@@ -0,0 +1,28 @@
+bin/ibus-setup-cangjie
+lib/ibus-cangjie/ibus-engine-cangjie
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__init__.py
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/canberra.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/canberra.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/engine.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/engine.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/setup.cpython-%%PYTHON_SUFFIX%%.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/__pycache__/setup.cpython-%%PYTHON_SUFFIX%%.pyc
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/canberra.py
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/engine.py
+%%PYTHON_SITELIBDIR%%/ibus_cangjie/setup.py
+share/appdata/cangjie.appdata.xml
+share/appdata/quick.appdata.xml
+share/applications/ibus-setup-cangjie.desktop
+share/applications/ibus-setup-quick.desktop
+%%DATADIR%%/setup.ui
+share/ibus/component/cangjie.xml
+share/ibus/component/quick.xml
+share/icons/hicolor/16x16/intl/cangjie.png
+share/icons/hicolor/16x16/intl/quick.png
+share/icons/hicolor/scalable/intl/cangjie.svg
+share/icons/hicolor/scalable/intl/quick.svg
+share/locale/pt_BR/LC_MESSAGES/ibus-cangjie.mo
+share/locale/zh_HK/LC_MESSAGES/ibus-cangjie.mo
+share/locale/zh_TW/LC_MESSAGES/ibus-cangjie.mo