aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-10-27 08:53:05 +0800
committerjbeich <jbeich@FreeBSD.org>2018-10-27 08:53:05 +0800
commita57d1d2bf85f01f6f7b66e1aec3b42d308a27feb (patch)
tree8528f4d05b0c64a9d97f5481887e0faf2266c176 /chinese
parentbe214c27f7a0af789575c02d1bb2c0565babb72d (diff)
downloadfreebsd-ports-gnome-a57d1d2bf85f01f6f7b66e1aec3b42d308a27feb.tar.gz
freebsd-ports-gnome-a57d1d2bf85f01f6f7b66e1aec3b42d308a27feb.tar.zst
freebsd-ports-gnome-a57d1d2bf85f01f6f7b66e1aec3b42d308a27feb.zip
chinese/librime: unbreak with boost 1.69
CMake Error at /usr/local/share/cmake/Modules/FindBoost.cmake:2049 (message): Unable to find the requested Boost libraries. Boost version: 1.69.0 Boost include path: /usr/local/include Could not find the following Boost libraries: boost_signals Some (but not all) of the required Boost libraries were found. You may need to install these additional Boost libraries. Alternatively, set BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT to the location of Boost. Call Stack (most recent call first): CMakeLists.txt:41 (find_package) PR: 232525
Diffstat (limited to 'chinese')
-rw-r--r--chinese/librime/files/patch-boost-1.6913
1 files changed, 13 insertions, 0 deletions
diff --git a/chinese/librime/files/patch-boost-1.69 b/chinese/librime/files/patch-boost-1.69
new file mode 100644
index 000000000000..3873db20f1af
--- /dev/null
+++ b/chinese/librime/files/patch-boost-1.69
@@ -0,0 +1,13 @@
+https://github.com/rime/librime/issues/225
+
+--- CMakeLists.txt.orig 2014-12-21 11:46:44 UTC
++++ CMakeLists.txt
+@@ -38,7 +38,7 @@ set(Boost_USE_MULTITHREADED ON)
+ if(MSVC)
+ set(Boost_USE_STATIC_RUNTIME ON)
+ endif(MSVC)
+-find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex signals system)
++find_package(Boost 1.46.0 REQUIRED COMPONENTS filesystem regex system)
+ if(Boost_FOUND)
+ include_directories(${Boost_INCLUDE_DIRS})
+ link_directories(${Boost_LIBRARY_DIRS})