aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>1999-09-05 00:34:32 +0800
committerfoxfair <foxfair@FreeBSD.org>1999-09-05 00:34:32 +0800
commit54ea03ae96443beea882c7d6ef58d2cc08344f93 (patch)
treeae6f1e642c3ce28aeefc3ca15fa200257d519e94 /chinese
parent95a666ec71a327aaa80eb40dbe08a88c1c97f84b (diff)
downloadfreebsd-ports-gnome-54ea03ae96443beea882c7d6ef58d2cc08344f93.tar.gz
freebsd-ports-gnome-54ea03ae96443beea882c7d6ef58d2cc08344f93.tar.zst
freebsd-ports-gnome-54ea03ae96443beea882c7d6ef58d2cc08344f93.zip
Submitted by: Joe Jih-Shien Lu <JoeLu@JoeLu.m8.ntu.edu.tw>
Make libtabe to enable shared mode.
Diffstat (limited to 'chinese')
-rw-r--r--chinese/libtabe/Makefile15
-rw-r--r--chinese/libtabe/pkg-plist6
2 files changed, 19 insertions, 2 deletions
diff --git a/chinese/libtabe/Makefile b/chinese/libtabe/Makefile
index a69045dd8a7f..9b376115f1f7 100644
--- a/chinese/libtabe/Makefile
+++ b/chinese/libtabe/Makefile
@@ -18,15 +18,26 @@ RUN_DEPENDS= ${PREFIX}/lib/libdb2.a:${PORTSDIR}/databases/db
WRKSRC= ${WRKDIR}/libtabe
HAS_CONFIGURE= yes
+USE_GMAKE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--includedir=${PREFIX}/include/tabe \
--with-dbinc=${PREFIX}/include/db2 \
- --with-dblib=${PREFIX}/lib
+ --with-dblib=${PREFIX}/lib \
+ --enable-shared
+
+.include <bsd.port.pre.mk>
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/tabe
${CP} ${WRKSRC}/doc/libtabe.sgml ${PREFIX}/share/doc/tabe
.endif
+.if ${PORTOBJFORMAT} == "elf"
+ ${RM} ${PREFIX}/lib/libtabe.so ${PREFIX}/lib/libtabe.so.0
+ ${MV} ${PREFIX}/lib/libtabe.so.0.1 ${PREFIX}/lib/libtabe.so.0
+ ${LN} -s libtabe.so.0 ${PREFIX}/lib/libtabe.so
+.else
+ ${RM} ${PREFIX}/lib/libtabe.so.0
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/chinese/libtabe/pkg-plist b/chinese/libtabe/pkg-plist
index 9bfe9526b62b..eb09166b2396 100644
--- a/chinese/libtabe/pkg-plist
+++ b/chinese/libtabe/pkg-plist
@@ -5,7 +5,13 @@ bin/tsiyindump
include/tabe/bims.h
include/tabe/tabe.h
lib/libbims.a
+lib/libbims.so
+lib/libbims.so.0.1
lib/libtabe.a
+lib/libtabe.so
+lib/libtabe.so.0.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
share/doc/tabe/libtabe.sgml
share/tabe/tsiyin/tsi.db
share/tabe/tsiyin/yin.db