aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2011-05-18 17:06:49 +0800
committerdanfe <danfe@FreeBSD.org>2011-05-18 17:06:49 +0800
commit1b11473b46b4884062dffe1381b51855669005cf (patch)
tree143cd73e9fdfc0bd1282f3205f0430788d128846 /chinese
parente8079893c450099d7ecf1c9dc23b6aef1d3bbe4d (diff)
downloadfreebsd-ports-gnome-1b11473b46b4884062dffe1381b51855669005cf.tar.gz
freebsd-ports-gnome-1b11473b46b4884062dffe1381b51855669005cf.tar.zst
freebsd-ports-gnome-1b11473b46b4884062dffe1381b51855669005cf.zip
* Update to version 1.6
* Remove two offending and incorrect patches: GNU getline() should be replaced by standard fgets() with care, as they two return different things (number of characters read vs. pointer to the string). These two patches simply replaced one call with the other, leaving return value unmodified according to what caller had expected, which leads to all sorts of weird crashes and segfaults. Port itself checks for getline() presence and uses bundled implementation if it's not found * As usual, clean up Makefile and port description while I'm here
Diffstat (limited to 'chinese')
-rw-r--r--chinese/wenju/Makefile18
-rw-r--r--chinese/wenju/distinfo4
-rw-r--r--chinese/wenju/files/patch-src::tim::timtable.c20
-rw-r--r--chinese/wenju/files/patch-src::wrap::wrap.c11
-rw-r--r--chinese/wenju/files/patch-tests::Makefile.in10
-rw-r--r--chinese/wenju/pkg-descr9
-rw-r--r--chinese/wenju/pkg-plist5
7 files changed, 24 insertions, 53 deletions
diff --git a/chinese/wenju/Makefile b/chinese/wenju/Makefile
index 7c811827e510..fc080282bd9a 100644
--- a/chinese/wenju/Makefile
+++ b/chinese/wenju/Makefile
@@ -1,35 +1,31 @@
-# New ports collection makefile for: wenju
-# Date created: 18 Oct 2003
-# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+# New ports collection makefile for: wenju
+# Date created: 18 Oct 2003
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
#
# $FreeBSD$
#
PORTNAME= wenju
-PORTVERSION= 1.4
-PORTREVISION= 4
+PORTVERSION= 1.6
CATEGORIES= chinese
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Collection of writing tools in Chinese
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_GNOME= gtk20
USE_LDCONFIG= yes
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.else
-CONFIGURE_ARGS+=--disable-nls
+CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
post-install:
- gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
+ gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
.include <bsd.port.mk>
diff --git a/chinese/wenju/distinfo b/chinese/wenju/distinfo
index fa8c17583b4e..c831385ea5bf 100644
--- a/chinese/wenju/distinfo
+++ b/chinese/wenju/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wenju-1.4.tar.gz) = 23de4074eb0555e8eec3ae88badb991d25c527f5563d0c30daa965c3309e2c60
-SIZE (wenju-1.4.tar.gz) = 1832555
+SHA256 (wenju-1.6.tar.gz) = 762be1f7ebea38055d74b061618644598488d0162f399c187ac795550eedcc42
+SIZE (wenju-1.6.tar.gz) = 1910402
diff --git a/chinese/wenju/files/patch-src::tim::timtable.c b/chinese/wenju/files/patch-src::tim::timtable.c
deleted file mode 100644
index 285b36d18446..000000000000
--- a/chinese/wenju/files/patch-src::tim::timtable.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/tim/timtable.c.orig Sat Oct 18 05:34:57 2003
-+++ src/tim/timtable.c Sat Oct 18 05:35:14 2003
-@@ -86,7 +86,7 @@
-
- line = (char *)malloc(n*sizeof(char));;
- /* getline() is a GNU externsion */
-- while ((l = getline(&line, &n, fp)) > 0) {
-+ while ((l = fgets(line, n, fp)) > 0) {
- l = preprocess_line(line, l);
- if (l > 0) {
- char *p;
-@@ -189,7 +189,7 @@
-
- line = (char *)malloc(n*sizeof(char));;
- /* getline() is a GNU externsion */
-- while ((l = getline(&line, &n, fp)) > 0) {
-+ while ((l = fgets(line, n, fp)) > 0) {
- l = preprocess_line(line, l);
- if (l > 0) {
- char *p;
diff --git a/chinese/wenju/files/patch-src::wrap::wrap.c b/chinese/wenju/files/patch-src::wrap::wrap.c
deleted file mode 100644
index 5d3136d2da4a..000000000000
--- a/chinese/wenju/files/patch-src::wrap::wrap.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/wrap/wrap.c.orig Sat Oct 18 05:37:16 2003
-+++ src/wrap/wrap.c Sat Oct 18 05:36:19 2003
-@@ -293,7 +293,7 @@
- size = 0;
- p = NULL;
- /* Read in an input line. */
-- while ((length = getline(&p, &size, fp)) > 0) {
-+ while ((length = fgets(p, size, fp)) > 0) {
- if (p[0] == '\n') {
- /* An empty line signals the end of the paragraph. */
- if (strcmp(text->str, "\n") == 0) {
diff --git a/chinese/wenju/files/patch-tests::Makefile.in b/chinese/wenju/files/patch-tests::Makefile.in
index 96d2392f8b67..2519f01f0ef6 100644
--- a/chinese/wenju/files/patch-tests::Makefile.in
+++ b/chinese/wenju/files/patch-tests::Makefile.in
@@ -1,11 +1,11 @@
---- tests/Makefile.in.orig 2008-08-31 08:25:29.000000000 +0800
-+++ tests/Makefile.in 2008-08-31 08:26:18.000000000 +0800
-@@ -76,7 +76,7 @@
- INSTALL_SCRIPT = @INSTALL_SCRIPT@
+--- tests/Makefile.in 2007-09-29 05:31:49.000000000 +0800
++++ tests/Makefile.in 2011-05-17 10:48:34.000000000 +0800
+@@ -105,7 +105,7 @@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
INTLLIBS = @INTLLIBS@
+ INTL_MACOSX_LIBS = @INTL_MACOSX_LIBS@
-LDFLAGS = @LDFLAGS@
-+LDFLAGS = @LDFLAGS@ ${INTLLIBS}
++LDFLAGS = @LDFLAGS@ @INTLLIBS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
LIBOBJS = @LIBOBJS@
diff --git a/chinese/wenju/pkg-descr b/chinese/wenju/pkg-descr
index 5974822fce76..197ab28ac9ab 100644
--- a/chinese/wenju/pkg-descr
+++ b/chinese/wenju/pkg-descr
@@ -1,4 +1,9 @@
-A collection of writing tools (wenju in Chinese pinyin) such as input
-method, text file formatter, etc. All the tools are based on Unicode.
+A collection of writing tools (wenju in Chinese pinyin) such as TIM (Table-
+based Input Method), text file formatter, etc. All the tools are based on
+Unicode. Default input tables include Wubi and Pinyin, among others.
+
+This port also provides "wrap" utility which can be used to wrap input text
+to specified width. It correctly takes into account punctuation marks when
+breaking words, and that Latin and Chinese characters have different width.
WWW: http://sourceforge.net/projects/wenju/
diff --git a/chinese/wenju/pkg-plist b/chinese/wenju/pkg-plist
index 784a3b79c995..c2f511414d65 100644
--- a/chinese/wenju/pkg-plist
+++ b/chinese/wenju/pkg-plist
@@ -1,7 +1,5 @@
-@comment $FreeBSD$
bin/tim-config
bin/wrap
-lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-tim.a
lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-tim.la
lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-tim.so
%%NLS%%share/locale/zh_CN/LC_MESSAGES/wenju.mo
@@ -9,11 +7,14 @@ lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-tim.so
%%DATADIR%%/cj.tim
%%DATADIR%%/cj5-s.tim
%%DATADIR%%/erbi.tim
+%%DATADIR%%/greek.tim
%%DATADIR%%/liu.tim
%%DATADIR%%/phone.tim
+%%DATADIR%%/pianpang.tim
%%DATADIR%%/pinyin-p.tim
%%DATADIR%%/pinyin.tim
%%DATADIR%%/qfrench.tim
+%%DATADIR%%/shengdiao.tim
%%DATADIR%%/wubi.tim
%%DATADIR%%/wubihua-n.tim
@dirrm %%DATADIR%%