aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2003-10-09 12:14:26 +0800
committerclive <clive@FreeBSD.org>2003-10-09 12:14:26 +0800
commiteba0a7d8a1510df243780e236b9646212ff441c0 (patch)
treef3f419b14aac90f0cfdb24dcadfcc02625267104 /chinese
parent6a95e1223026007e1ed609b59edbcdbe914893bc (diff)
downloadfreebsd-ports-gnome-eba0a7d8a1510df243780e236b9646212ff441c0.tar.gz
freebsd-ports-gnome-eba0a7d8a1510df243780e236b9646212ff441c0.tar.zst
freebsd-ports-gnome-eba0a7d8a1510df243780e236b9646212ff441c0.zip
Improve multibyte ability, otherwise it is broken functionally.
PR: ports/57732 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Diffstat (limited to 'chinese')
-rw-r--r--chinese/tin/Makefile2
-rw-r--r--chinese/tin/files/patch-cook.c15
-rw-r--r--chinese/tin/files/patch-mail.c15
3 files changed, 32 insertions, 0 deletions
diff --git a/chinese/tin/Makefile b/chinese/tin/Makefile
index efd122bdb9dd..9a24e5fb95cd 100644
--- a/chinese/tin/Makefile
+++ b/chinese/tin/Makefile
@@ -13,6 +13,8 @@ MASTERDIR= ${.CURDIR}/../../news/tin
MAINTAINER= yssu@CCCA.NCTU.edu.tw
EXTRA_PATCHES= ${.CURDIR}/files/patch-attrib.c \
+ ${.CURDIR}/files/patch-cook.c \
+ ${.CURDIR}/files/patch-mail.c \
${.CURDIR}/files/patch-init.c
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/tin/files/patch-cook.c b/chinese/tin/files/patch-cook.c
new file mode 100644
index 000000000000..82b650d951da
--- /dev/null
+++ b/chinese/tin/files/patch-cook.c
@@ -0,0 +1,15 @@
+--- src/cook.c.orig Tue Aug 26 20:34:07 2003
++++ src/cook.c Wed Oct 8 15:05:05 2003
+@@ -719,7 +719,12 @@
+ break; /* premature end of file, file error etc. */
+
+ /* convert network to local charset, tex2iso, iso2asc etc. */
++#ifndef CHARSET_CONVERSION
+ process_charsets(&line, &max_line_len, get_param(part->params, "charset"), tinrc.mm_local_charset, CURR_GROUP.attribute->tex2iso_conv && art->tex2iso);
++#else
++ // force to use undeclared_charset first
++ process_charsets(&line, &max_line_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : get_param(part->params, "charset"), tinrc.mm_local_charset, CURR_GROUP.attribute->tex2iso_conv && art->tex2iso);
++#endif /* !CHARSET_CONVERSION */
+
+ len = (int) strlen(line);
+
diff --git a/chinese/tin/files/patch-mail.c b/chinese/tin/files/patch-mail.c
new file mode 100644
index 000000000000..63e977afc71d
--- /dev/null
+++ b/chinese/tin/files/patch-mail.c
@@ -0,0 +1,15 @@
+--- src/mail.c.orig Sun Aug 10 21:27:36 2003
++++ src/mail.c Wed Oct 8 14:52:42 2003
+@@ -327,7 +327,12 @@
+ *
+ * TODO: change US-ASCII to UTF-8 when NNTP draft becomes RFC
+ */
++#ifndef CHARSET_CONVERSION
+ process_charsets(&r, &r_len, "US-ASCII", tinrc.mm_local_charset, FALSE);
++#else
++ process_charsets(&r, &r_len, (CURR_GROUP.attribute->undeclared_charset) ? (CURR_GROUP.attribute->undeclared_charset) : "US-ASCII", tinrc.mm_local_charset, FALSE);
++#endif /* !CHARSET_CONVERSION */
++
+ group->description = convert_to_printable(r);
+ }
+