aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /chinese
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/docproj/Makefile4
-rw-r--r--chinese/oto/Makefile2
-rw-r--r--chinese/oxim/Makefile2
3 files changed, 6 insertions, 2 deletions
diff --git a/chinese/docproj/Makefile b/chinese/docproj/Makefile
index dc2fc66811c1..d729cb13c3d0 100644
--- a/chinese/docproj/Makefile
+++ b/chinese/docproj/Makefile
@@ -34,4 +34,8 @@ do-fetch:
pre-patch:
@${CP} -R ${SRC} ${WRKDIR}
+post-patch:
+ @${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
+ ${WRKSRC}/cjktexsty/Makefile
+
.include <bsd.port.mk>
diff --git a/chinese/oto/Makefile b/chinese/oto/Makefile
index a1a6bed0eb41..4a342fd2aab5 100644
--- a/chinese/oto/Makefile
+++ b/chinese/oto/Makefile
@@ -17,7 +17,7 @@ USES= iconv
GNU_CONFIGURE= YES
USE_GMAKE= YES
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${ICONV_LIB}"
post-patch:
@${FIND} ${WRKSRC}/src/ -type f -print0 | \
diff --git a/chinese/oxim/Makefile b/chinese/oxim/Makefile
index 89926944fce4..05a09d7abdff 100644
--- a/chinese/oxim/Makefile
+++ b/chinese/oxim/Makefile
@@ -26,7 +26,7 @@ WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -liconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=--disable-bimsphone-module \
--disable-static \
--with-conf-dir=${PREFIX}/etc/${PORTNAME} \