aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-01-23 01:15:11 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-01-23 01:15:11 +0800
commit3d7a4832b9bd719f44a94975bd9ecdaa35814bdd (patch)
tree795229ba90b2b6a5dd2d5b8957d9697dee2bbf2a /chinese
parenta2e267c59ae7a2864e553df38c8388c4c824df79 (diff)
downloadfreebsd-ports-gnome-3d7a4832b9bd719f44a94975bd9ecdaa35814bdd.tar.gz
freebsd-ports-gnome-3d7a4832b9bd719f44a94975bd9ecdaa35814bdd.tar.zst
freebsd-ports-gnome-3d7a4832b9bd719f44a94975bd9ecdaa35814bdd.zip
- Unbreak this port
- Remove BROKEN, DEPRECATED and EXPIRATION_DATE - Take maintainership Feature safe: yes
Diffstat (limited to 'chinese')
-rw-r--r--chinese/unrar/Makefile8
-rw-r--r--chinese/unrar/files/patch-arcread.cpp8
-rw-r--r--chinese/unrar/files/patch-unicode.cpp12
3 files changed, 12 insertions, 16 deletions
diff --git a/chinese/unrar/Makefile b/chinese/unrar/Makefile
index e06485df9fe1..ab1b916c4e77 100644
--- a/chinese/unrar/Makefile
+++ b/chinese/unrar/Makefile
@@ -7,17 +7,13 @@
CATEGORIES= chinese
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
MASTERDIR= ${.CURDIR}/../../archivers/unrar
EXTRA_PATCHES= ${.CURDIR}/files/patch-arcread.cpp \
${.CURDIR}/files/patch-unicode.cpp
-CONFLICTS= unrar-*
-
-BROKEN= obsoleted
-DEPRECATED= constantly behind master and no maintainer
-EXPIRATION_DATE= 2011-02-20
+CONFLICTS= unrar-[0-9]* unrar-iconv-[0-9]*
.include "${MASTERDIR}/Makefile"
diff --git a/chinese/unrar/files/patch-arcread.cpp b/chinese/unrar/files/patch-arcread.cpp
index e8c8c9b7210a..f5e7c65d9c63 100644
--- a/chinese/unrar/files/patch-arcread.cpp
+++ b/chinese/unrar/files/patch-arcread.cpp
@@ -1,6 +1,6 @@
---- arcread.cpp.orig Sun Aug 1 01:55:38 2004
-+++ arcread.cpp Sun Aug 1 01:57:56 2004
-@@ -540,6 +540,7 @@
+--- arcread.cpp.orig 2011-01-04 20:28:47.000000000 +0800
++++ arcread.cpp 2011-01-21 22:59:22.000000000 +0800
+@@ -629,6 +629,7 @@
void Archive::ConvertUnknownHeader()
{
@@ -8,7 +8,7 @@
if (NewLhd.UnpVer<20 && (NewLhd.FileAttr & 0x10))
NewLhd.Flags|=LHD_DIRECTORY;
if (NewLhd.HostOS>=HOST_MAX)
-@@ -551,6 +552,16 @@
+@@ -640,6 +641,16 @@
}
for (char *s=NewLhd.FileName;*s!=0;s=charnext(s))
{
diff --git a/chinese/unrar/files/patch-unicode.cpp b/chinese/unrar/files/patch-unicode.cpp
index 14bfc0dac269..01ffc65c4ee5 100644
--- a/chinese/unrar/files/patch-unicode.cpp
+++ b/chinese/unrar/files/patch-unicode.cpp
@@ -1,10 +1,10 @@
---- unicode.cpp.orig Thu Aug 4 00:34:30 2005
-+++ unicode.cpp Wed Sep 7 22:01:58 2005
+--- unicode.cpp.orig 2011-01-04 20:28:47.000000000 +0800
++++ unicode.cpp 2011-01-21 23:01:09.000000000 +0800
@@ -7,6 +7,7 @@
- bool WideToChar(const wchar *Src,char *Dest,int DestSize)
+ bool WideToChar(const wchar *Src,char *Dest,size_t DestSize)
{
bool RetCode=true;
+ return(RetCode); /* patch for chinese filename */
- #ifdef _WIN_32
- if (WideCharToMultiByte(CP_ACP,0,Src,-1,Dest,DestSize,NULL,NULL)==0)
- RetCode=false;
+ *Dest=0; // Set 'Dest' to zero just in case the conversion will fail.
+
+ #ifdef _WIN_ALL