aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-05 07:27:58 +0800
committerantoine <antoine@FreeBSD.org>2014-01-05 07:27:58 +0800
commit40498420b2ab5001c62d3454c3f4180ef99df04b (patch)
tree5094821d4832268b6a38be61f91d1a9645a988e9 /chinese
parent27009bfb716dae775c407ecb6388054f33d9efd1 (diff)
downloadfreebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.tar.gz
freebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.tar.zst
freebsd-ports-gnome-40498420b2ab5001c62d3454c3f4180ef99df04b.zip
With gtk 2.4.22, immodule cache has moved from gtk.immodules to
immodules.cache. gtk-query-immodules-2.0 has a new option, --update-cache that does what we want too. Use this new option. While here, add stage support to non slave ports Reviewed by: kwm (immodules part)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fcitx/Makefile20
-rw-r--r--chinese/fcitx/pkg-plist17
-rw-r--r--chinese/gcin/Makefile17
-rw-r--r--chinese/gcin/files/patch-Makefile17
-rw-r--r--chinese/gcin/pkg-plist19
-rw-r--r--chinese/oxim/Makefile10
-rw-r--r--chinese/oxim/pkg-plist5
-rw-r--r--chinese/wenju/pkg-plist4
8 files changed, 48 insertions, 61 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 1acc6905af7e..c120c4b8581b 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -22,8 +22,6 @@ LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
libicuuc.so:${PORTSDIR}/devel/icu
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
-MAN1= createPYMB.1 fcitx-remote.1 fcitx.1 mb2org.1 mb2txt.1 \
- readPYBase.1 readPYMB.1 scel2org.1 txt2mb.1
SUB_FILES= pkg-message
SUB_LIST+= PORTSDIR=${PORTSDIR}
@@ -33,7 +31,7 @@ USE_XZ= yes
USE_GNOME= pango intltool libxml2 introspection
USE_XORG= x11 xext xkbfile
USE_LDCONFIG= yes
-USES= cmake gettext iconv pathfix pkgconfig
+USES= cmake desktop-file-utils gettext iconv pathfix pkgconfig shared-mime-info
INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
@@ -46,7 +44,6 @@ QT4_DESC= Enable Qt4 IM module
OPENCC_DESC= Enable OpenCC for Chinese Transform
TPUNC_DESC= Use traditional quotation marks
-NO_STAGE= yes
.include <bsd.port.options.mk>
CMAKE_ARGS+= -DENABLE_XDGAUTOSTART=OFF -DFORCE_ENCHANT=ON
@@ -95,10 +92,6 @@ CMAKE_ARGS+= -DENABLE_DEBUG=ON
DOCS_EXTRA_PATCHES= ${FILESDIR}/nodocs-doc_CMakeLists.txt
-.if defined(NOPORTDATA)
-IGNORE= code tables are required, undefine NOPORTDATA
-.endif
-
_DICT_VER= 20120815
post-patch:
@@ -111,15 +104,4 @@ EXTRA_PATCHES+= ${FILESDIR}/getline-src_lib_fcitx-utils_utils.c \
${FILESDIR}/getline-src_lib_fcitx-utils_utils.h
.endif
-post-install:
-.if ${PORT_OPTIONS:MGTK2}
- -${LOCALBASE}/bin/gtk-query-immodules-2.0 > ${LOCALBASE}/etc/gtk-2.0/gtk.immodules
-.endif
-.if ${PORT_OPTIONS:MGTK3}
- -${LOCALBASE}/bin/gtk-query-immodules-3.0 > ${LOCALBASE}/lib/gtk-3.0/${GTK3_VERSION}/immodules.cache
-.endif
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
.include <bsd.port.mk>
diff --git a/chinese/fcitx/pkg-plist b/chinese/fcitx/pkg-plist
index bebc6a3eec88..1cb651fe4db8 100644
--- a/chinese/fcitx/pkg-plist
+++ b/chinese/fcitx/pkg-plist
@@ -84,13 +84,22 @@ lib/libfcitx-utils.so
lib/libfcitx-utils.so.0
lib/libfcitx-utils.so.0.1
lib/girepository-1.0/Fcitx-1.0.typelib
+man/man1/createPYMB.1.gz
+man/man1/fcitx-remote.1.gz
+man/man1/fcitx.1.gz
+man/man1/mb2org.1.gz
+man/man1/mb2txt.1.gz
+man/man1/readPYBase.1.gz
+man/man1/readPYMB.1.gz
+man/man1/scel2org.1.gz
+man/man1/txt2mb.1.gz
share/gir-1.0/Fcitx-1.0.gir
%%GTK2%%lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-fcitx.so
-%%GTK2%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %%LOCALBASE%%/etc/gtk-2.0/gtk.immodules
-%%GTK2%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %%LOCALBASE%%/etc/gtk-2.0/gtk.immodules
+%%GTK2%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
+%%GTK2%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
%%GTK3%%lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-fcitx.so
-%%GTK3%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 > %%LOCALBASE%%/lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
-%%GTK3%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 > %%LOCALBASE%%/lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
+%%GTK3%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 --update-cache
+%%GTK3%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-3.0 --update-cache
%%QT4%%lib/qt4/plugins/inputmethods/libqtim-fcitx.so
%%QT4%%@dirrmtry lib/qt4/plugins/inputmethods
%%QT4%%@dirrmtry lib/qt4/plugins
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 285163114a08..adf1a26f683e 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -26,12 +26,6 @@ OPTIONS_DEFINE= ANTHY QT_IM_MODULE
ANTHY_DESC= Japanese anthy IM module
QT_IM_MODULE_DESC= QT IM module
-MAN1= gcin.1 gcin-exit.1 gcin2tab.1 gcin-gb-toggle.1 gcin-kbm-toggle.1 \
- gcin-message.1 gcin-tools.1 gtab-merge.1 juyin-learn.1 \
- phoa2d.1 sim2trad.1 tsa2d32.1 tslearn.1 \
- ts-contribute.1 ts-edit.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MQT_IM_MODULE}
@@ -103,17 +97,8 @@ post-build:
post-install:
.if !defined(DEBUG_FLAGS)
.for f in gcin* gtab-merge juyin-learn phoa2* sim2trad trad2sim ts-edit tsa2d32 tsd2a32 tsin2gtab-phrase tslearn
- @${STRIP_CMD} ${PREFIX}/bin/${f}
-.endfor
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
-.for f in Changelog.html README.html
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor
.endif
- @${LOCALBASE}/bin/gtk-query-immodules-2.0 > ${LOCALBASE}/etc/gtk-2.0/gtk.immodules
- @${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
.include <bsd.port.post.mk>
diff --git a/chinese/gcin/files/patch-Makefile b/chinese/gcin/files/patch-Makefile
index 55c3150bc842..c8720190f1eb 100644
--- a/chinese/gcin/files/patch-Makefile
+++ b/chinese/gcin/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2011-12-19 10:45:09.000000000 +0800
-+++ Makefile 2012-02-03 08:29:40.000000000 +0800
-@@ -90,7 +90,7 @@ PROGS_CV=kbmcv pin-juyin
+--- ./Makefile.orig 2012-12-08 00:32:13.000000000 +0000
++++ ./Makefile 2014-01-04 22:34:02.000000000 +0000
+@@ -94,7 +94,7 @@
all: $(PROGS) trad2sim $(GCIN_SO) $(DATA) $(PROGS_CV) gcin.spec gcin-fedora.spec
$(MAKE) -C data
$(MAKE) -C gtk-im
@@ -9,7 +9,7 @@
if [ $(USE_I18N) = 'Y' ]; then $(MAKE) -C po; fi
if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im; fi
if [ $(QT_IM) = 'Y' ]; then $(MAKE) -C qt-im; fi
-@@ -204,7 +204,7 @@ install:
+@@ -215,11 +215,11 @@
$(MAKE) -C data install
$(MAKE) -C im-client install
$(MAKE) -C gtk-im install
@@ -18,8 +18,13 @@
if [ $(GTK3_IM) = 'Y' ]; then $(MAKE) -C gtk3-im install; fi
if [ $(QT_IM) = 'Y' ]; then $(MAKE) -C qt-im install; fi
if [ $(QT4_IM) = 'Y' ]; then $(MAKE) -C qt4-im install; fi
-@@ -221,6 +221,7 @@ install:
- rm -f $(bindir)/trad2sim; ln -sf sim2trad $(bindir)/trad2sim; \
+- if [ $(prefix) = /usr/local ]; then \
++ if [ $(prefix) = /nonstaged ]; then \
+ install -m 644 gcin.png /usr/share/icons; \
+ install -d $(DOC_DIR); \
+ install -m 644 README.html Changelog.html $(DOC_DIR); \
+@@ -234,6 +234,7 @@
+ rm -f $(bindir)/ts-contribute; ln -sf ts-edit $(bindir)/ts-contribute; \
fi
$(MAKE) -C scripts install
+ $(MAKE) -C man install
diff --git a/chinese/gcin/pkg-plist b/chinese/gcin/pkg-plist
index 97f8fbd8139d..8c71598f8d5c 100644
--- a/chinese/gcin/pkg-plist
+++ b/chinese/gcin/pkg-plist
@@ -27,6 +27,21 @@ lib/gcin/intcode-module.so
lib/gcin/libgcin-im-client.so
lib/gcin/libgcin-im-client.so.1.2.5
lib/gcin/libgcin-im-client.so.1
+man/man1/gcin-exit.1.gz
+man/man1/gcin-gb-toggle.1.gz
+man/man1/gcin-kbm-toggle.1.gz
+man/man1/gcin-message.1.gz
+man/man1/gcin-tools.1.gz
+man/man1/gcin.1.gz
+man/man1/gcin2tab.1.gz
+man/man1/gtab-merge.1.gz
+man/man1/juyin-learn.1.gz
+man/man1/phoa2d.1.gz
+man/man1/sim2trad.1.gz
+man/man1/ts-contribute.1.gz
+man/man1/ts-edit.1.gz
+man/man1/tsa2d32.1.gz
+man/man1/tslearn.1.gz
%%DATADIR%%/script/gcin-user-setup
%%DATADIR%%/script/gtab.append_prepare
%%DATADIR%%/script/html-browser
@@ -153,5 +168,5 @@ share/icons/gcin.png
@dirrmtry lib/gtk-2.0/immodules
@dirrmtry lib/gtk-2.0
@dirrm lib/gcin
-@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
-@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
+@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
+@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
diff --git a/chinese/oxim/Makefile b/chinese/oxim/Makefile
index a59f67cfc936..22be747ff9d4 100644
--- a/chinese/oxim/Makefile
+++ b/chinese/oxim/Makefile
@@ -34,9 +34,6 @@ CONFIGURE_ARGS+=--disable-bimsphone-module \
# oxim requires qinputcontextplugin.h which only exists in Debian package
CONFIGURE_ARGS+=--disable-qt-immodule
-MAN1= oxim.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTK2}
@@ -83,11 +80,4 @@ post-patch:
${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/src/gtk-immodule/gtkintl.h
-post-install:
-.if ${PORT_OPTIONS:MGTK2}
- @${LOCALBASE}/bin/gtk-query-immodules-2.0 > ${PREFIX}/etc/gtk-2.0/gtk.immodules
-.endif
- @${CAT} ${PKGMESSAGE}
- @${ECHO} To display this message again, type ${PKG_INFO} -D ${PKGNAME}
-
.include <bsd.port.mk>
diff --git a/chinese/oxim/pkg-plist b/chinese/oxim/pkg-plist
index 62ddadf877ca..a923aef6f5f5 100644
--- a/chinese/oxim/pkg-plist
+++ b/chinese/oxim/pkg-plist
@@ -23,6 +23,7 @@ lib/oxim/tables/cnscj.tab
lib/oxim/tables/cnsphone.tab
lib/oxim/tables/default.phr
lib/oxim/tables/symbol.list
+man/man1/oxim.1.gz
share/locale/zh_CN/LC_MESSAGES/oxim.mo
share/locale/zh_HK/LC_MESSAGES/oxim.mo
share/locale/zh_TW/LC_MESSAGES/oxim.mo
@@ -35,5 +36,5 @@ share/locale/zh_TW/LC_MESSAGES/oxim.mo
@dirrmtry share/locale/zh_HK
%%GTK2%%@dirrmtry lib/gtk-2.0/immodules
%%GTK2%%@dirrmtry lib/gtk-2.0
-%%GTK2%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
-%%GTK2%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
+%%GTK2%%@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
+%%GTK2%%@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
diff --git a/chinese/wenju/pkg-plist b/chinese/wenju/pkg-plist
index 0ab4ab888c3a..85460721ccba 100644
--- a/chinese/wenju/pkg-plist
+++ b/chinese/wenju/pkg-plist
@@ -18,5 +18,5 @@ lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-tim.so
%%DATADIR%%/wubi.tim
%%DATADIR%%/wubihua-n.tim
@dirrm %%DATADIR%%
-@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
-@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
+@exec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache
+@unexec %%LOCALBASE%%/bin/gtk-query-immodules-2.0 --update-cache