aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /chinese
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'chinese')
-rw-r--r--chinese/oto/Makefile4
-rw-r--r--chinese/oxim/Makefile4
-rw-r--r--chinese/pcmanx/Makefile1
-rw-r--r--chinese/qterm/Makefile2
-rw-r--r--chinese/scim-array/Makefile1
-rw-r--r--chinese/scim-chewing/Makefile2
-rw-r--r--chinese/scim-fcitx/Makefile6
-rw-r--r--chinese/scim-pinyin/Makefile7
-rw-r--r--chinese/scim-tables/Makefile4
-rw-r--r--chinese/srecite/Makefile4
-rw-r--r--chinese/zhcon/Makefile4
11 files changed, 18 insertions, 21 deletions
diff --git a/chinese/oto/Makefile b/chinese/oto/Makefile
index fb37fcdfb7b4..266c94f5281f 100644
--- a/chinese/oto/Makefile
+++ b/chinese/oto/Makefile
@@ -16,8 +16,8 @@ COMMENT= Show you font info and add new 'name' and 'cmap' tables
USE_ICONV= yes
GNU_CONFIGURE= YES
USE_GMAKE= YES
-CPPFLAGS= -I${LOCALBASE}/include
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LIBS="-L${LOCALBASE}/lib -liconv"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -liconv"
post-patch:
@${FIND} ${WRKSRC}/src/ -type f -print0 | \
diff --git a/chinese/oxim/Makefile b/chinese/oxim/Makefile
index fdd017bba3fe..c35dc86b4d57 100644
--- a/chinese/oxim/Makefile
+++ b/chinese/oxim/Makefile
@@ -29,8 +29,6 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+=--disable-bimsphone-module \
--disable-static \
--with-conf-dir=${PREFIX}/etc/${PORTNAME} \
@@ -75,7 +73,7 @@ PLIST_SUB+= UNICODE="@comment "
# TODO WITHOUT_NLS knob
#.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -lintl"
+LDFLAGS+= -lintl
PLIST_SUB+= NLS=""
#.else
#CONFIGURE_ARGS+=--disable-nls
diff --git a/chinese/pcmanx/Makefile b/chinese/pcmanx/Makefile
index 2c88fa571f8a..e402de7b174f 100644
--- a/chinese/pcmanx/Makefile
+++ b/chinese/pcmanx/Makefile
@@ -35,7 +35,6 @@ USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index a889e47e8dbb..77fb5c7ab8fa 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -20,7 +20,7 @@ USE_PERL5_BUILD=yes
USE_QT_VER= 3
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --enable-mt --prefix=${PREFIX}
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(WITHOUT_PYTHON)
USE_PYTHON= 2.5+
diff --git a/chinese/scim-array/Makefile b/chinese/scim-array/Makefile
index 376edfe9fbd6..ca765b5bd993 100644
--- a/chinese/scim-array/Makefile
+++ b/chinese/scim-array/Makefile
@@ -25,7 +25,6 @@ USE_ICONV= yes
CFLAGS+= -fPIC
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
pre-configure:
@${REINPLACE_CMD} -e "s,@SCIM_MODULEDIR@,$$(pkg-config --variable=moduledir scim | ${SED} -e s,`pkg-config --variable=prefix scim`,${PREFIX},)," ${WRKSRC}/src/Makefile.in
diff --git a/chinese/scim-chewing/Makefile b/chinese/scim-chewing/Makefile
index 9116c8990e39..65a032ac7b06 100644
--- a/chinese/scim-chewing/Makefile
+++ b/chinese/scim-chewing/Makefile
@@ -25,7 +25,7 @@ USE_GNOME= intltool
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-D__STDC_ISO_10646__ -I${LOCALBASE}/include"
+CPPFLAGS+= -D__STDC_ISO_10646__ -I${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e 's,@DATADIRNAME@,share,g' ${WRKSRC}/po/Makefile.in.in
diff --git a/chinese/scim-fcitx/Makefile b/chinese/scim-fcitx/Makefile
index 3c96bf311dc7..117e7385c246 100644
--- a/chinese/scim-fcitx/Makefile
+++ b/chinese/scim-fcitx/Makefile
@@ -26,10 +26,10 @@ MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/fcitx
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lintl" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- SCIM_DATADIR=${PREFIX}/share/scim \
+CONFIGURE_ENV+= SCIM_DATADIR=${PREFIX}/share/scim \
SCIM_ICONDIR=${PREFIX}/share/scim/icons
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
SUB_FILES= pkg-message
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 9f242317234e..0c81a0d51481 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -23,9 +23,10 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}" \
- CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
.include <bsd.port.pre.mk>
diff --git a/chinese/scim-tables/Makefile b/chinese/scim-tables/Makefile
index c293e9ce8a90..ec9b0c4c7b60 100644
--- a/chinese/scim-tables/Makefile
+++ b/chinese/scim-tables/Makefile
@@ -23,9 +23,9 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib -lintl" \
- SCIM_DATADIR=${PREFIX}/share/scim \
+CONFIGURE_ENV+= SCIM_DATADIR=${PREFIX}/share/scim \
SCIM_ICONDIR=${PREFIX}/share/scim/icons
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS+= --disable-skim-support
diff --git a/chinese/srecite/Makefile b/chinese/srecite/Makefile
index b4f4449933f9..c1e3288b2e78 100644
--- a/chinese/srecite/Makefile
+++ b/chinese/srecite/Makefile
@@ -19,8 +19,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for the Chinese people to study foreign language
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
index 14489675d565..eff4404600f2 100644
--- a/chinese/zhcon/Makefile
+++ b/chinese/zhcon/Makefile
@@ -22,8 +22,8 @@ USE_ICONV= yes
# Don't bother to add ".if !defined(WITHOUT_NLS)", zhcon requires libintl
USE_GETTEXT= yes
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message