aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2012-01-11 05:47:44 +0800
committerdelphij <delphij@FreeBSD.org>2012-01-11 05:47:44 +0800
commit61361459c88ceea7dfaabc6bf872cfa67e8e525d (patch)
tree517569e8c6b2128b8bedfe13f8cc3f82e944d8bf /chinese
parentf95e0ed610c4e6296762405b9ce81c1952315596 (diff)
downloadfreebsd-ports-gnome-61361459c88ceea7dfaabc6bf872cfa67e8e525d.tar.gz
freebsd-ports-gnome-61361459c88ceea7dfaabc6bf872cfa67e8e525d.tar.zst
freebsd-ports-gnome-61361459c88ceea7dfaabc6bf872cfa67e8e525d.zip
Update to 1.4.0.
Changes: * Remove dependency on boost * Require GCC 4.4+ for c++0x standard * Add three options to select database to use and select optional dependencies PR: ports/163883 Submitted by: Henry Hu <henry.hu.sh gmail.com> (maintainer)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/ibus-pinyin/Makefile54
-rw-r--r--chinese/ibus-pinyin/distinfo6
-rw-r--r--chinese/ibus-pinyin/pkg-plist6
3 files changed, 56 insertions, 10 deletions
diff --git a/chinese/ibus-pinyin/Makefile b/chinese/ibus-pinyin/Makefile
index a201d2376398..ad76a5f6c9f1 100644
--- a/chinese/ibus-pinyin/Makefile
+++ b/chinese/ibus-pinyin/Makefile
@@ -6,28 +6,63 @@
#
PORTNAME= ibus-pinyin
-PORTVERSION= 1.3.11
+PORTVERSION= 1.4.0
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DBTAR}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= henry.hu.sh@gmail.com
COMMENT= PinYin engine for IBus
BUILD_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
- ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3 \
- ${LOCALBASE}/include/boost/accumulators/accumulators.hpp:${PORTSDIR}/devel/boost-libs
-RUN_DEPENDS= ${BUILD_DEPENDS}
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
+RUN_DEPENDS= ibus-daemon:${PORTSDIR}/textproc/ibus \
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
USE_PYTHON= yes
USE_GNOME= pygtk2
+USE_GCC= 4.4+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-dependency-tracking
+CONFIGURE_ARGS= --disable-dependency-tracking --disable-lua-extension
PROJECTHOST= ibus
+OPTIONS= ANDROID_DB "Build Android DB" on \
+ OPENPHRASE_DB "Build Open Phrase DB" off \
+ OPENCC "Use opencc" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ANDROID_DB)
+CONFIGURE_ARGS+= --enable-db-android
+PLIST_SUB+= ANDROID_DB=""
+.else
+CONFIGURE_ARGS+= --disable-db-android
+PLIST_SUB+= ANDROID_DB="@comment "
+.endif
+
+OPENPHRASE_DBVER= 1.2.99
+OPENPHRASE_DBFILE= pinyin-database-${OPENPHRASE_DBVER}.tar.bz2
+
+.if defined(WITH_OPENPHRASE_DB)
+CONFIGURE_ARGS+= --enable-db-open-phrase
+DISTFILES+= ${OPENPHRASE_DBFILE}
+PLIST_SUB+= OPENPHRASE_DB=""
+.else
+CONFIGURE_ARGS+= --disable-db-open-phrase
+PLIST_SUB+= OPENPHRASE_DB="@comment "
+.endif
+
+.if defined(WITH_OPENCC)
+CONFIGURE_ARGS+= --enable-opencc
+LIB_DEPENDS+= opencc.1:${PORTSDIR}/chinese/opencc
+.else
+CONFIGURE_ARGS+= --disable-opencc
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -36,7 +71,12 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-extract:
+.if defined(WITH_OPENPHRASE_DB)
+ @${CP} ${DISTDIR}/${OPENPHRASE_DBFILE} ${WRKSRC}/data/db/open-phrase
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/chinese/ibus-pinyin/distinfo b/chinese/ibus-pinyin/distinfo
index 0e0345bd8500..6963464cb67d 100644
--- a/chinese/ibus-pinyin/distinfo
+++ b/chinese/ibus-pinyin/distinfo
@@ -1,2 +1,4 @@
-SHA256 (ibus-pinyin-1.3.11.tar.gz) = 3b778777eef1c47150675ed74a572776f0aa27f5a19b681200b71741f08b722a
-SIZE (ibus-pinyin-1.3.11.tar.gz) = 1659622
+SHA256 (ibus-pinyin-1.4.0.tar.gz) = 4fcaef6ac0533945c7feb4cb36fc72c102aae63b3fb4cbf338cdcc816182c24a
+SIZE (ibus-pinyin-1.4.0.tar.gz) = 1813003
+SHA256 (pinyin-database-1.2.99.tar.bz2) = 32c7d07b9f41e1dfc0f9008f54eca8e6cb367e7f2b19ac94c49754442694c321
+SIZE (pinyin-database-1.2.99.tar.bz2) = 9977983
diff --git a/chinese/ibus-pinyin/pkg-plist b/chinese/ibus-pinyin/pkg-plist
index 4459e6affb7e..548576016f07 100644
--- a/chinese/ibus-pinyin/pkg-plist
+++ b/chinese/ibus-pinyin/pkg-plist
@@ -4,7 +4,9 @@
%%NLS%%share/locale/zh_TW/LC_MESSAGES/ibus-pinyin.mo
libexec/ibus-engine-pinyin
libexec/ibus-setup-pinyin
-%%DATADIR%%/db/android.db
+%%ANDROID_DB%%%%DATADIR%%/db/android.db
+%%OPENPHRASE_DB%%%%DATADIR%%/db/open-phrase.db
+%%DATADIR%%/db/english.db
%%DATADIR%%/db/create_index.sql
%%DATADIR%%/icons/chinese.svg
%%DATADIR%%/icons/english.svg
@@ -30,6 +32,8 @@ share/ibus/component/pinyin.xml
%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ru
%%NLS%%@dirrmtry share/locale
+@dirrmtry share/ibus/component
+@dirrmtry share/ibus
@dirrm %%DATADIR%%/setup
@dirrm %%DATADIR%%/icons
@dirrmtry %%DATADIR%%/db