aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorkeichii <keichii@FreeBSD.org>2003-05-19 16:33:28 +0800
committerkeichii <keichii@FreeBSD.org>2003-05-19 16:33:28 +0800
commita2b9f21c6ee64484c031df94e9e938bc6b1d910f (patch)
tree5f62118ae745919f6608081d3d6698031c20547b /chinese
parentea17c487b81b55c57e0f8fac13eca94a27a0bc9d (diff)
downloadfreebsd-ports-gnome-a2b9f21c6ee64484c031df94e9e938bc6b1d910f.tar.gz
freebsd-ports-gnome-a2b9f21c6ee64484c031df94e9e938bc6b1d910f.tar.zst
freebsd-ports-gnome-a2b9f21c6ee64484c031df94e9e938bc6b1d910f.zip
Obsolete port. In the future, we should use the simple
ports/x11/rxvt-* because it is now i18n complete.
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile3
-rw-r--r--chinese/rxvt-big5/Makefile30
-rw-r--r--chinese/rxvt-big5/files/patch-multibyte_cursor143
-rw-r--r--chinese/rxvt-big5/pkg-message11
-rw-r--r--chinese/rxvt-gb/Makefile23
-rw-r--r--chinese/rxvt/Makefile21
-rw-r--r--chinese/rxvt/pkg-descr11
7 files changed, 0 insertions, 242 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 496b0ff5fdda..7acc1d87fef1 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -89,9 +89,6 @@
SUBDIR += pycodec
SUBDIR += qe
SUBDIR += qterm
- SUBDIR += rxvt
- SUBDIR += rxvt-big5
- SUBDIR += rxvt-gb
SUBDIR += stardict
SUBDIR += stardict2
SUBDIR += tcl83
diff --git a/chinese/rxvt-big5/Makefile b/chinese/rxvt-big5/Makefile
deleted file mode 100644
index 048ec962d174..000000000000
--- a/chinese/rxvt-big5/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: rxvt-big5
-# Date created: Thur Nov 2, 2000
-# Whom: Michael C . Wu <keichii@iteration.net>
-#
-# $FreeBSD$
-#
-
-CATEGORIES= chinese
-
-MASTERDIR= ${.CURDIR}/../../x11/rxvt
-
-.if !defined(NO_MULTIBYTE_CURSOR)
-EXTRA_PATCHES= ${.CURDIR}/files/patch-multibyte_cursor
-.endif
-PKGMESSAGE= ${.CURDIR}/pkg-message
-
-.include "${MASTERDIR}/Makefile"
-
-PORTNAME= rxvt
-PORTVERSION= 2.6.4
-
-#.include <bsd.port.pre.mk>
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}tw-
-
-MAINTAINER= keichii@freebsd.org
-COMMENT= Chinese big5 locale enabled RXVT program, slave port from X11/rxvt
-
-CONFIGURE_ARGS+= \
- --enable-xim --enable-big5 \
- --enable-next-scroll --with-term=xterm-color
diff --git a/chinese/rxvt-big5/files/patch-multibyte_cursor b/chinese/rxvt-big5/files/patch-multibyte_cursor
deleted file mode 100644
index 98ccfa4fbf68..000000000000
--- a/chinese/rxvt-big5/files/patch-multibyte_cursor
+++ /dev/null
@@ -1,143 +0,0 @@
---- rclock/rclock.c
-+++ rclock/rclock.c
-@@ -1201,8 +1201,16 @@
- int n = (sizeof(execPrgm) - strlen (execPrgm) - 2);
- if ((n > 0) && (n >= strlen (prgm)))
- {
-- /* for co-occurring programs */
-- strcat (execPrgm, ";");
-+ /* for co-occurring programs */
-+ switch (execPrgm[strlen (execPrgm)-1])
-+ {
-+ case '&':
-+ case ';':
-+ break;
-+ default:
-+ strcat (execPrgm, ";");
-+ break;
-+ }
- strncat (execPrgm, prgm, n);
- }
- }
---- src/command.c
-+++ src/command.c
-@@ -1221,11 +1221,23 @@
- ^ !!(shft | ctrl)) ? '\b' : '\177');
- } else
- len = strlen(STRCPY(kbuf, key_backspace));
-+#ifdef MULTICHAR_SET
-+ if ((Options & Opt_mc_hack) && scr_multi2()) {
-+ memmove(kbuf + len, kbuf, len);
-+ len *= 2;
-+ }
-+#endif
- break;
- #endif
- #ifndef NO_DELETE_KEY
- case XK_Delete:
- len = strlen(STRCPY(kbuf, key_delete));
-+#ifdef MULTICHAR_SET
-+ if ((Options & Opt_mc_hack) && scr_multi1()) {
-+ memmove(kbuf + len, kbuf, len);
-+ len *= 2;
-+ }
-+#endif
- break;
- #endif
- case XK_Tab:
-@@ -1279,6 +1291,14 @@
- kbuf[2] = ("dacb"[keysym - XK_Left]);
- } else if (PrivateModes & PrivMode_aplCUR)
- kbuf[1] = 'O';
-+#ifdef MULTICHAR_SET
-+ if ((Options & Opt_mc_hack) &&
-+ ((keysym==XK_Left && scr_multi2()) ||
-+ (keysym==XK_Right && scr_multi1()))) {
-+ memmove(kbuf + len, kbuf, len);
-+ len *= 2;
-+ }
-+#endif
- break;
-
- #ifndef UNSHIFTED_SCROLLKEYS
---- src/rxvt.h
-+++ src/rxvt.h
-@@ -408,6 +408,7 @@
- #define Opt_scrollTtyOutput (1LU<<11)
- #define Opt_scrollKeypress (1LU<<12)
- #define Opt_transparent (1LU<<13)
-+#define Opt_mc_hack (1LU<<14)
- /* place holder used for parsing command-line options */
- #define Opt_Reverse (1LU<<30)
- #define Opt_Boolean (1LU<<31)
-@@ -548,6 +549,9 @@
- #ifdef USE_XIM
- Rs_preeditType,
- Rs_inputMethod,
-+#endif
-+#ifdef MULTICHAR_SET
-+ Rs_mc_hack,
- #endif
- #if defined (HOTKEY_CTRL) || defined (HOTKEY_META)
- Rs_bigfont_key,
---- src/screen.c.orig Fri Jul 14 11:29:29 2000
-+++ src/screen.c Sat Dec 23 13:49:05 2000
-@@ -1980,15 +1980,15 @@
- int
- scr_move_to(int y, int len)
- {
-- int start;
-+ int start, newstart;
-
- want_refresh = 1;
- start = TermWin.view_start;
- if (y >= len)
- TermWin.view_start = 0;
- else {
-- TermWin.view_start = ((len - y)
-- * (TermWin.nrow - 1 + TermWin.nscrolled) / len);
-+ newstart = ((len - y) * (TermWin.nrow - 1 + TermWin.nscrolled) / len);
-+ TermWin.view_start = max(newstart,0);
- if (TermWin.view_start < TermWin.nrow)
- TermWin.view_start = 0;
- else
-@@ -3501,5 +3501,28 @@
- XGetWindowAttributes(Xdisplay, TermWin.vt, &xwa);
- pos->x = Col2Pixel(screen.cur.col) + xwa.x;
- pos->y = Height2Pixel((screen.cur.row + 1)) + xwa.y;
-+}
-+#endif
-+
-+#ifdef MULTICHAR_SET
-+/* EXTPROTO */
-+int
-+scr_multi1(void)
-+{
-+ rend_t rend;
-+
-+ rend = screen.rend[screen.cur.row + TermWin.saveLines][screen.cur.col];
-+ return ((rend & RS_multiMask)==RS_multi1);
-+}
-+
-+/* EXTPROTO */
-+int
-+scr_multi2(void)
-+{
-+ rend_t rend;
-+
-+ if (screen.cur.col==0) return 0;
-+ rend = screen.rend[screen.cur.row + TermWin.saveLines][screen.cur.col-1];
-+ return ((rend & RS_multiMask)==RS_multi2);
- }
- #endif
---- src/xdefaults.c
-+++ src/xdefaults.c
-@@ -215,6 +215,8 @@
- #ifdef MULTICHAR_SET
- STRG(Rs_multichar_encoding, "multichar_encoding", "km", "mode",
- "multiple-character font encoding; mode = eucj | sjis | big5 | gb"),
-+ BOOL(Rs_mc_hack, "multibyte_cursor", "mcc", Opt_mc_hack,
-+ "Multibyte character cursor movement"),
- #endif /* MULTICHAR_SET */
- #ifdef USE_XIM
- STRG(Rs_preeditType, "preeditType", "pt", "style",
diff --git a/chinese/rxvt-big5/pkg-message b/chinese/rxvt-big5/pkg-message
deleted file mode 100644
index ebd8a1634da1..000000000000
--- a/chinese/rxvt-big5/pkg-message
+++ /dev/null
@@ -1,11 +0,0 @@
-If you want rxvt-big5 to automatically detect multibyte characters when
-moving the cursor, put the following line into your .Xdefaults or .Xresources:
-
-rxvt.multibyte_cursor: yes
-
-If you do not wish to have this feature, reinstall the port with the following
-commands:
-
-cd /usr/ports/chinese/rxvt-big5
-make NO_MULTIBYTE_CURSOR=yes deinstall clean install clean
-
diff --git a/chinese/rxvt-gb/Makefile b/chinese/rxvt-gb/Makefile
deleted file mode 100644
index 83f0d88a7eff..000000000000
--- a/chinese/rxvt-gb/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-# New ports collection makefile for: rxvt-big5
-# Date created: Thur Nov 2, 2000
-# Whom: Michael C . Wu <keichii@iteration.net>
-#
-# $FreeBSD$
-#
-
-CATEGORIES= chinese
-
-MASTERDIR= ${.CURDIR}/../../x11/rxvt
-.include "${MASTERDIR}/Makefile"
-
-PORTNAME= rxvt
-PORTVERSION= 2.6.4
-
-#.include <bsd.port.pre.mk>
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}cn-
-
-MAINTAINER= keichii@freebsd.org
-COMMENT= Chinese GB locale enabled RXVT program, slave port from X11/rxvt
-
-CONFIGURE_ARGS+= --enable-xim --enable-big5 \
- --enable-next-scroll --with-term=xterm-color
diff --git a/chinese/rxvt/Makefile b/chinese/rxvt/Makefile
deleted file mode 100644
index c3f238255635..000000000000
--- a/chinese/rxvt/Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
-# New ports collection Makefile for: rxvt
-# Date created: Nov 16 1997
-# Whom: frankch@waru.life.nthu.edu.tw
-#
-# $FreeBSD$
-#
-
-CATEGORIES= chinese
-
-MASTERDIR= ${.CURDIR}/../../x11/rxvt-devel
-
-.include "${MASTERDIR}/Makefile"
-
-MAINTAINER= keichii@freebsd.org
-COMMENT= A low memory usage xterm replacement that supports color & Chinese
-
-CONFIGURE_ARGS+= \
- --enable-menubar --enable-graphics \
- --disable-backspace-key --disable-delete-key \
- --enable-rxvt-scroll --enable-next-scroll \
- --with-encoding=big5
diff --git a/chinese/rxvt/pkg-descr b/chinese/rxvt/pkg-descr
deleted file mode 100644
index 8a875972261e..000000000000
--- a/chinese/rxvt/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
-Rxvt is an xterm replacement which uses a little less memory, and is
-suitable for use on machines with small memories.
-The KANJI support was added to rxvt since 2.17, from 2.4.4(3?) the support
-for Chinese BIG5 encoding is also added.
-Since 2.6PRE2, rxvt supports XIM. This port no longer patches for XCIN,
-a Chinese input server. Instead, the user must install an input server which
-support the XIM protocol. The user has to either patch XCIN (2.1, 2.3) or use
-XCIN 2.5, which support XIM and only XIM protocol.
-
-WWW: http://www.rxvt.org/
-http://xcin.linux.org.tw/ (Chinese XIM server)