aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-10-22 00:52:22 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-10-22 00:52:22 +0800
commitc9b1ee9b4fc94f68067a8f9bbd4a8515f5c36260 (patch)
tree64fc233ed0425ea857885ee6554c676d18f9c844 /chinese
parent587bea2ac97575c42dc0774bd9394bedd0fd5697 (diff)
downloadfreebsd-ports-gnome-c9b1ee9b4fc94f68067a8f9bbd4a8515f5c36260.tar.gz
freebsd-ports-gnome-c9b1ee9b4fc94f68067a8f9bbd4a8515f5c36260.tar.zst
freebsd-ports-gnome-c9b1ee9b4fc94f68067a8f9bbd4a8515f5c36260.zip
Fix build on powerpc64
- While I'm here: - Sort USES - Remove .include <bsd.port.options.mk> PR: 232416 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: Zhihao Yuan <lichray@gmail.com> (maintainer)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/librime/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 8e0333eab019..7e485d9b3f0e 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -20,8 +20,10 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libopencc.so:chinese/opencc \
libyaml-cpp.so:devel/yaml-cpp
-USES= cmake compiler:c++11-lib pathfix pkgconfig gettext perl5
+USES= cmake compiler:c++11-lib gettext pathfix perl5 pkgconfig
USE_PERL5= build patch
+
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
USE_XORG= xorgproto
LDFLAGS+= -lintl
@@ -30,12 +32,8 @@ GH_ACCOUNT= rime
PLIST_SUB= VER=${PORTVERSION}
-BROKEN_powerpc64= Does not link: undefined reference to YAML::detail::node_data::empty_scalar[abi:cxx11]
-
-.include <bsd.port.options.mk>
-
-post-patch: .SILENT
- ${FIND} ${WRKSRC} \( -name '*.cc' -or -name '*.h' \) \
+post-patch:
+ @${FIND} ${WRKSRC} \( -name '*.cc' -or -name '*.h' \) \
-exec ${PERL} -i -pe '$$. == 1 && s/^\xef\xbb\xbf//;' {} \;
.include <bsd.port.mk>