aboutsummaryrefslogtreecommitdiffstats
path: root/comms/airspy
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-27 13:09:28 +0800
committeryuri <yuri@FreeBSD.org>2018-06-27 13:09:28 +0800
commite923b2cc78d48a9f871a0bcf28966a14709c8370 (patch)
tree072ce085013233e2c579472b293758090a49d290 /comms/airspy
parentac5519bafd4c98980fb80af9656f90be3793f47e (diff)
downloadfreebsd-ports-gnome-e923b2cc78d48a9f871a0bcf28966a14709c8370.tar.gz
freebsd-ports-gnome-e923b2cc78d48a9f871a0bcf28966a14709c8370.tar.zst
freebsd-ports-gnome-e923b2cc78d48a9f871a0bcf28966a14709c8370.zip
comms/airspy: Fix build due to the MMX-related errors
Fix errors like this: error: always_inline function '_mm_loadu_ps' requires target feature 'mmx', but would be inlined into function 'x' that is compiled without support for 'mmx' Reported by: fallout
Diffstat (limited to 'comms/airspy')
-rw-r--r--comms/airspy/Makefile8
-rw-r--r--comms/airspy/files/patch-libairspy_src_iqconverter__float.c12
2 files changed, 20 insertions, 0 deletions
diff --git a/comms/airspy/Makefile b/comms/airspy/Makefile
index 9932a78d4d16..bb5a61d50a1a 100644
--- a/comms/airspy/Makefile
+++ b/comms/airspy/Makefile
@@ -4,6 +4,7 @@ PORTNAME= airspy
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.9-18
DISTVERSIONSUFFIX= -gbfb6670
+PORTREVISION= 1
CATEGORIES= comms hamradio
MAINTAINER= yuri@FreeBSD.org
@@ -22,4 +23,11 @@ USE_LDCONFIG= yes
CMAKE_OFF= INSTALL_UDEV_RULES
CMAKE_ARGS= -DLIBUSB_LIBRARIES="/usr/lib/libusb.so"
+OPTIONS_DEFINE_amd64= SSE
+OPTIONS_DEFINE_i386= SSE
+OPTIONS_DEFAULT_amd64= SSE
+OPTIONS_DEFAULT_i386= SSE
+
+SSE_CFLAGS= -DFREEBSD_USE_SIMD -msse -msse2 -mfpmath=sse -mmmx
+
.include <bsd.port.mk>
diff --git a/comms/airspy/files/patch-libairspy_src_iqconverter__float.c b/comms/airspy/files/patch-libairspy_src_iqconverter__float.c
new file mode 100644
index 000000000000..b990181a257f
--- /dev/null
+++ b/comms/airspy/files/patch-libairspy_src_iqconverter__float.c
@@ -0,0 +1,12 @@
+--- libairspy/src/iqconverter_float.c.orig 2018-06-27 04:58:05 UTC
++++ libairspy/src/iqconverter_float.c
+@@ -39,7 +39,9 @@ THE SOFTWARE.
+ #define _inline inline
+ #define FIR_STANDARD
+ #elif defined(__FreeBSD__)
++# if defined(FREEBSD_USE_SIMD)
+ #define USE_SSE2
++# endif
+ #include <immintrin.h>
+ #define _inline inline
+ #define _aligned_free(mem) free(mem)