aboutsummaryrefslogtreecommitdiffstats
path: root/comms/conserver/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
committertg <tg@FreeBSD.org>2000-07-05 20:37:06 +0800
commit3a84881f168162a487490bbbd275ca05b7f5560d (patch)
treee888acd7e17d635c1f902fccb1eefdf89f15641a /comms/conserver/Makefile
parent83513fef56c1c9996eb040a93488ed7837fac927 (diff)
downloadfreebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.tar.gz
freebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.tar.zst
freebsd-ports-gnome-3a84881f168162a487490bbbd275ca05b7f5560d.zip
As threatened on freebsd-ports: all startup scripts know about the two
options `start' and `stop' now (unless I have forgotten any). This allows us to call the scripts from /etc/rc.shutdown with the correct option. The (42 or so) ports that already DTRT before are unchanged.
Diffstat (limited to 'comms/conserver/Makefile')
-rw-r--r--comms/conserver/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/comms/conserver/Makefile b/comms/conserver/Makefile
index e07cc9a78909..4ab1c30a28ba 100644
--- a/comms/conserver/Makefile
+++ b/comms/conserver/Makefile
@@ -37,11 +37,8 @@ post-extract:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/conserver.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/conserver.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/conserver.sh; \
- ${ECHO} "if [ -x ${PREFIX}/sbin/conserver -a -f ${PREFIX}/etc/conserver.cf ]; then" >> ${PREFIX}/etc/rc.d/conserver.sh; \
- ${ECHO} " ${PREFIX}/sbin/conserver -d -n ; ${ECHO} -n ' conserver'" >> ${PREFIX}/etc/rc.d/conserver.sh; \
- ${ECHO} "fi" >> ${PREFIX}/etc/rc.d/conserver.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/conserver.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/conserver.sh \
+ ${PREFIX}/etc/rc.d/conserver.sh; \
fi
.include <bsd.port.mk>