aboutsummaryrefslogtreecommitdiffstats
path: root/comms/cqrlog
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2018-02-19 04:33:49 +0800
committerdb <db@FreeBSD.org>2018-02-19 04:33:49 +0800
commit49c286df9de9eb7f056158c9be0b3e2b43f4e730 (patch)
tree26b61a3007d935d2b5259668f597f93ba1b8bb75 /comms/cqrlog
parente770cf081e32155851ef08c5c58d93dfcb3bc0e3 (diff)
downloadfreebsd-ports-gnome-49c286df9de9eb7f056158c9be0b3e2b43f4e730.tar.gz
freebsd-ports-gnome-49c286df9de9eb7f056158c9be0b3e2b43f4e730.tar.zst
freebsd-ports-gnome-49c286df9de9eb7f056158c9be0b3e2b43f4e730.zip
Version 2.2.0
wsjt remote mode improvements (Saku, OH1KH) CQ-monitor now remembers showing state (Saku, OH1KH) "My Alert" is now compared oppsite way: This should fit also compound callsign XX/YOURCALL or YOURCALL/XX (Saku, OH1KH) CQ-monitor: Country names (cut to length 15) are now displayed instead of callsign prefixes. (Saku, OH1KH) "Show only active band" checkbox addec to Band map filter for quick access. (Saku, OH1KH) "Re/Set" button added to Export "Choose fields to export" dialog for set/reset all check boxes in one go. (Saku, OH1KH) a lot of CQ monitor improvements (Saku, OH1KH) remote wsjt: Short cut key Ctrl+J (Saku, OH1KH) help files updated (Saku, OH1KH) Voice keyer works now also with FM and AM modes and also from CWkeys windows. (Saku, OH1KH) QSO in QSO list window can be sorted in ascending date/time order (oldes QSO first). (Jörg, DL8DTL) CQRLOG should work correcly on HiDPI monitors 630M definition was missing in some functions (Saku, OH1KH) ADIF upload didn't work when name or QTH were too long
Diffstat (limited to 'comms/cqrlog')
-rw-r--r--comms/cqrlog/Makefile13
-rw-r--r--comms/cqrlog/distinfo6
-rw-r--r--comms/cqrlog/files/patch-Makefile16
-rw-r--r--comms/cqrlog/files/patch-help_h1.html6
-rw-r--r--comms/cqrlog/files/patch-src_ssl__openssl__lib.pas20
-rw-r--r--comms/cqrlog/files/patch-src_synaser.pas65
-rw-r--r--comms/cqrlog/pkg-plist53
7 files changed, 71 insertions, 108 deletions
diff --git a/comms/cqrlog/Makefile b/comms/cqrlog/Makefile
index 943a9e9e37a2..57e76b6627c1 100644
--- a/comms/cqrlog/Makefile
+++ b/comms/cqrlog/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cqrlog
-PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTVERSION= 2.2.0
DISTVERSIONPREFIX= v
CATEGORIES= comms hamradio
@@ -22,9 +21,10 @@ GH_ACCOUNT= ok2cqr
USES= shebangfix
SHEBANG_FILES= tools/cqrlog-apparmor-fix \
voice_keyer/voice_keyer.sh
-
-USE_FPC= cairo fcl-base fcl-db fcl-image fcl-json fcl-net fcl-web \
- fcl-registry rtl-extra fcl-xml mysql numlib openssl pasjpeg x11
+
+USE_FPC= cairo fcl-base chm fcl-db fcl-image fcl-json fcl-net fcl-web \
+ fcl-registry rtl-extra fcl-xml mysql numlib openssl \
+ pasjpeg regexpr x11
ALL_TARGET= ${PORTNAME}
@@ -35,6 +35,9 @@ OPTIONS_SINGLE= LCL
OPTIONS_SINGLE_LCL= GTK2 QT4
OPTIONS_DEFAULT= GTK2
+USE_XORG+= x11
+USE_GNOME+= gdkpixbuf2 cairo
+
GTK2_USE= fpc=gtk2 gnome=gtk20
GTK2_BUILD_DEPENDS= ${LAZARUS_DIR}/lcl/units/${BUILDNAME}/gtk2/interfaces.ppu:editors/lazarus-lcl-gtk2
GTK2_MAKE_ARGS= PLATFORM=gtk2
diff --git a/comms/cqrlog/distinfo b/comms/cqrlog/distinfo
index 520e83d080f6..4861b103399d 100644
--- a/comms/cqrlog/distinfo
+++ b/comms/cqrlog/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1488127529
-SHA256 (ok2cqr-cqrlog-v2.0.4_GH0.tar.gz) = 70aa5b09e281059d7a310ff3c2e4b428ae19e1f7413800fa4d1aaabd2c94f6a0
-SIZE (ok2cqr-cqrlog-v2.0.4_GH0.tar.gz) = 7737032
+TIMESTAMP = 1518534250
+SHA256 (ok2cqr-cqrlog-v2.2.0_GH0.tar.gz) = 6e148f5dd3242aa69884db704016418daef0683da12b906b70fe9a96bf5bbb2b
+SIZE (ok2cqr-cqrlog-v2.2.0_GH0.tar.gz) = 9784876
diff --git a/comms/cqrlog/files/patch-Makefile b/comms/cqrlog/files/patch-Makefile
index cfdf3c99e1af..ae8aba6e1e30 100644
--- a/comms/cqrlog/files/patch-Makefile
+++ b/comms/cqrlog/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2016-04-20 16:06:15 UTC
-+++ Makefile
+--- Makefile.orig 2017-12-30 02:10:01.000000000 -0500
++++ Makefile 2018-01-05 12:34:28.752177000 -0500
@@ -1,12 +1,13 @@
-CC=lazbuild
+CC=lazbuild -d
@@ -19,18 +19,18 @@
$(ST) src/cqrlog
gzip tools/cqrlog.1 -c > tools/cqrlog.1.gz
-@@ -30,7 +31,7 @@ install:
- install -d -v $(sharedir)/pixmaps/cqrlog
- install -d -v $(sharedir)/icons
+@@ -38,7 +39,7 @@
+ install -d -v $(sharedir)/icons/cqrlog
install -d -v $(sharedir)/applications
+ install -d -v $(sharedir)/appdata
- install -d -v $(sharedir)/man/man1
+ install -d -v $(mandir)/man/man1
install -v -m 0755 src/cqrlog $(bindir)
install -v -m 0755 tools/cqrlog-apparmor-fix $(datadir)/cqrlog-apparmor-fix
install -v -m 0644 ctyfiles/* $(datadir)/ctyfiles/
-@@ -47,7 +48,7 @@ install:
- install -v -m 0644 images/cqrlog.png $(sharedir)/pixmaps/cqrlog/cqrlog.png
- install -v -m 0644 images/cqrlog.png $(sharedir)/icons/cqrlog.png
+@@ -64,7 +65,7 @@
+ install -v -m 0644 images/icon/32x32/cqrlog.png $(sharedir)/pixmaps/cqrlog/cqrlog.png
+ install -v -m 0644 images/icon/128x128/cqrlog.png $(sharedir)/icons/cqrlog.png
install -v -m 0644 src/changelog.html $(datadir)/changelog.html
- install -v -m 0644 tools/cqrlog.1.gz $(sharedir)/man/man1/cqrlog.1.gz
+ install -v -m 0644 tools/cqrlog.1.gz $(mandir)/man/man1/cqrlog.1.gz
diff --git a/comms/cqrlog/files/patch-help_h1.html b/comms/cqrlog/files/patch-help_h1.html
index 8ca2d51991cd..27aabb81d2d5 100644
--- a/comms/cqrlog/files/patch-help_h1.html
+++ b/comms/cqrlog/files/patch-help_h1.html
@@ -1,6 +1,6 @@
---- help/h1.html.orig 2016-04-24 21:16:09 UTC
-+++ help/h1.html
-@@ -401,7 +401,7 @@ There are no known dependencies issues.<
+--- help/h1.html.orig 2017-12-30 02:10:01.000000000 -0500
++++ help/h1.html 2018-01-05 12:34:48.900265000 -0500
+@@ -414,7 +414,7 @@
<pre>/usr/local/bin/xplanet</pre>
is OK in most cases for installation from sources,
the usual path for installation from precompiled packages is
diff --git a/comms/cqrlog/files/patch-src_ssl__openssl__lib.pas b/comms/cqrlog/files/patch-src_ssl__openssl__lib.pas
deleted file mode 100644
index e1e66d989d61..000000000000
--- a/comms/cqrlog/files/patch-src_ssl__openssl__lib.pas
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/ssl_openssl_lib.pas.orig 2016-04-20 16:06:15 UTC
-+++ src/ssl_openssl_lib.pas
-@@ -86,7 +86,7 @@ uses
-
- {$IFDEF CIL}
- const
-- {$IFDEF LINUX}
-+ {$IFNDEF WIN32}
- DLLSSLName = 'libssl.so';
- DLLUtilName = 'libcrypto.so';
- {$ELSE}
-@@ -1704,7 +1704,7 @@ begin
- {$ELSE}
- SSLLibHandle := LoadLib(DLLSSLName);
- SSLUtilHandle := LoadLib(DLLUtilName);
-- {$IFNDEF LINUX}
-+ {$IFDEF WIN32}
- if (SSLLibHandle = 0) then
- SSLLibHandle := LoadLib(DLLSSLName2);
- {$ENDIF}
diff --git a/comms/cqrlog/files/patch-src_synaser.pas b/comms/cqrlog/files/patch-src_synaser.pas
deleted file mode 100644
index e8837eb7e65d..000000000000
--- a/comms/cqrlog/files/patch-src_synaser.pas
+++ /dev/null
@@ -1,65 +0,0 @@
---- src/synaser.pas.orig 2016-04-20 16:06:15 UTC
-+++ src/synaser.pas
-@@ -302,7 +302,7 @@ type
- procedure DcbToTermios(const dcb: TDCB; var term: termios); virtual;
- procedure TermiosToDcb(const term: termios; var dcb: TDCB); virtual;
- {$ENDIF}
--{$IFDEF LINUX}
-+{$IFDEF UNIX}
- function ReadLockfile: integer; virtual;
- function LockfileName: String; virtual;
- procedure CreateLockfile(PidNr: integer); virtual;
-@@ -591,7 +591,7 @@ type
-
- {:Raise Synaser error with ErrNumber code. Usually used by internal routines.}
- procedure RaiseSynaError(ErrNumber: integer); virtual;
--{$IFDEF LINUX}
-+{$IFDEF UNIX}
- function cpomComportAccessible: boolean; virtual;{HGJ}
- procedure cpomReleaseComport; virtual; {HGJ}
- {$ENDIF}
-@@ -766,7 +766,7 @@ begin
- end;
- if InstanceActive then
- begin
-- {$IFDEF LINUX}
-+ {$IFDEF UNIX}
- if FLinuxLock then
- cpomReleaseComport;
- {$ENDIF}
-@@ -917,7 +917,7 @@ begin
- FHandle := THandle(fpOpen(FDevice, O_RDWR or O_SYNC));
- {$ENDIF}
- SerialCheck(integer(FHandle));
-- {$IFDEF LINUX}
-+ {$IFDEF UNIX}
- if FLastError <> sOK then
- if FLinuxLock then
- cpomReleaseComport;
-@@ -949,7 +949,7 @@ begin
- begin
- SetSynaError(ErrNoDeviceAnswer);
- FileClose(integer(FHandle)); {HGJ}
-- {$IFDEF LINUX}
-+ {$IFDEF UNIX}
- if FLinuxLock then
- cpomReleaseComport; {HGJ}
- {$ENDIF} {HGJ}
-@@ -1899,7 +1899,7 @@ begin
- {$IFNDEF FPC}
- SerialCheck(ioctl(integer(FHandle), TCFLSH, TCIOFLUSH));
- {$ELSE}
-- SerialCheck(fpioctl(integer(FHandle), TCFLSH, Pointer(PtrInt(TCIOFLUSH))));
-+ SerialCheck(TCFlush(integer(FHandle), TCIOFLUSH));
- //SerialCheck(fpioctl(integer(FHandle), TCFLSH, TCIOFLUSH));
- {$ENDIF}
- FBuffer := '';
-@@ -2136,7 +2136,7 @@ end;
- Ownership Manager.
- }
-
--{$IFDEF LINUX}
-+{$IFDEF UNIX}
-
- function TBlockSerial.LockfileName: String;
- var
diff --git a/comms/cqrlog/pkg-plist b/comms/cqrlog/pkg-plist
index 2ac98fd1090f..7e4ab84ce409 100644
--- a/comms/cqrlog/pkg-plist
+++ b/comms/cqrlog/pkg-plist
@@ -1,5 +1,6 @@
bin/cqrlog
man/man1/cqrlog.1.gz
+share/appdata/cqrlog.appdata.xml
share/applications/cqrlog.desktop
%%DATADIR%%/changelog.html
%%DATADIR%%/cqrlog-apparmor-fix
@@ -16,12 +17,10 @@ share/applications/cqrlog.desktop
%%DATADIR%%/ctyfiles/lotw1.txt
%%DATADIR%%/ctyfiles/qslmgr.csv
%%DATADIR%%/ctyfiles/us_states.tab
+%%DATADIR%%/help/contest.html
%%DATADIR%%/help/cwd.html
-%%DATADIR%%/help/cwd.html.bak
-%%DATADIR%%/help/cwd.html.orig
+%%DATADIR%%/help/fldxml.html
%%DATADIR%%/help/h1.html
-%%DATADIR%%/help/h1.html.bak
-%%DATADIR%%/help/h1.html.orig
%%DATADIR%%/help/h20.html
%%DATADIR%%/help/h21.html
%%DATADIR%%/help/h22.html
@@ -30,6 +29,7 @@ share/applications/cqrlog.desktop
%%DATADIR%%/help/h25.html
%%DATADIR%%/help/h26.html
%%DATADIR%%/help/h27.html
+%%DATADIR%%/help/h28.html
%%DATADIR%%/help/h3.html
%%DATADIR%%/help/h4.html
%%DATADIR%%/help/h5.html
@@ -38,8 +38,13 @@ share/applications/cqrlog.desktop
%%DATADIR%%/help/h8.html
%%DATADIR%%/help/img/bulb.png
%%DATADIR%%/help/img/c03.jpg
+%%DATADIR%%/help/img/contest.png
+%%DATADIR%%/help/img/contest_html_export.png
%%DATADIR%%/help/img/cwdaem.png
%%DATADIR%%/help/img/exc.png
+%%DATADIR%%/help/img/fxml5.png
+%%DATADIR%%/help/img/fxml8.png
+%%DATADIR%%/help/img/fxml9.png
%%DATADIR%%/help/img/h1.png
%%DATADIR%%/help/img/h10.png
%%DATADIR%%/help/img/h100.png
@@ -160,11 +165,40 @@ share/applications/cqrlog.desktop
%%DATADIR%%/help/img/h98.png
%%DATADIR%%/help/img/h99.png
%%DATADIR%%/help/img/line.png
+%%DATADIR%%/help/img/misc12.png
+%%DATADIR%%/help/img/misc13.png
+%%DATADIR%%/help/img/misc14.png
+%%DATADIR%%/help/img/misc3.png
+%%DATADIR%%/help/img/misc40.png
+%%DATADIR%%/help/img/misc41.png
+%%DATADIR%%/help/img/misc42.png
+%%DATADIR%%/help/img/misc43.png
+%%DATADIR%%/help/img/misc44.png
+%%DATADIR%%/help/img/misc5.png
+%%DATADIR%%/help/img/misc8.png
%%DATADIR%%/help/img/note.png
%%DATADIR%%/help/img/radio_memory.png
+%%DATADIR%%/help/img/wkdgrid10.png
+%%DATADIR%%/help/img/wkdgrid11.png
+%%DATADIR%%/help/img/wkdgrid9.png
+%%DATADIR%%/help/img/wsjt1.png
+%%DATADIR%%/help/img/wsjt15.png
+%%DATADIR%%/help/img/wsjt16.png
+%%DATADIR%%/help/img/wsjt17.png
+%%DATADIR%%/help/img/wsjt18.png
+%%DATADIR%%/help/img/wsjt19.png
+%%DATADIR%%/help/img/wsjt2.png
+%%DATADIR%%/help/img/wsjt20.png
+%%DATADIR%%/help/img/wsjt21.png
+%%DATADIR%%/help/img/wsjt27.png
+%%DATADIR%%/help/img/wsjt28.png
+%%DATADIR%%/help/img/wsjt4.png
%%DATADIR%%/help/index.html
+%%DATADIR%%/help/remi.html
%%DATADIR%%/help/sql_console.html
+%%DATADIR%%/help/wkdgrid.html
%%DATADIR%%/help/wkusb.html
+%%DATADIR%%/help/wsjt.html
%%DATADIR%%/images/BigEarth.bmp
%%DATADIR%%/images/HamQTH.png
%%DATADIR%%/images/bck.png
@@ -209,6 +243,7 @@ share/applications/cqrlog.desktop
%%DATADIR%%/images/sunset_small_.png
%%DATADIR%%/images/uses_eqsl.png
%%DATADIR%%/images/view.png
+%%DATADIR%%/images/world_borders.png
%%DATADIR%%/members/070-club.txt
%%DATADIR%%/members/10-10.txt
%%DATADIR%%/members/599dxa.txt
@@ -216,6 +251,7 @@ share/applications/cqrlog.desktop
%%DATADIR%%/members/a1-club.txt
%%DATADIR%%/members/a1-op.txt
%%DATADIR%%/members/afm.txt
+%%DATADIR%%/members/agb.txt
%%DATADIR%%/members/agcw.txt
%%DATADIR%%/members/arci.txt
%%DATADIR%%/members/arktika.txt
@@ -231,7 +267,9 @@ share/applications/cqrlog.desktop
%%DATADIR%%/members/cfo.txt
%%DATADIR%%/members/cft.txt
%%DATADIR%%/members/conveniat.txt
+%%DATADIR%%/members/cqcw.txt
%%DATADIR%%/members/ctc.txt
+%%DATADIR%%/members/ctid.txt
%%DATADIR%%/members/cwjf.txt
%%DATADIR%%/members/cwops.txt
%%DATADIR%%/members/cwsp.txt
@@ -248,22 +286,27 @@ share/applications/cqrlog.desktop
%%DATADIR%%/members/foc.txt
%%DATADIR%%/members/foc_names.txt
%%DATADIR%%/members/fog.txt
+%%DATADIR%%/members/fpqrp.txt
%%DATADIR%%/members/gacw.txt
%%DATADIR%%/members/gdxf.txt
%%DATADIR%%/members/gqrpc.txt
+%%DATADIR%%/members/gra.txt
%%DATADIR%%/members/gtc.txt
%%DATADIR%%/members/hacwg.txt
+%%DATADIR%%/members/hadxc.txt
%%DATADIR%%/members/hh.txt
%%DATADIR%%/members/hhc.txt
%%DATADIR%%/members/hsc.txt
%%DATADIR%%/members/htc.txt
%%DATADIR%%/members/inorc.txt
%%DATADIR%%/members/jaig.txt
+%%DATADIR%%/members/lcc.txt
%%DATADIR%%/members/lids.txt
%%DATADIR%%/members/marac.txt
%%DATADIR%%/members/marconista.txt
%%DATADIR%%/members/mcl.txt
%%DATADIR%%/members/mcwg.txt
+%%DATADIR%%/members/mdxc.txt
%%DATADIR%%/members/mdxg.txt
%%DATADIR%%/members/mf.txt
%%DATADIR%%/members/mfca.txt
@@ -302,6 +345,7 @@ share/applications/cqrlog.desktop
%%DATADIR%%/members/udxc.txt
%%DATADIR%%/members/uft.txt
%%DATADIR%%/members/uksmg.txt
+%%DATADIR%%/members/uqrqc.txt
%%DATADIR%%/members/vhsc.txt
%%DATADIR%%/members/vrk.txt
%%DATADIR%%/members/wap.txt
@@ -317,6 +361,7 @@ share/applications/cqrlog.desktop
%%DATADIR%%/zipcodes/italy-prov.txt
%%DATADIR%%/zipcodes/usa-ca.txt
%%DATADIR%%/zipcodes/usa-states.txt
+share/icons/cqrlog.png
share/icons/cqrlog/128x128/cqrlog.png
share/icons/cqrlog/256x256/cqrlog.png
share/icons/cqrlog/32x32/cqrlog.png