aboutsummaryrefslogtreecommitdiffstats
path: root/comms/cwdaemon/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-03-17 23:45:39 +0800
committervs <vs@FreeBSD.org>2005-03-17 23:45:39 +0800
commit60dabe6485ca94790262d52ddfe622a056e4f4b4 (patch)
tree87284b4ca76c3fe364befd702ed2b9bed71dd1cc /comms/cwdaemon/Makefile
parentf3b82c7e5cf51eedf5dff6af70695758e5b6ab2e (diff)
downloadfreebsd-ports-gnome-60dabe6485ca94790262d52ddfe622a056e4f4b4.tar.gz
freebsd-ports-gnome-60dabe6485ca94790262d52ddfe622a056e4f4b4.tar.zst
freebsd-ports-gnome-60dabe6485ca94790262d52ddfe622a056e4f4b4.zip
Add cwdaemon 0.9.2, an amateur Radio cw (morse code) keyer daemon:
Cwdaemon is a small daemon which uses the pc parallel or serial port and a simple transistor switch to output morse code to a transmitter from a text message sent to it via the udp internet protocol. PR: ports/74772 Submitted by: Diane Bruce <db AT db.net>
Diffstat (limited to 'comms/cwdaemon/Makefile')
-rw-r--r--comms/cwdaemon/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/comms/cwdaemon/Makefile b/comms/cwdaemon/Makefile
new file mode 100644
index 000000000000..5dfdc6ae576d
--- /dev/null
+++ b/comms/cwdaemon/Makefile
@@ -0,0 +1,31 @@
+# ports collection makefile for: cwdaemon
+# Date created: 17 Mar 2005
+# Whom: Diane Bruce <db@db.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cwdaemon
+PORTVERSION= 0.9.2
+CATEGORIES= comms
+MASTER_SITES= http://pg4i.mattsnetwork.co.uk/download/
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= db@db.net
+COMMENT= Amateur Radio cw (morse code) keyer daemon
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-exec
+
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/doc
+MAN8= cwdaemon.8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}; ${MAKE} install-data
+.else
+ cd ${WRKSRC}; ${MAKE} install-man
+.endif
+
+.include <bsd.port.mk>