aboutsummaryrefslogtreecommitdiffstats
path: root/comms/dabstick-radio/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-08-23 21:58:06 +0800
committerdanfe <danfe@FreeBSD.org>2015-08-23 21:58:06 +0800
commit1b99b311d6949241b8b6af908fa690b918649f53 (patch)
treed7e4bb9afa5cf3d4a317c34cb2def15670c6693d /comms/dabstick-radio/Makefile
parent840edc908a1f27de97b0eb9aec8d1f53b38e5316 (diff)
downloadfreebsd-ports-gnome-1b99b311d6949241b8b6af908fa690b918649f53.tar.gz
freebsd-ports-gnome-1b99b311d6949241b8b6af908fa690b918649f53.tar.zst
freebsd-ports-gnome-1b99b311d6949241b8b6af908fa690b918649f53.zip
Consistently spell out ONLY_FOR_ARCHS_REASON due to SSE (and other SIMD
instructions) use. Particularly, saying "SSE extensions" is superfluous, as SSE abbreviation itself means "Streaming SIMD Extensions". Correct way to refer to particular (CPU-agnostic) technology is "SIMD instruction set", which is not limited to MMX, SSE family, AVX, NEON, etc. Since "instruction set" looks a bit too formal in the option description, use more casual and shorter word "instructions".
Diffstat (limited to 'comms/dabstick-radio/Makefile')
-rw-r--r--comms/dabstick-radio/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index 95d49a809484..ad6d8d223754 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -28,13 +28,13 @@ PORTDOCS= *
PLIST_FILES+= bin/dabreceiver bin/fmreceiver bin/spectrum-viewer
ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= uses MMX and SSE2
+ONLY_FOR_ARCHS_REASON= uses MMX and SSE2 instructions
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if (${OSVERSION} >= 901000) && exists(${DESTDIR}/usr/bin/clang)
+.if (${OSVERSION} >= 900014) && exists(${DESTDIR}/usr/bin/clang)
CC= clang
CXX= clang++
CPP= clang-cpp