aboutsummaryrefslogtreecommitdiffstats
path: root/comms/dfu-util
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-02-19 07:07:57 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-02-19 07:07:57 +0800
commit6c9b0f654f66ef7faa3e8064238876156aaea8d7 (patch)
tree0a2972ff68f04d5d345975540f252a496910482d /comms/dfu-util
parent5244d085b69beaaa823290647df67f2619ae1cf9 (diff)
downloadfreebsd-ports-gnome-6c9b0f654f66ef7faa3e8064238876156aaea8d7.tar.gz
freebsd-ports-gnome-6c9b0f654f66ef7faa3e8064238876156aaea8d7.tar.zst
freebsd-ports-gnome-6c9b0f654f66ef7faa3e8064238876156aaea8d7.zip
dfu-util is a program that implements the host (PC) side of the USB DFU
(Universal Serial Bus Device Firmware Upgrade) protocol. In the OpenMoko project (for example), this program is used to communicate with the specially enhanced u-boot boot loader, which implements the DFU device side. Author: Bruce Cran <bruce@cran.org.uk> WWW: http://wiki.openmoko.org/wiki/Dfu-util PR: 131430 Submitted by: Bruce Cran <bruce at cran dot org dot uk>
Diffstat (limited to 'comms/dfu-util')
-rw-r--r--comms/dfu-util/Makefile37
-rw-r--r--comms/dfu-util/distinfo3
-rw-r--r--comms/dfu-util/files/patch-configure.ac13
-rw-r--r--comms/dfu-util/files/patch-src-commands.h11
-rw-r--r--comms/dfu-util/files/patch-src-dfu.c11
-rw-r--r--comms/dfu-util/files/patch-src-dfu.h11
-rw-r--r--comms/dfu-util/files/patch-src-main.c11
-rw-r--r--comms/dfu-util/files/patch-src-sam7dfu.c11
-rw-r--r--comms/dfu-util/pkg-descr9
-rw-r--r--comms/dfu-util/pkg-message2
10 files changed, 119 insertions, 0 deletions
diff --git a/comms/dfu-util/Makefile b/comms/dfu-util/Makefile
new file mode 100644
index 000000000000..6f8748f77847
--- /dev/null
+++ b/comms/dfu-util/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: dfu-util
+# Date created: 2008-02-04
+# Whom: Bruce Cran <bruce@cran.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dfu-util
+DISTVERSION= 0.1.snap${SNAPDATE}
+CATEGORIES= comms
+MASTER_SITES= http://www.cran.org.uk/~brucec/software/
+
+MAINTAINER= bruce@cran.org.uk
+COMMENT= Device firmware update (DFU) USB programmer
+
+MAN1= dfu-util.1
+PLIST_FILES= bin/dfu-util
+USE_AUTOTOOLS= aclocal:19 automake:19 autoheader:262
+AUTOMAKE_ARGS= --add-missing --foreign --copy
+
+SNAPDATE= 20090212
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800063
+IGNORE= requires new USB stack in FreeBSD 8
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dfu-util ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/dfu-util.1 ${MAN1PREFIX}/man/man1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/comms/dfu-util/distinfo b/comms/dfu-util/distinfo
new file mode 100644
index 000000000000..f8147e2fac99
--- /dev/null
+++ b/comms/dfu-util/distinfo
@@ -0,0 +1,3 @@
+MD5 (dfu-util-0.1.snap20090212.tar.gz) = b11b6a0e5adcf549ec139e3f68879fb8
+SHA256 (dfu-util-0.1.snap20090212.tar.gz) = 3af5421857ee83df09ccd5d1061620a93907820ff9df7e0706e54e88548b2496
+SIZE (dfu-util-0.1.snap20090212.tar.gz) = 21774
diff --git a/comms/dfu-util/files/patch-configure.ac b/comms/dfu-util/files/patch-configure.ac
new file mode 100644
index 000000000000..b8e800739dd7
--- /dev/null
+++ b/comms/dfu-util/files/patch-configure.ac
@@ -0,0 +1,13 @@
+--- configure.ac.orig 2008-10-07 14:14:07.000000000 +0100
++++ configure.ac 2009-02-04 22:04:02.000000000 +0000
+@@ -15,9 +15,7 @@
+
+ # Checks for libraries.
+
+-PKG_CHECK_MODULES(USB, libusb >= 0.1.4,,
+- AC_MSG_ERROR([*** Required libusb >= 0.1.4 not installed ***]))
+-AC_CHECK_LIB([usbpath],[usb_path2devnum],,,-lusb)
++USB_LIBS=-lusb20
+
+ LIBS="$LIBS $USB_LIBS"
+ CFLAGS="$CFLAGS $USB_CFLAGS"
diff --git a/comms/dfu-util/files/patch-src-commands.h b/comms/dfu-util/files/patch-src-commands.h
new file mode 100644
index 000000000000..2cfa3d43aef5
--- /dev/null
+++ b/comms/dfu-util/files/patch-src-commands.h
@@ -0,0 +1,11 @@
+--- src/commands.h.orig 2007-02-22 21:33:15.000000000 +0000
++++ src/commands.h 2009-02-04 22:04:41.000000000 +0000
+@@ -21,7 +21,7 @@
+ #ifndef __COMMANDS_H__
+ #define __COMMANDS_H__
+
+-#include <usb.h>
++#include <libusb20_compat01.h>
+ #include "arguments.h"
+
+ int execute_command( struct usb_dev_handle *device,
diff --git a/comms/dfu-util/files/patch-src-dfu.c b/comms/dfu-util/files/patch-src-dfu.c
new file mode 100644
index 000000000000..03fd922339e7
--- /dev/null
+++ b/comms/dfu-util/files/patch-src-dfu.c
@@ -0,0 +1,11 @@
+--- src/dfu.c.orig 2007-02-25 15:43:05.000000000 +0000
++++ src/dfu.c 2009-02-04 22:05:08.000000000 +0000
+@@ -19,7 +19,7 @@
+ */
+
+ #include <stdio.h>
+-#include <usb.h>
++#include <libusb20_compat01.h>
+ #include "dfu.h"
+
+ /* DFU commands */
diff --git a/comms/dfu-util/files/patch-src-dfu.h b/comms/dfu-util/files/patch-src-dfu.h
new file mode 100644
index 000000000000..d7e08a0b911c
--- /dev/null
+++ b/comms/dfu-util/files/patch-src-dfu.h
@@ -0,0 +1,11 @@
+--- src/dfu.h.orig 2007-02-25 15:43:05.000000000 +0000
++++ src/dfu.h 2009-02-04 22:05:15.000000000 +0000
+@@ -21,7 +21,7 @@
+ #ifndef __DFU_H__
+ #define __DFU_H__
+
+-#include <usb.h>
++#include <libusb20_compat01.h>
+ #include "usb_dfu.h"
+
+ /* DFU states */
diff --git a/comms/dfu-util/files/patch-src-main.c b/comms/dfu-util/files/patch-src-main.c
new file mode 100644
index 000000000000..5a09bb0f48b0
--- /dev/null
+++ b/comms/dfu-util/files/patch-src-main.c
@@ -0,0 +1,11 @@
+--- src/main.c 2009-02-09 01:50:55.118776000 +0000
++++ src/main.c 2009-02-12 21:15:13.000000000 +0000
+@@ -26,7 +26,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <getopt.h>
+-#include <usb.h>
++#include <libusb20_compat01.h>
+ #include <errno.h>
+
+ #include "dfu.h"
diff --git a/comms/dfu-util/files/patch-src-sam7dfu.c b/comms/dfu-util/files/patch-src-sam7dfu.c
new file mode 100644
index 000000000000..85227047092f
--- /dev/null
+++ b/comms/dfu-util/files/patch-src-sam7dfu.c
@@ -0,0 +1,11 @@
+--- src/sam7dfu.c 2009-02-09 01:50:55.118776000 +0000
++++ src/sam7dfu.c 2009-02-12 21:15:27.000000000 +0000
+@@ -12,7 +12,7 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <string.h>
+-#include <usb.h>
++#include <libusb20_compat01.h>
+
+ #include "config.h"
+ #include "dfu.h"
diff --git a/comms/dfu-util/pkg-descr b/comms/dfu-util/pkg-descr
new file mode 100644
index 000000000000..299192e950a6
--- /dev/null
+++ b/comms/dfu-util/pkg-descr
@@ -0,0 +1,9 @@
+dfu-util is a program that implements the host (PC) side of the USB DFU
+(Universal Serial Bus Device Firmware Upgrade) protocol.
+
+In the OpenMoko project (for example), this program is used to communicate
+with the specially enhanced u-boot boot loader, which implements the DFU
+device side.
+
+Author: Bruce Cran <bruce@cran.org.uk>
+WWW: http://wiki.openmoko.org/wiki/Dfu-util
diff --git a/comms/dfu-util/pkg-message b/comms/dfu-util/pkg-message
new file mode 100644
index 000000000000..df412ea52d65
--- /dev/null
+++ b/comms/dfu-util/pkg-message
@@ -0,0 +1,2 @@
+Note: dfu-util may not work on the first run, it might be necessary to run it
+twice before it detects the device correctly.