aboutsummaryrefslogtreecommitdiffstats
path: root/comms/efax-gtk/files
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-28 05:45:41 +0800
committerpav <pav@FreeBSD.org>2004-06-28 05:45:41 +0800
commitcd17eeb3fc5729b28a05cb9b73f4df826b2f80ee (patch)
tree86f573b3785e58e851b84410771971a31ab17f40 /comms/efax-gtk/files
parent762268be86847d23f905c96668b9eaf4d3a9b793 (diff)
downloadfreebsd-ports-gnome-cd17eeb3fc5729b28a05cb9b73f4df826b2f80ee.tar.gz
freebsd-ports-gnome-cd17eeb3fc5729b28a05cb9b73f4df826b2f80ee.tar.zst
freebsd-ports-gnome-cd17eeb3fc5729b28a05cb9b73f4df826b2f80ee.zip
- Update to 2.2.8
PR: ports/68417 Submitted by: Jean-Baptiste Quenot <jb.quenot@caraldi.com> (maintainer)
Diffstat (limited to 'comms/efax-gtk/files')
-rw-r--r--comms/efax-gtk/files/patch-install11
-rw-r--r--comms/efax-gtk/files/patch-pthread-include66
-rw-r--r--comms/efax-gtk/files/patch-src::config.h.in12
-rw-r--r--comms/efax-gtk/files/patch-src::prog_defs.h11
4 files changed, 66 insertions, 34 deletions
diff --git a/comms/efax-gtk/files/patch-install b/comms/efax-gtk/files/patch-install
deleted file mode 100644
index 86d620b3980b..000000000000
--- a/comms/efax-gtk/files/patch-install
+++ /dev/null
@@ -1,11 +0,0 @@
---- efax-gtk-faxfilter/Makefile.in.orig Thu Feb 5 21:35:06 2004
-+++ efax-gtk-faxfilter/Makefile.in Sun Feb 29 15:48:48 2004
-@@ -441,8 +441,6 @@
-
-
- install-data-hook:
-- chown lp $(spooldir)
-- chgrp lp $(spooldir)
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/comms/efax-gtk/files/patch-pthread-include b/comms/efax-gtk/files/patch-pthread-include
new file mode 100644
index 000000000000..96e44cdd4c0f
--- /dev/null
+++ b/comms/efax-gtk/files/patch-pthread-include
@@ -0,0 +1,66 @@
+--- src/efax_controller.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/efax_controller.cpp Sun Jun 27 13:22:32 2004
+@@ -14,9 +14,6 @@
+ #include <sys/wait.h>
+ #include <fcntl.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <fstream>
+ #include <iomanip>
+@@ -30,6 +27,10 @@
+ #include <glibmm/thread.h>
+
+ #include "efax_controller.h"
++
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef HAVE_STRINGSTREAM
+ #include <sstream>
+--- src/fax_list.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/fax_list.cpp Sun Jun 27 13:22:44 2004
+@@ -24,9 +24,6 @@
+ #include <stdlib.h>
+ #include <signal.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <gdkmm/pixbuf.h>
+ #include <gdk/gdkkeysyms.h> // the key codes are here
+@@ -42,6 +39,10 @@
+ #include "dialogs.h"
+ #include "fax_list_icons.h"
+ #include "pipes.h"
++
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef HAVE_STRINGSTREAM
+ #include <sstream>
+--- src/socket_server.cpp.orig Sun Jun 27 13:22:08 2004
++++ src/socket_server.cpp Sun Jun 27 13:22:54 2004
+@@ -20,14 +20,14 @@
+ #include <unistd.h>
+ #include <netdb.h>
+ #include <errno.h>
+-#ifdef HAVE_PTHREAD_SIGMASK
+-#include <pthread.h>
+-#endif
+
+ #include <glibmm/convert.h>
+
+ #include "socket_server.h"
+
++#ifdef HAVE_PTHREAD_SIGMASK
++#include <pthread.h>
++#endif
+
+ #ifdef ENABLE_NLS
+ #include <libintl.h>
diff --git a/comms/efax-gtk/files/patch-src::config.h.in b/comms/efax-gtk/files/patch-src::config.h.in
deleted file mode 100644
index 3955f3cf6303..000000000000
--- a/comms/efax-gtk/files/patch-src::config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/config.h.in.orig Thu Feb 5 21:37:17 2004
-+++ src/config.h.in Mon May 3 11:09:39 2004
-@@ -79,9 +79,3 @@
-
- /* Define to `unsigned' if <sys/types.h> does not define. */
- #undef size_t
--
--/* Define to `unsigned int' if <sys/types.h> does not define. */
--#undef socklen_t
--
--/* Define to `signed int' if <sys/types.h> does not define. */
--#undef ssize_t
diff --git a/comms/efax-gtk/files/patch-src::prog_defs.h b/comms/efax-gtk/files/patch-src::prog_defs.h
deleted file mode 100644
index a7665d118db6..000000000000
--- a/comms/efax-gtk/files/patch-src::prog_defs.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/prog_defs.h.orig Mon May 3 16:44:33 2004
-+++ src/prog_defs.h Mon May 3 16:44:46 2004
-@@ -9,6 +9,8 @@
- #ifndef PROG_DEFS_H
- #define PROG_DEFS_H
-
-+#include <unistd.h>
-+
- #include "config.h"
-
- // deal with any configuration issues arising from config.h