aboutsummaryrefslogtreecommitdiffstats
path: root/comms/ems-flasher
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-04-22 16:43:12 +0800
committerpawel <pawel@FreeBSD.org>2012-04-22 16:43:12 +0800
commit5090384cfa33bd08db89b5eee16fb7a68af46d67 (patch)
treea4514d1fdd8056cccc1c1cd56069497153ea7e46 /comms/ems-flasher
parent8fe8156aa0d04a1c3b2fe3467800516ea41ea727 (diff)
downloadfreebsd-ports-gnome-5090384cfa33bd08db89b5eee16fb7a68af46d67.tar.gz
freebsd-ports-gnome-5090384cfa33bd08db89b5eee16fb7a68af46d67.tar.zst
freebsd-ports-gnome-5090384cfa33bd08db89b5eee16fb7a68af46d67.zip
ems-flasher is software for flashing the EMS Gameboy USB 64 MBit cart.
WWW: http://lacklustre.net/redmine/projects/ems-flash/ PR: ports/166915 Submitted by: Nicole Reid <root@cooltrainer.org>
Diffstat (limited to 'comms/ems-flasher')
-rw-r--r--comms/ems-flasher/Makefile36
-rw-r--r--comms/ems-flasher/distinfo2
-rw-r--r--comms/ems-flasher/files/patch-Makefile17
-rw-r--r--comms/ems-flasher/pkg-descr3
4 files changed, 58 insertions, 0 deletions
diff --git a/comms/ems-flasher/Makefile b/comms/ems-flasher/Makefile
new file mode 100644
index 000000000000..ff9615781f91
--- /dev/null
+++ b/comms/ems-flasher/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ems-flasher
+# Date created: 2012-03-22
+# Whom: Nicole Reid <root@cooltrainer.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ems-flasher
+PORTVERSION= 0.03
+CATEGORIES= comms
+MASTER_SITES= http://lacklustre.net/redmine/attachments/download/10/ \
+ http://update.cooltrainer.org/freebsd-ports/comms/ems-flasher/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= root@cooltrainer.org
+COMMENT= Utility to flash ROM images to the EMS USB 64mb flash cart
+
+LICENSE= MIT
+
+USE_GMAKE= yes
+CFLAGS+= -g -Wall
+LDFLAGS+= -lusb
+USE_GCC= 4.6+
+
+PLIST_FILES= bin/ems-flasher
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+IGNORE= does not compile with the old USB stack
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ems-flasher ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/comms/ems-flasher/distinfo b/comms/ems-flasher/distinfo
new file mode 100644
index 000000000000..55ae958d9243
--- /dev/null
+++ b/comms/ems-flasher/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ems-flasher-0.03.tgz) = d77723a3956e00a9b8af9a3545ed2c55cd2653d65137e91b38523f7805316786
+SIZE (ems-flasher-0.03.tgz) = 7135
diff --git a/comms/ems-flasher/files/patch-Makefile b/comms/ems-flasher/files/patch-Makefile
new file mode 100644
index 000000000000..9f3bbd38d92e
--- /dev/null
+++ b/comms/ems-flasher/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig 2012-03-22 18:15:08.163459495 -0400
++++ Makefile 2012-03-22 18:15:36.050459158 -0400
+@@ -1,13 +1,10 @@
+ PROG = ems-flasher
+ OBJS = ems.o main.o
+
+-CFLAGS = -g -Wall -Werror
+-CFLAGS += `pkg-config --cflags libusb-1.0`
+-
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) -o $(PROG) $(OBJS) `pkg-config --libs libusb-1.0`
++ $(CC) -o $(PROG) $(OBJS) $(LDFLAGS)
+
+ clean:
+ rm -f $(PROG) $(OBJS)
diff --git a/comms/ems-flasher/pkg-descr b/comms/ems-flasher/pkg-descr
new file mode 100644
index 000000000000..090c747a5861
--- /dev/null
+++ b/comms/ems-flasher/pkg-descr
@@ -0,0 +1,3 @@
+ems-flasher is software for flashing the EMS Gameboy USB 64 MBit cart.
+
+WWW: http://lacklustre.net/redmine/projects/ems-flash/