aboutsummaryrefslogtreecommitdiffstats
path: root/comms/flrig/Makefile
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2014-04-12 07:57:16 +0800
committerdb <db@FreeBSD.org>2014-04-12 07:57:16 +0800
commit0bbf62e6b1efdbaa2e619159348a5170d27c95e8 (patch)
tree4ad54446f2b7e20bee0b2375b5d47da31c1f7df9 /comms/flrig/Makefile
parent069b962d97038645209a3b1d942e7b8512351d7b (diff)
downloadfreebsd-ports-gnome-0bbf62e6b1efdbaa2e619159348a5170d27c95e8.tar.gz
freebsd-ports-gnome-0bbf62e6b1efdbaa2e619159348a5170d27c95e8.tar.zst
freebsd-ports-gnome-0bbf62e6b1efdbaa2e619159348a5170d27c95e8.zip
Flrig is a transceiver control program designed to be used either stand alone
or as an adjunct to fldigi. The supported transceivers all have some degree of CAT. The flrig user interface changes to accommodate the degree of CAT support available for the transceiver in use. WWW: http://www.w1hkj.com/flrig-help/index.html PR: ports/188454 Submitted by: Stephen Hurd <shurd@sasktel.net>
Diffstat (limited to 'comms/flrig/Makefile')
-rw-r--r--comms/flrig/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/comms/flrig/Makefile b/comms/flrig/Makefile
new file mode 100644
index 000000000000..fc48d83987ed
--- /dev/null
+++ b/comms/flrig/Makefile
@@ -0,0 +1,35 @@
+# Created by: Stephen Hurd <shurd@sasktel.net>
+# $FreeBSD$
+
+PORTNAME= flrig
+PORTVERSION= 1.3.13
+CATEGORIES= comms hamradio
+MASTER_SITES= http://www.w1hkj.com/downloads/flrig/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= shurd@sasktel.net
+COMMENT= Ham Radio rig control program, cooperates with fldigi
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
+
+USES= gmake
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
+PLIST_FILES= bin/flrig share/applications/flrig.desktop \
+ share/pixmaps/flrig.xpm
+OPTIONS_DEFINE= NATIVE_OPT
+
+NATIVE_OPT_DESC= Enable Native Optimizations
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MNATIVE_OPT}
+CONFIGURE_ARGS+=--enable-optimizations=native
+.else
+CONFIGURE_ARGS+=--enable-optimizations=none
+.endif
+
+.include <bsd.port.mk>