aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gfax
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-01-09 15:02:23 +0800
committermezz <mezz@FreeBSD.org>2005-01-09 15:02:23 +0800
commit1582c611cf26ed3a4298d72e0ce588fe04894999 (patch)
tree34c74403a79b94c15a945b111d68a89920dff25d /comms/gfax
parentf522d894114c012fbbf1531e6fe695fd71aa94b0 (diff)
downloadfreebsd-ports-gnome-1582c611cf26ed3a4298d72e0ce588fe04894999.tar.gz
freebsd-ports-gnome-1582c611cf26ed3a4298d72e0ce588fe04894999.tar.zst
freebsd-ports-gnome-1582c611cf26ed3a4298d72e0ce588fe04894999.zip
Fix the build, but still add it as broke because it doesn't run. It happens
same thing in the Linux world, which gfax needs to catch up with mono and gtk-sharp. PR: ports/75975 Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org> Reported by: pointyhat via kris Approved by: maintainer timeout, no contact from him for weeks
Diffstat (limited to 'comms/gfax')
-rw-r--r--comms/gfax/Makefile2
-rw-r--r--comms/gfax/files/patch-Makefile20
2 files changed, 13 insertions, 9 deletions
diff --git a/comms/gfax/Makefile b/comms/gfax/Makefile
index 8cfecc1cb74a..7ca5e800779b 100644
--- a/comms/gfax/Makefile
+++ b/comms/gfax/Makefile
@@ -24,6 +24,8 @@ USE_GMAKE= yes
USE_REINPLACE= yes
USE_GNOME= gnomeprefix gnomehier libgnomeprint
+BROKEN= "Doesn't run"
+
.include <bsd.port.pre.mk>
MAKE_ENV+= SETENV="/usr/bin/env" \
diff --git a/comms/gfax/files/patch-Makefile b/comms/gfax/files/patch-Makefile
index 9240bed46a3f..f93ec334816e 100644
--- a/comms/gfax/files/patch-Makefile
+++ b/comms/gfax/files/patch-Makefile
@@ -1,20 +1,22 @@
---- Makefile.orig Wed Jun 30 15:27:25 2004
-+++ Makefile Fri Jul 9 01:14:53 2004
-@@ -1,4 +1,4 @@
+--- Makefile.orig Wed Jun 30 18:27:25 2004
++++ Makefile Sat Jan 8 18:54:20 2005
+@@ -1,4 +1,3 @@
-export MONO_PATH=/usr/lib/mono:/usr/lib/mono/gtk-sharp
-+export MONO_PATH=${LOCALBASE}/lib/mono:${LOCALBASE}/lib/mono/gtk-sharp
MCS = mcs /define:DEBUG
#MCS = mcs /define:DEBUGHYLAFAX
-@@ -11,7 +11,6 @@
+@@ -11,9 +10,7 @@
/resource:./pixmaps/gfax.png,gfax.png \
/resource:./pixmaps/send.png,send.png
-
- REFERENCES = -r gnome-sharp -r gtk-sharp -r glib-sharp -r glade-sharp -r gdk-sharp \
- -r gconf-sharp -r gconf-sharp-peditors.dll
+-REFERENCES = -r gnome-sharp -r gtk-sharp -r glib-sharp -r glade-sharp -r gdk-sharp \
+- -r gconf-sharp -r gconf-sharp-peditors.dll
++REFERENCES = $(shell pkg-config --libs gnome-sharp glade-sharp gconf-sharp)
SOURCES = src/phonebook.cs \
-@@ -22,7 +21,7 @@
+ src/gui.cs \
+ src/main.cs \
+@@ -22,7 +19,7 @@
src/fax.cs \
src/hylafax.cs \
src/Settings.cs
@@ -23,7 +25,7 @@
DATE=`date +%y-%m-%d`
all: mono-gfax.exe
-@@ -31,37 +30,43 @@
+@@ -31,37 +28,43 @@
$(MCS) $(RESOURCES) -o $@ $(SOURCES) $(REFERENCES)
schema: